locked
Remote Access problem RRS feed

  • General discussion

  • Hello,

    I have a problem with remote access over the web, I installed WHS on a PC (E6600, 4GB, 320GB) everything works within my home lan.

    The went to setup Remote access and used the wizard which failed with my Linksys E3000 which does not work properly with UPnP.
    So I set the port forwarding to the following (my ISP (Telenet Belgium) blocks all ports belowe 1024):
    • Incoming port 8081 to 4125 to 192.168.1.11 (WHS IP set by DHCP reservation)
    • Incoming port 8082 to 80 to 192.168.1.11
    • Incoming port 8083 to 443 to 192.168.11
    Then set the DNS to http://server.homeserver.com after this I installed the windows phone 7 app and used https://server.homeserver.com:8083 and everything worked over WiFi GPRS/EDGE/3G/HSDPA without any problems on my phone.


    Then wanted to try remote access through the web browser, so tried http://server.homeserver.com:8082 and https://server.homeserver.com:8083 from my Win7 PC in my home network. This all worked fine without any problems.

    Then tried it from another PC (work and girlfriend) but it didn't worked on IE9 and firefox. When I used http://server.homeserver.com:8082 the URL changed after 15 sec to https://server.homeserver.com/remote and showed a blank page.
    Then tried https://server.homeserver.com:8083 and IE said: Internet Explorer could not display this webpage.
    When I try http://server.homese...com:8082/remote I got 403 error.

    So I tried my IE9 on WP7.5 but this also did not work (the WP7.5 My home server does work). Also tried blackberry but the same problem.

    I have tried everything and searched the web but couldn't find any awnser.
    Would could help me?         
    Thursday, October 27, 2011 8:27 AM

All replies

  • Try https://server.homeserver.com:8083/remote, but I don't expect it will work. Port assignments (or the lack) are built into the remote access web app, and are not user-configurable (even by mapping ports in your router).
    I'm not on the WHS team, I just post a lot. :)
    Thursday, October 27, 2011 1:37 PM
  • Also tried that but doesn't work.

    What do you mean by:

    Port assignments (or the lack) are built into the remote access web app

    That adding :8082 or :8083 doesn't work ?

     

    Thursday, October 27, 2011 2:44 PM
  • Exactly. Adding a port in the URL will generally not work, because the URL for a link within in the Remote Access app is fully constructed in the app itself.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, October 27, 2011 3:27 PM
  • Well, I assume WHS 2011 acts as an RD Gateway. . . Is there a way to actually use it as an RD Gateway while the WHS continues to use uPnP?
    Thursday, October 27, 2011 4:26 PM
  • Ah oke, so I will have to change the ports in the WHS and IIS ?

    I googled and someting showed me something similiar. Will test it tonigh when I am home.

    Thursday, October 27, 2011 4:32 PM
  • Ah oke, so I will have to change the ports in the WHS and IIS ?

    I googled and someting showed me something similiar. Will test it tonigh when I am home.


    No, that certainly won't have the desired results. The Remote Access application (not remote desktop) constructs urls with no embedded port (the :8082 on the end of the server name), and when a browser sees that, it assumes port 80. So changing the port in IIS won't help. The client components also use port 80, so changing the port may break those too...

    Really, there's no way to change the ports Windows Home Server 2011 uses.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, October 27, 2011 7:14 PM
  • So when the ISP blocks the ports there is nothing to do with WHS2011 and remote access. The strange thing is that the WP7 app works over the cellphone network.
    Thursday, October 27, 2011 7:39 PM
  • For me, I had problems using AT&T's service until I opened port 3189.  When I did, everything worked correctly.  You might try this.
    Thanks. Paul Carvajal
    Friday, October 28, 2011 2:44 AM
  • Windows Home Server 2011 doesn't use port 3189 for anything. Only ports 80 and 443.
    I'm not on the WHS team, I just post a lot. :)
    Friday, October 28, 2011 4:23 AM
  • Also made a DNS with No-Ip and direct port (http://xxxx.servehttp.com:8082), but still not working. But I can ping this IP from other PC.


    Pingen naar xxxx.servehttp.com [x.xx.xxx.xx] met 32 bytes aan gegevens:
    Antwoord van x.xx.xxx.xx: bytes=32 tijd=160 ms TTL=47
    Antwoord van x.xx.xxx.xx: bytes=32 tijd=161 ms TTL=47
    Antwoord van x.xx.xxx.xx: bytes=32 tijd=160 ms TTL=47
    Antwoord van x.xx.xxx.xx: bytes=32 tijd=161 ms TTL=47

    Ping-statistieken voor x.xx.xxx.xx:
        Pakketten: verzonden = 4, ontvangen = 4, verloren = 0
        (0% verlies).

    De gemiddelde tijd voor het uitvoeren van één bewerking in milliseconden:
        Minimum = 160ms, Maximum = 161ms, Gemiddelde = 160ms

    Friday, October 28, 2011 4:39 AM
  • Sorry fat fingered it - 3389.  This came from the WHS v.1 Technical Brief documentation on Remote Access, in the chapter "Enabling Remote Access".  It says you don't have to forward the port, but in my case, it needed to be for some reason.  It didn't work until I did it.


    Thanks. Paul Carvajal

    Saturday, October 29, 2011 4:26 AM
  • I have tried that with no succes, when I connect my phone to wifi I can access the remote access webpage
    Sunday, October 30, 2011 8:57 AM
  • Hi,
    Till now I had no change to try it outside, with your ISP (Telenet), but I can reach my server from a outside VDSL line with ISP Belgacom, using https//....homeserver.com:8081
    Only thing I have done: forwarding both ports 8081 and 8443 in my apple time capsule to the server's IP, and given access to this ports in Windows firewall inside WHS2011.
    The servers IP is not DHCP installed but has a fixed IP in the 192.168....... range.
    Tried also to reach my server from the gprs network with Base, on iPhone and it works as charm, only using the adress without adding the port.
    Same for reaching the server with a Blackberry, no problems.
    Would like to try it also with Telenet ISP from outside, but don't now anybody in my neighbourhood.
    Sunday, October 30, 2011 7:35 PM
  • That is samething I have done, but doesn't work for me.

    Sunday, October 30, 2011 7:44 PM
  • Maybe its something wrong with the forwarding in your router.

    I report you next wednesday evening, I try from work with Telenet to reach my server. If its working as with Belgacom, then it must be your router.

    I can't see any difference between Telenet and Belgacom ISP's. Both are blocking beneath 1024



    • Edited by timmermc Sunday, October 30, 2011 8:22 PM
    Sunday, October 30, 2011 8:21 PM
  • I'm now able to access my Linksys router webpage from my work at port 8085, with http://xxxx.homeserver.com:8085

    The WHS still no succes, I have shut down my firewall in de WHS and enabled DMZ in the router.

    Tuesday, November 1, 2011 7:50 AM
  • I have now added https:// port 8083 to the IIS default website this works. This does not work for http:// 8082
    Tuesday, November 1, 2011 9:02 PM
  • I have now added https:// port 8083 to the IIS default website this works. This does not work for http:// 8082

    Indeed, thats the way I added the port also in IIS. Now I always connect thru https://...... homeserver.com:8443

    Glad you made it finally!! Microsoft and our ISP's make it all so simple...

    Tuesday, November 1, 2011 9:31 PM
  • heb je de bindings nagekeken op uw iis
    kijk zeker dat er geen twee websites zijn die op de  zelfde poort staan,
    kijk ook na of de firewall van uw whs de poorten die u wil gebruiken er in staan.

    ik heb gewoon bij de bindings waar https staat poort 4443 bijgezet
    en bij http poort 80  8090 en ook de hostname ingevuld   ****.homeserver.com de test knop zal niet werken omdat die altijd op poort 80 zal proberen.

    Tuesday, November 1, 2011 9:42 PM
  • Klop dat had ik ook niet, maar als je de huidige poorten wijziged werkt de launchpad niet meer maar ook My Home Server niet meer.

    The only problem now is that the normal http site doesn't work because it automatically switches over to https. But Https doesn't work at my workplace.

    • Edited by The-Raver Wednesday, November 2, 2011 7:37 AM
    Wednesday, November 2, 2011 6:43 AM
  • Klop dat had ik ook niet, maar als je de huidige poorten wijziged werkt de launchpad niet meer maar ook My Home Server niet meer.

    The only problem now is that the normal http site doesn't work because it automatically switches over to https. But Https doesn't work at my workplace.

    Probably ports are blocked at your workplace, many companies are doing this. Have you tried with extension https://servername.homeserver.com:8083 (I guess you used this number)

    But if your 'work' is blocking ports (ask the IT manager) then you will not be able to make a connection, not http or https, even if you try other ports. Be happy you still can use Facebook (hope so!).

    • Edited by timmermc Wednesday, November 2, 2011 8:17 PM
    Wednesday, November 2, 2011 8:12 PM
  • I could access my router on http port 8085 from my work, but https and port8085 did not work.
    So that is why I want the WHS to work with http.

    But then again gmail also uses https and works perfectly (and all the other site like fb, youtube).


    • Edited by The-Raver Thursday, November 3, 2011 6:49 AM
    Thursday, November 3, 2011 6:48 AM