locked
Apple's itunes cause registry error? RRS feed

  • Question

  •  Hi,

    About a week ago something strange happened to my computer for the first time in a long time, it's a custom built computer with multiple hard drives and optical drives with 4 GBs of high performance memory that is about 3 years old, it has always ran Vistas with no issues that couldn't be easily resolved. However one day when I rebooted my computer after installing the newest version of itunes windows refused to boot instead giving me the option to either start up in safe mode or try to repair the problem. It indicated probably a hardware change may have cause the issue. Neither of the options worked. After giving up on it for the night, I turned off the computer. The next day when I booted it up and select normal mode it loaded up, albeit extremely slowly. However I noticed that day that it was not updating and I got a pop up saying I maybe a victim of piracy. While trying to investigate why this had pop up I notice my control panel would not load up, my printer had cease to also work, and update was not updating new files. All my other programs ran fine, including the latest games such as Dawn of War II.

    I tried using One Care Beta scanner to try to resolve it, it found a enormous number of registry errors but for whatever reason would not fix it. Norton 360 scans also came up negative on malicious software. Also I checked Genuine Validation page to try to fix, however I could not get pass beyond going to my cmd.exe program and typing the command net start slsvc, it would say that does not exist. So, given we live in the age of the internet I googled the issue and found this forum. After reading through other similar issues posted and trying out those solutions to no avail, I tried "Fix for Software Licensing Service has Stopped" on some Vista 64bit systems. I didn't check that topic initially as it did not sound like it matched my issue, however after trying the solution of copying and pasting the contents of the registry file and create a new one on notepad, everything is now restored to how it was.

    The only changed I made to my computer before this issue developed was updating my itunes from version 7 to the latest version 8 and rebooting my computer.
    Wednesday, February 25, 2009 3:04 AM

Answers

  • Hi Endsong,

      itunes is widely used (i use it) and I haven't seen any problems associated with updating it. My feeling is that the issue just happen to occur at the same time as installing itunes.

      Now, just to confirm, your issue was resolved by doing the fix found in the "Fix for 'Software Licensing Service has Stopped' on some Vista 64bit systems" thread?

      If so, then the issue was that the registry entry that tell Vista where the slsvc.exe file is located (the slsvc.exe file runs the Software Licensinf Service) was deleted or corrupt.  we have seen this normaly caused by some Registry Cleaner programs, but could also occur form random corruption, malware, failing hard drive or a bad sector on the hard drive.

      The fact that the One Care Beta scanner found a number of registry errors makes me think that either malware, hard drive issue or random corruption was to blame. 

      If you don't see any more problems, I assume the issue is resolved.  


      If I have misunderstood your post and your issue is still occuring, please post a Diagnostic Report and I will see what we can do to resolve the issue.

    Thank you,
    Darin MS
     
    Attention Forum All Users: Please Do Not post your issue in someone else's Thread...Create your own.
    • Proposed as answer by Darin Smith MS Wednesday, February 25, 2009 10:06 PM
    • Marked as answer by Darin Smith MS Friday, March 6, 2009 11:28 PM
    Wednesday, February 25, 2009 9:56 PM