Error: Your registry settings were not copied correctly ... RRS feed

  • Question

  • I'm working on a Windows 7 64-bit machine. I've got MP 2010 installed. I'm developing an application using Visual Studio 2010 utilizing a SQL Server 2005 database. Running through code the program works fine. Everything does exactly as it should. In the Form_Load procedure, I have any errors writing to a text file. When I compiled the application (using VS 2010 Setup and Deploy or whatever it's called), it gave me a warning to make sure all dependencies for MapPoint were included. When I run the compiled application, I get two errors (one written in the Form_Load procedure) and a dialogbox error. The written error I get is:

    "MapPoint network files cannot be accessed at this time."

    However, the dialogbox shown on the screen says:

    "Your registry settings for this application were not copied correctly. To correct these settings, run Setup again for this application from the location where you originally installed it."

    The caption/title/text of the dialogbox is "Microsoft MapPoint." In addition to that error message, on my taskbar, you see the Microsoft MapPoint icon.

    I have uploaded two screenshots, one of the dialogbox and one of the icon. There are located here:

    Dialog Box Screenshot

    Taskbar Icon Screenshot

    I did a Google search for the registry settings error but that didn't return any useful information (that I could find). A lot of that was people having problems launching MapPoint itself. I can run MapPoint on this machine with no problems. It's when using it in my application that it becomes an issue.

    Has anyone else encountered this error? Is there something I need to change in my compile? I have it set up to run with highest level access and have set Compatibility to be run as XP SP3 and as Administrator. Should that be changed? I couldn't find the "dependencies" that MapPoint requires but when a friend tried compiling this using InstallShield (and running the program through IS to get all the dependencies, his compiled application showed the exact same dialogbox error as mine.

    I'm not sure if this is important but I'll include it anyway. I reference two maps in my program. One is the "main" map (which is used for displaying the pushpins, etc.). The other is a "temp" map which is never visible. I use this map to run calculations on, get data returned, etc. This way the "display" map isn't used for that and always stays "clean." I declare both as global variables like this:

    Friend objMap As MapPoint.Map
    Friend objTmpMap As MapPoint.Map

    Then, on the main form, here is how I create the default view of the map (using settings from a config file):

    With AxMappointControl1
      '  open a North American map
      '  set the map object to the current map
      objMap = AxMappointControl1.ActiveMap
      objMap.MapStyle = MapPoint.GeoMapStyle.geoMapStyleTerrain
      '  set the font to the smaller size
      objMap.MapFont = MapPoint.GeoMapFont.geoMapFontSmaller
      .Units = MapPoint.GeoUnits.geoMiles
      If oConfig.MapCenterPointLatitude <> 0 AndAlso _
          oConfig.MapCenterPointLongitude <> 0 Then
        objLoc = objMap.GetLocation(oConfig.MapCenterPointLatitude, oConfig.MapCenterPointLongitude)
      End If
      If oConfig.MapDefaultAltitude <> 0 Then
        objMap.Altitude = oConfig.MapDefaultAltitude
        objMap.Altitude = 5715
      End If
      If oConfig.MapDefaultStyle <> -1 AndAlso _
          oConfig.MapDefaultStyle <= 6 Then
        objMap.MapStyle = oConfig.MapDefaultStyle
      End If
    End With
    I added the MapPoint control to the form by first adding it to the ToolBox and then dragging it and sticking it in a panel.

    Thank you in advance for any and all help/suggestions/instructions/etc that you can give. Any and all help is very much appreciated.

    • Moved by Chao Kuo Monday, November 8, 2010 9:28 AM Map point issue. (From:Visual Basic General)
    • Moved by Sheng Jiang 蒋晟 Sunday, December 15, 2013 4:13 PM
    Friday, October 15, 2010 6:59 PM


All replies