locked
Sync Services in .NET 3.5 RRS feed

  • Question

  •  

    Does anyone know if Sync Services was released as part of .NET 3.5?  I uninstalled my beta of Sync Services and installed .NET 3.5 this morning and everything broke.  Looks like I didn't have the Microsoft.Synchronization.Data assemblies in the GAC.  I reinstalled the beta of Sync Services and everything worked fine, I also wasn't warned that I was installing an older version over a new version (I still have .NET 3.5 on).

     

    Was Sync Services not included in 3.5?  Were the namespaces changed?  Also, does anyone know off hand if .NET 3.5 will be pushed out as a recommended update or an optional update?

     

    Thanks!

    Jeremy

    • Moved by Max Wang_1983 Friday, April 22, 2011 9:42 PM forum consolidation (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Tuesday, November 20, 2007 4:20 PM

Answers

  • Hi Jeremy,

     

    Sync Services is not part of .NET framework. Thus it is not releasing with .NET 3.5. The first version of Sync Services for ADO.NET has shipped with VS 2008. It should be also released as a standalone package that you can install on any machine, it requires .NET 2.0 or above to work. The next version will be bundled with Microsoft Sync Framework as it is part of it.

     

    Thanks

    Tuesday, November 20, 2007 6:12 PM

All replies

  • Hi Jeremy,

     

    Sync Services is not part of .NET framework. Thus it is not releasing with .NET 3.5. The first version of Sync Services for ADO.NET has shipped with VS 2008. It should be also released as a standalone package that you can install on any machine, it requires .NET 2.0 or above to work. The next version will be bundled with Microsoft Sync Framework as it is part of it.

     

    Thanks

    Tuesday, November 20, 2007 6:12 PM
  • Thanks!

     

    Tuesday, November 20, 2007 6:42 PM