none
problems linking fortran 90 code with ms mpi RRS feed

  • Question

  • hi,
    I installed microsoft compute cluster pack and there is no msmpif.lib or any other fortran library.
    I used msmpi.lib and It returns that "check your include directories: module [mpi]"
    It is said that msmpi works for fortran90 too.
    please help me out

    Regards
    Parsa
    • Moved by Josh Barnard Tuesday, May 19, 2009 8:18 PM Not scheduler related (From:Windows HPC Server Job Submission and Scheduling)
    Tuesday, May 19, 2009 11:05 AM

Answers

All replies

  • Hi Parsa,

    are you using Microsoft Compute Cluster Server (v1) or the Windows HPC Server (v2)?


    if you are using MSMPI sdk (v2), you need to link with msmpi.lib plus one of the fortran libraries.

    The msmpifec.lib supports compiling where the fortran compiler puts string length at the end of the parameter stack (most common case).
    The msmpifms.lib supports compiling where the Fortran compilers puts the string length right after the string pointer on the parameter stack (mixed).

    I assume that you are building for x64 target.

    Thanks,
    .Erez
    Saturday, May 23, 2009 4:06 AM
  • Parsa, were you able to get your app working?
    Thursday, June 25, 2009 11:20 PM
    Moderator
  • First, you need to include "mpi.f90" (which is from the default hpc 2008 Inc directory) in your source code and manually compiled it.

    It will generate "mpi.mod", then your "use MPI" will work and HPC 2008 could build a FORTRAN 90 solution.

    PS. I noticed that if you use "include 'mpif.h' " instead of "use MPI", your source file could compile. However, it could not be built and linked.

     

    Hope it helps

    wicwawa

    Monday, November 8, 2010 1:50 AM