none
"RenderCapability.Tier" reports 0 with Nvidia Quadro M2000M?! RRS feed

  • Question

  • Hello everyone,

    The title says it all. I was noticing some pretty bad 3D performance with my WPF application so I checked "RenderCapability.Tier" and to my surprise it's reporting "0". This is a brand new 64-bit Windows 10 machine (Dell Precision 7510 laptop) sporting an Nvidia Quadro M2000M with driver version 369.30 that supports DirectX v12. Can anyone hazard a guess as to why WPF is using software rendering? Thanks in advance!

    -L

    Thursday, May 11, 2017 12:28 AM

All replies


  • Hi LKeene,

    As far as I know, WPF hardware acceleration is not required to open, the developer only needs to determine whether the current system to support hardware acceleration to determine what UI rendering.

    We can use the following code to choose different code routs to render the UI.

        // The rendering tier corresponds to the high-order word of the Tier property. 
                int renderingTier = (RenderCapability.Tier >> 16);
                if (renderingTier == 0)
                {
                  // Hardware acceleration is not supported
                  // To ensure the smooth sacrifice some UI features
                }
                else if (renderingTier == 1)
                {
                    //Support  partial hardware acceleration
                    //***
                }
                else
                {
                     //Support hardware acceleration
                     //***
                }
    


    RenderCapability.Tier Property:
    https://msdn.microsoft.com/en-us/library/system.windows.media.rendercapability.tier%28v=vs.110%29.aspx?f=255&MSPPError=-2147217396

    Hardware Acceleration in WPF:
    http://blogs.microsoft.co.il/janiv/2009/06/07/hardware-acceleration-in-wpf/


    Also, If you think it is a bug, I suggest you can report your question at Connect:
    https://connect.microsoft.com/

    Or, You can also visit the Nvidia Support and report your question:
    http://www.nvidia.com/object/support.html


    Best Regards,

    Yohann Lu



    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, May 11, 2017 6:34 AM
  • I'm afraid you've misunderstood my question Yohann. I am able to check the rendering tier. What I don't understand is why my computer is not using the GPU. Here are things that I've tried so far:

    1) Disconnect the laptop from the external monitor, just in case the combined monitor real estate was too large for the texture buffer. Still reporting as rendering tier 0.

    2) In the device manager window under "Display adapters", disable the "DameWare Development Mirror Driver". Still reporting as tier 0.

    Does anyone have any other suggestions of things I can try?

    -L

    Thursday, May 11, 2017 6:15 PM
  • Hi LKeene,

    According to your further description, I suggest you can use the following ways to getting suitable.

    You can report your question at Connect:
    https://connect.microsoft.com/

    Visit the Nvidia Support and report your question:
    http://www.nvidia.com/object/support.html

    Your understanding and cooperation will be grateful.

    Best Regards,

    Yohann Lu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, May 12, 2017 2:40 AM