none
Debugging MPI app in VS2010 RRS feed

  • Question

  • Having some trouble MPISHIM. Everytime I run a debug on my MPI app, I get the following:

    MPISHIM: Command line incomplete.  USAGE: mpishim100.exe PortNumber ComputerName

    MPISHIM: Command line incomplete.  USAGE: mpishim100.exe PortNumber ComputerName

    MPISHIM: Command line incomplete.  USAGE: mpishim100.exe PortNumber ComputerName

    I'm currently running Win7 x64, and using Intel MPI.

    Thursday, February 9, 2012 12:13 PM

All replies

  • Hello,

    Please write a command that you use. Such an error means that there is a mistake in command arguments or something important is missing.

    Friday, February 10, 2012 3:36 PM
  • I press F5, vs automatically generat mpishim.bat:

    @echo off

    @rem cmdLine will store the arguments to this bat file, without the first two arguments.
    @rem The first two arguments are the mpishim path and the computer name. Those arguments
    @rem are already in the string below.
    set cmdLine=
    shift
    shift
    :VarLoop
      if (%1)==() goto VarLoopEnd
      set cmdLine=%cmdLine%%1
      shift
    goto VarLoop
    :VarLoopEnd

    "mpiexec.exe" -n 1 -wdir "c:\users\sheng\documents\visual studio 2010\Projects\test\Debug\Sheng\test"  "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x86\mpishim100.exe" 5521 127.0.0.1

    But before last time I reinstall my computer, there's nothing wrong. If I rewrite it:

    "mpiexec.exe" -n 1 -wdir "c:\users\sheng\documents\visual studio 2010\Projects\test\Debug\Sheng\test"  "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x86\mpishim100.exe 5521 127.0.0.1"

    the debugger can start well. I want to konw how can I only press F5 to start debugger correctly as usual. Maybe I need change some setting on my computer.

    Thanks.

    Saturday, February 11, 2012 4:20 AM
  • Hello,

    I don't know exactly what type of error is this, but i see the difference between two commands:

    "mpiexec.exe" -n 1 -wdir "c:\users\sheng\documents\visual studio 2010\Projects\test\Debug\Sheng\test"  "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x86\mpishim100.exe" 5521 127.0.0.1

    "mpiexec.exe" -n 1 -wdir "c:\users\sheng\documents\visual studio 2010\Projects\test\Debug\Sheng\test"  "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x86\mpishim100.exe 5521 127.0.0.1"

    Please provide the sequence of steps when you setting up MPI on your workstation.

    Monday, February 13, 2012 2:42 PM