locked
Data Imports in CRM 2011 - Lookups RRS feed

  • Question

  • Hi,

    I have a bunch of contacts that I want to import. One of the columns in my source file is called Account Name which contains the parent account name. When I try to map this in the data import wizard I select Parent Customer and then a dialog box appears asking me to select the Related Record Type (either Account or Contact). If I select Account I am still unable to select the Referred Field as this is greyed out as is the OK button.

    Any ideas much appreciated.

    Here's a link to the screenshot;

    http://www.flickr.com/photos/66807474@N00/5527116550/

    Regards

    Shaun

    Tuesday, March 15, 2011 8:36 AM

Answers

  • Followed up offline with Shaun and tried a workaround for this issue. Publishing it here in case others run into similar issues. The workaround essentially consists of exporting the map and inserting lookup mappings manually. The steps are:

    1.       Map rest of the fields and try a dummy import. Leave the “Account Name” field unmapped. Make sure that you include a name for the new map.

    2.       Locate the map in Settings->Data Management->Data Maps

    3.       Select the Map and click export. Save the exported file.

    4.       Open up the file in a text editor.

    5.       Insert a new mapping for the “Account Name” OR “Company Name” field (whichever is in your source CSV file). This xml section should be inserted with the rest of the AttributeMap nodes.

     

    <AttributeMap>

    <SourceAttributeName>Company Name</SourceAttributeName>

    <TargetAttributeName>parentcustomerid</TargetAttributeName>

    <ProcessCode>Process</ProcessCode>

    <LookupMaps>

    <LookupMap>

    <LookupEntityName>account</LookupEntityName>

    <LookupAttributeName>name</LookupAttributeName>

    <LookupType>System</LookupType>

    <ProcessCode>Process</ProcessCode>

    </LookupMap>

    </LookupMaps>

    </AttributeMap>

     

    6.       Save the file and reimport the map with a new name.

    7.       Use the map for subsequent Imports.

     

    • Proposed as answer by AmitNeo Wednesday, March 16, 2011 6:57 AM
    • Marked as answer by Donna EdwardsMVP Saturday, June 11, 2011 3:19 AM
    Wednesday, March 16, 2011 6:57 AM
  • The easiest way to make sure your Lookup mappings work (without editing the import map XML) is to name the CSV column exactly as per the Display Name of the corresponding Lookup attribute in CRM.

    So, for the Parent Account of a Contact, name the Company column 'Parent Account' - the Data Import wizard will map it automatically exposing and enabling the Entity/Attribute mapping dialog that would otherwise have been greyed out (disabled).


    --pogo (pat) @ pogo69.wordpress.com
    Wednesday, June 8, 2011 7:30 PM

All replies

  • Hi Shaun,

    It's not very clear from the screenshot which fields are disabled. Can you send over a sample file that you are trying to Import? I can try and reproduce the issue locally then.

    Please send the files to amitneo (at) microsoft (dot) com

    Thanks,
    Amit

    Tuesday, March 15, 2011 9:19 AM
  • Followed up offline with Shaun and tried a workaround for this issue. Publishing it here in case others run into similar issues. The workaround essentially consists of exporting the map and inserting lookup mappings manually. The steps are:

    1.       Map rest of the fields and try a dummy import. Leave the “Account Name” field unmapped. Make sure that you include a name for the new map.

    2.       Locate the map in Settings->Data Management->Data Maps

    3.       Select the Map and click export. Save the exported file.

    4.       Open up the file in a text editor.

    5.       Insert a new mapping for the “Account Name” OR “Company Name” field (whichever is in your source CSV file). This xml section should be inserted with the rest of the AttributeMap nodes.

     

    <AttributeMap>

    <SourceAttributeName>Company Name</SourceAttributeName>

    <TargetAttributeName>parentcustomerid</TargetAttributeName>

    <ProcessCode>Process</ProcessCode>

    <LookupMaps>

    <LookupMap>

    <LookupEntityName>account</LookupEntityName>

    <LookupAttributeName>name</LookupAttributeName>

    <LookupType>System</LookupType>

    <ProcessCode>Process</ProcessCode>

    </LookupMap>

    </LookupMaps>

    </AttributeMap>

     

    6.       Save the file and reimport the map with a new name.

    7.       Use the map for subsequent Imports.

     

    • Proposed as answer by AmitNeo Wednesday, March 16, 2011 6:57 AM
    • Marked as answer by Donna EdwardsMVP Saturday, June 11, 2011 3:19 AM
    Wednesday, March 16, 2011 6:57 AM
  • I am running into the same issue, while editing the Import map is a valid work-around it is a very time consuming process compared to just using the UI as intended. Are there any fixes for this issue?
    Wednesday, June 8, 2011 4:15 PM
  • The easiest way to make sure your Lookup mappings work (without editing the import map XML) is to name the CSV column exactly as per the Display Name of the corresponding Lookup attribute in CRM.

    So, for the Parent Account of a Contact, name the Company column 'Parent Account' - the Data Import wizard will map it automatically exposing and enabling the Entity/Attribute mapping dialog that would otherwise have been greyed out (disabled).


    --pogo (pat) @ pogo69.wordpress.com
    Wednesday, June 8, 2011 7:30 PM