none
Can't upload an avitar image RRS feed

  • Question

  • I've tried bmp and jpg, both under 1MB, several times in the past 24 hrs and the page refreshes but nothing happens.

    ??
    Mike, Bristol UK.
    Saturday, March 15, 2008 8:17 PM

Answers

  • I cannot reproduce this issue using the url to the jpeg above. Have you tried all the steps Bryan mentioned? There is a latency issue where changing or uploading an avatar may not be noticable for a while (based on cache), maybe this is what you are seeing?
    Brent Serbus STO Forums Program Manager
    Tuesday, March 25, 2008 9:24 PM
    Answerer

All replies

  • I just tried this today and it seems to work if I sign-out and back in. Can you try that?

    rholzli
    Sunday, March 16, 2008 7:04 PM
  • Mike,
    It sounds like the upload is not working properly for you, can you upload the image you want somewhere and post a link?


    Rick,
    We set a 15 minute expires header on avatars, which means that your browser will hold onto a person's avatar for 15 minutes before requesting that image again. We did this for two reasons:

    1. It makes browsing the forums a lot faster for a lot of users
    2. It keeps our SQL Servers from bogging down (avatars are currently store in a database.) We're planning a file based system to replace this.

    We attempt to expire your old avatar right away, but the worse case scenario is that it could take up to 15 minutes to get a new one. In IE you can get around this by pressing CRTL + F5, this tells IE to ignore expiry information and get everything fresh. You could also try deleting your temporary internet files.

    Thanks,
    Bryan


    Dev Lead :: Server and Tools Online
    Monday, March 17, 2008 4:43 PM
  • Hi Bryan

    How about this?

    http://mikeotaylor.googlepages.com/mikeblog.jpg/mikeblog-full.jpg

    Many thanks
    Mike, Bristol UK.
    Tuesday, March 18, 2008 10:47 AM
  • Thanks Rick

    I already tried all of that kind of thing - signing in and out, refreshing ...
    Mike, Bristol UK.
    Tuesday, March 18, 2008 10:49 AM
  • I cannot reproduce this issue using the url to the jpeg above. Have you tried all the steps Bryan mentioned? There is a latency issue where changing or uploading an avatar may not be noticable for a while (based on cache), maybe this is what you are seeing?
    Brent Serbus STO Forums Program Manager
    Tuesday, March 25, 2008 9:24 PM
    Answerer
  • Still no joy. I dunno what's wrong. Who needs one anyway.

    Thanks for your interest.
    Mike, Bristol UK.
    • Edited by MIKE1552526 Thursday, March 27, 2008 2:44 PM I forgot to say thanks.
    Thursday, March 27, 2008 2:43 PM
  • Mike,

    try to resize your image to 44 x 44  or lower and then upload it and sign-out and back in that should work.

    Feddly
    Feddly Jeanniton
    Thursday, April 10, 2008 4:49 AM
  • Feddly et al.

    I'm having the same issue as Mike. I'm waiting to see if it's the cache, but I've tried uploading a 44x44 version of an avatar, logging out and relogging in. Now I'm stumped.

    Here's roughly the avatar I was using -- (the Big Lebowski).
    http://lcpericas.googlepages.com/imagyhes.jpg/imagyhes-full.jpg

    I'm uploading it from a drive other than the C drive.

    Any more ideas?

    Thanks.

    a.k.a.
    • Edited by a_k_a Thursday, May 8, 2008 11:42 PM Missspeling
    Thursday, May 8, 2008 11:41 PM
  • Ok, it's the cache.

    Once you see a forum post on this issue, then you start to get prematurely frustrated.

    *Sigh.* But now I'm better.

    Thank yous all around.

    a.k.a.
    Thursday, May 8, 2008 11:45 PM
  • This issues has been fixed. Once you upload an avatar everyone should see it right away. Avatars are now being cached in geographic content delivery networks.
    Dev Lead :: Server and Tools Online
    • Proposed as answer by Bryan Thomas Wednesday, September 10, 2008 6:40 PM
    • Edited by Bryan Thomas Wednesday, September 10, 2008 6:40 PM
    Wednesday, September 10, 2008 6:40 PM
  • Thank goodness! That's a relief. The long wait was really confusing me in the former release, and it didn't change even after hitting the refresh button seven times.

    Web Designers for Obama/Biden 08.
    • Edited by Oliver Black Wednesday, September 10, 2008 11:54 PM Edit
    Wednesday, September 10, 2008 11:53 PM