locked
Install: Unable to register Remote Desktop Control RRS feed

  • Question

  •  

    I have a WHS set up at our small business, working successfully backing up several Win XP Pro machines.  We have one machine that has trouble when installing the connector software.  As soon as we try to launch the setup.exe, whether from the CD or through the network, we get a box pop-up that says, "Unable to register Remote Desktop Control"

     

    I believe that XP Home should be supported, though I recall that one of the things that Home is missing is the Remote Desktop feature.

     

    I have worked through multiple troubleshooting pages and searched the forums here but don't see any information on this error.  As far as I can tell, the PC sees the server over the network just fine, and several other PCs have been set up with the connector software and are working just fine, though they are all running XP Pro.

     

    I am running on a home-built WHS using the OEM release, and I just upgraded from the CTP version.  This XP Home PC has never been working, and it seems like we may have seen this same error message when we tried to install it on the pre-release version.

     

    Has anyone else seen this problem?  Thanks,

    Tuesday, December 11, 2007 12:13 AM

Answers

All replies

  • XP Home doesn't support Remote Desktop server, so you can't RD into an XP Home machine, but you should be able to RD into the server from one (as that's using the RD client software).

     

    I don't remember seeing that message when I installed the connector on an XP Home machine here, but that was the original OEM release and it may be that behaviour has changed with the update. Does install terminate, or are you able to complete successfully otherwise?

     

    Is this machine running some different AV software or running a different firewall?

     

    Tuesday, December 11, 2007 12:52 AM
  • Can you please post complete error message, or confirm that you've already done so?

     

    Are you logged in with an account that has Administrator rights on the LOCAL system?

    Tuesday, December 11, 2007 12:54 AM
    Moderator
  • The installation does not complete, in fact it seems to be stopped dead in its tracks.  The complete error message I recieve is:

     

    "Unable to register Remote Desktop Control"

     

    as a pop-up box when I first double-click Setup.exe to install the connector software.

     

    I am not try to use remote desktop, just install the basic connector software so that I can back up this XP Home machine.

     

    Yes, the user is logged in as an administrator. 

    Tuesday, December 11, 2007 8:21 PM
  • The machine is running a Macafee anti-virus, but I've tried to disable it and get the same message.  Also I believe the macafee firewall is disabled and the windows firewall is on.  I don't think i'm having a firewall problem because I can access the server just fine from this machine.  I've worked through a trouble-shooting guide related to firewall and name-resolution issues and had no problems completing the trouble-shooting steps there.

     

     

    Tuesday, December 11, 2007 8:24 PM
  • I don't think this is a firewall problem, but something blocking the install, either AV or some configuration on that PC. When you say you've tried to disable it, do I take that to mean that you weren't necessarily successful? Do you have any other "security" software on that machine?

     

    Can you run CHKDSK /F on this machine to make sure there are no issues on the local drive. (Do this my opening Start > Programs > Run and entering CMD to open a command window). You'll then get a message saying it can't lock the drive and ask if you want to do ths next time you restart. Type Y <enter> and restart the machine when ready.)
    Tuesday, December 11, 2007 8:42 PM
  • > do I take that to mean that you weren't necessarily successful?

     

    yes...he had disabled everything he could within mcafee.  now we've completely blown it away and rebooted and we're getting the same error

     

    he is going to run chkdsk /f and reboot when he leaves tonight

    Tuesday, December 11, 2007 11:44 PM
  • Solved!  I found a clue when I right-clicked on 'My Computer', selected Manage, and got 'Access Denied'

     

    Found some things to try here:

     

    http://www.winhelponline.com/articles/43/1/Error-Access-is-Denied--while-selecting-Manage-from-the-My-Computer-context-menu.html

     

    It turned out that the %windir% environment variable was not defined, so we set that to C:\Windows and not only could we right-click to bring up Computer Management, but the WHS Connector software installed smooth as a whistle.

     

     

    Tuesday, December 18, 2007 7:05 PM
  • Very useful info, thanks for sharing this and good detective work!!

    Tuesday, December 18, 2007 10:21 PM