locked
Live Search is excluding WWW from domain name search results. RRS feed

  • Question

  • I've got two issues that have been driving me up the wall and I'm hoping someone here can help. My wife's cake decorating site, www.coveredwithicing.com isn't being crawled properly. What is happening is that all of the results that Live Search displays don't show the www, only the domain name. I've got a redirect on the site so that if someone clicks the links it goes back to the www like it should, but that doesn't seem to help.

     

    For proof of what's happening, do a site search on the domain name (site:coveredwithicing.com) and then do one with the www in it (site:www.coveredwithicing.com). The later only shows three results, all from her blog. Shouldn't all results show the www?

     

    The second issue is Live's bot only crawls once a month or so and I have other sites that are hosted on the same server that are crawled almost daily. Shouldn't www.coveredwithicing.com be crawled just as frequently as the others, www.tennesseeriver600.com for example?

    Wednesday, January 21, 2009 7:56 PM

Answers

  • Hi MGD,

    I sent  this off to the redirect/ relevance team to look at. As soon as I have an update I will let you know.


    Brett 
    Program Manager, Live Search Webmaster Tools
    • Marked as answer by Brett Yount Wednesday, February 25, 2009 5:49 PM
    Wednesday, February 11, 2009 11:37 PM

All replies

  • Hi MGD King,

     

    What type of redirect are you using? regular 301? If you are using .htaccess are you using mod_rewrite?  I ask because we do have issues with them from time to time. Although I am not saying that this is the case here, it is a possibility. As far as crawl times go, they very greatly dependent on site rank. Your other sites might have a higher rank and so are crawled more frequently. I noticed you have the <changfeq> date on the sitemap set to monthly. You might try setting the date to daily and resubmit the sitemap to our tools.

     

     

    Brett

     

    Wednesday, January 21, 2009 10:53 PM
  • Hi Brett. Thanks for taking the time to look into this for me.

     

    I'm using .htaccess with the following code in it:

     

    Code Snippet

    RewriteEngine on

    #Redirect http://coveredwithicing.com to http://www.coveredwithicing.com
    RewriteCond %{HTTP_HOST} ^coveredwithicing.com
    RewriteRule ^(.*)$ http://www.coveredwithicing.com/$1 [r=301,L]

     

     

    And it appears to be working fine when clicking on a link that doesn't contain the www in it.

     

    I will set the date in the sitemap and resubmitt to see if that helps. I'll keep you posted.

     

     

    Thursday, January 22, 2009 5:06 PM
  • Thanks for getting back to me. It seems fairly straight forward. I'll take a closer look. This might take a little longer to see if there is anything we can do, but I'll keep you posted.

     

     

    Brett

     

    • Unmarked as answer by MGD King Thursday, February 5, 2009 10:23 PM
    Thursday, January 22, 2009 10:29 PM
  • Brett,

    It appears that it's back to doing what it was doing before, and now there's a 404 Error listed in the "Crawl Issues" portion of the Webmasters tools referring to a http://www.coveredwithicing.com/$1 link that it can't find. The only thing that triggers my memory of seeing http://www.coveredwithicing.com/$1 is in the 301 Rederict in my .htaccess file. Any ideas?
    Thursday, February 5, 2009 10:26 PM
  •  Now when performing a search for site:www.coveredwithicing.com, www.coveredwithicing.com/$1 is displayed. Why is that and how can I prevent it.
    Tuesday, February 10, 2009 3:47 PM
  • Hi MGD,

    I sent  this off to the redirect/ relevance team to look at. As soon as I have an update I will let you know.


    Brett 
    Program Manager, Live Search Webmaster Tools
    • Marked as answer by Brett Yount Wednesday, February 25, 2009 5:49 PM
    Wednesday, February 11, 2009 11:37 PM
  • Hi,

    I looked at the results today and I couldn't find the offending URL, so it looks like it was fixed. I am still waiting on the redirect issue and why it is not registering www for your home page.


    Brett
    Program Manager, Live Search Webmaster Tools
    Wednesday, February 25, 2009 5:53 PM