locked
P2P file sync RRS feed

  • Question

  • I've got a issue with only being able to transfer folder structure and wlx files when not syncing to the Live Desktop.
    It seems that this issue has cropped up late 2008, but there's no real concrete answers I can find.

    Here is the situation:
    - Both PCs running XP SP3, on 2 separate networks.
    - Syncing works and files transfer when connected via Live Desktop, and stops when unsynced with Live Desktop

    I checked the TCP/IP connections with the sysinternals process explorer for MOE.exe and Live Mesh Remote desktop and found that
    - MOE was trying to initate a connection to 192.168.1.4 (which is the LAN address of the other end of the P2P) - which timed out
    - MOE P2P connections to other local PCs (e.g. 192.168.1.10 is a real local peer) work fine and sync immediately
    - Remote desktop connections route through ag.mesh.com, and there are no TCP connections from either end to the peer

    Firewalls & antivirus
    - Disabled Window firewall(s)
    - Disabled NOD32 AV
    - Disabled router firewall
    - UPnp enabled/disabled

    VRRelay.. tried the relay.data.edge.messenger.live.com trick..(what's this anyway?)

    It seems to be something that's simply to do with the connection addressing.. Why is it trying to connect to 192.168.1.4 when it's on a completely remote network?

    Any help would be appreciated.. Unfortunately the 5GB storage on Mesh isn't going to support the weight of the sync folder. So will end up with a mix of wlx files and real files which I would prefer not to endure..

    Thanks
    Friday, August 7, 2009 10:37 PM

Answers

  • Unfortunately, the best that I can do is advise you to submit a bug report with logs.
     

    How to Submit Bugs and Live Mesh Logs

    I don't know why the P2P sync is still trying to reach the other PC at an old address, but it seems like the client on that machine isn't telling the service how to reach it. That would seem to indicate a problem with the client or with the router, but you've apparently tried a variety of things to insure that the router/NAT isn't the issue.

    -steve


    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Monday, August 10, 2009 12:34 PM
    Moderator