locked
How do I add a custom target attribute to a data map for importing data? RRS feed

  • Question

  • I'm trying to add a couple of custom target attributes for a bulk import data map. For example, in the excel spreadsheet I'm using as the data source, I have text data that tells me what kind of database the lead has installed. This is a key piece of data for us and I'd like to capture it in a text field that ultimately appears on lead, contact, and account forms.

    I've added an entity called "Installed Database" and have been able to make it appear on the Lead, Contact, and Account forms. But I cannot figure out how to make it appear in the list of Target Attributes when creating a data map.

    Any suggestions?
    • Moved by Xiaopeng Wu Tuesday, March 8, 2011 11:38 PM Forum consolidation (From:CRM Online)
    Friday, April 24, 2009 2:22 PM

Answers

  • If it is a custom object, the form field should have a lookup function to the right of the entry field.  Otherwise, it is most likely referencing another field and not the custom object field you'd created.

    Also check on the relationship setting (N:1 or 1:N) between the "Installed Database" and Account/Contact/Lead

    http://www.workopia.com/Links.htm

    Friday, April 24, 2009 10:59 PM
    Moderator

All replies

  • "Installed Database" is a custom object or picklist field?

    When you open a lead form, do you see the Install Databse field?  Is it a lookup or a picklist?

    Be sure to published the CRM customization involved and then re-check the data map.


    http://www.workopia.com/Links.htm

    Friday, April 24, 2009 7:06 PM
    Moderator
  • "Installed Database" is a custom object, and yes, I've been able to place it on a lead form, so I know it's been published. On the lead form, it's a text entry field (which is what I want). Where it's not showing up is in the list of Unmapped Attributes in the Target portion of the Data Map editing window. And this prevents me from mapping the Excel column "Installed Database" to the lead form for the import.

    Let me know if there's other info I can provide that would help...
    Friday, April 24, 2009 10:42 PM
  • If it is a custom object, the form field should have a lookup function to the right of the entry field.  Otherwise, it is most likely referencing another field and not the custom object field you'd created.

    Also check on the relationship setting (N:1 or 1:N) between the "Installed Database" and Account/Contact/Lead

    http://www.workopia.com/Links.htm

    Friday, April 24, 2009 10:59 PM
    Moderator
  • Well, I feel like I went in with a broadsword where a scalpel would've done, but I had to try several things. But based on you pointing the way, it seems like what needed to happen was that an N:N relationship needed to be set up, since 1:N wasn't doing it, and it wouldn't let me create an N:1 relationship since the field types weren't matching.

    So now I'm happily creating a data map with custom target attributes.

    Thanks for the pointers!
    Saturday, April 25, 2009 12:07 AM
  • If you can see the custom field on the lead form, it should appear in the data map for mapping your .csv columns to the applicable mapped target attribute.

    Are you creating the map from the data management settings?

    Settings->Data Management->Data Maps->"New"

    *Enter a name for the map
    *Select Lead from Record Type
    *In the Attributes link from the mappings section, you should see your "Installed Database" custom field in the list of unmapped attributes
    Saturday, April 25, 2009 12:16 AM
  • Yes, I am creating the map from the data management settings. And I was able to see the custom field on the lead form.

    But the "Installed Database" custom field did not appear in the list of unmapped attributed until I mucked around with the N:N relationships.
    Sunday, April 26, 2009 1:09 AM