locked
web addresses allowed http:// or https:// error RRS feed

  • Question

  • Anything I add in the WEB ADDRESSES ALLOWED field that begins wtih http:// or https:// results in an error when I click [OK]. 

    If I simply eliminate the http:// and put a website such as www.harnett.org it will not allow we access to any website.

    thanks

    -j

    Monday, July 23, 2007 7:32 PM

Answers

  •  

    Hi Jfrye,

     

    Based on SteadyState’s handbook,  when you enter the web addresses you want to allow the user profile to access, protocol prefixes http: or https: are not allowed in the Web Addresses Allowed box.

     

    Windows SteadyState Handbook

    http://www.microsoft.com/downloads/details.aspx?FamilyId=D64AF114-336C-4418-BEB7-E074E813B498&displaylang=en

     

    If the http: prefix cannot be automatically added, please check the following registry keys:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\DefaultPrefix

     

    The Default value’s value data should be "http://" without quotations.

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes

     

    The www value’s value data should be "http://" without quotations.

     

    Please modify the value data if either of them is incorrect. After that, please check if the website we added can be accessed or not.

     

    Best Regards,

    Wednesday, July 25, 2007 8:45 AM
  • Hi,

     

    As SteadyState uses a non-exist proxy server to block Internet access. Only the web sites added to the “Exceptions” list can skip the proxy server. Let’s manually configure the proxy server to check the result.

     

    1. To avoid confusion, please clear the “Prevent Internet access (except Web sites below)” option in SteadyState first.

    2. Click Start and click Run.

    3. Type “inetcpl.cpl” in the open box, and then press Enter.

    4. Select the Connections tab, click LAN Settings.

    5. Uncheck “Automatically detect settings”, select “Use a proxy server for your LAN. Input NoInternetAccess to the Address box, 80 to the port box.

    6. Click Advanced, select “Use the same proxy server for all protocols”

    7. Type www.tumblebooks.com in the Exceptions space. Click OK. (You can also add more websites to check this issue.)

    8. Open Registry Editor, check if ProxyOverride is available under the following branch. If so, please check if its value matches the address we added in the Exceptions list.

     

    [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

     

    9. Check if websites can be accessed or not.

     

    If the issue remains, we can conclude that the problem is not caused by SteadyState. I recommend consulting your network administrator to check if there is proxy server or some specific configurations which can affect Internet access. In addition, I would like to know the version of your Internet Explorer.

     

    Regards,

     

     

     

    Tuesday, August 7, 2007 8:38 AM

All replies

  •  

    Hi Jfrye,

     

    Based on SteadyState’s handbook,  when you enter the web addresses you want to allow the user profile to access, protocol prefixes http: or https: are not allowed in the Web Addresses Allowed box.

     

    Windows SteadyState Handbook

    http://www.microsoft.com/downloads/details.aspx?FamilyId=D64AF114-336C-4418-BEB7-E074E813B498&displaylang=en

     

    If the http: prefix cannot be automatically added, please check the following registry keys:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\DefaultPrefix

     

    The Default value’s value data should be "http://" without quotations.

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes

     

    The www value’s value data should be "http://" without quotations.

     

    Please modify the value data if either of them is incorrect. After that, please check if the website we added can be accessed or not.

     

    Best Regards,

    Wednesday, July 25, 2007 8:45 AM
  • Hey,

    I started over with a new profile.  Logged into that profile and can access anything on the Internet included URL I want.  I checked the registry as instructed and it is okay.

     

    I then went back to steadystate and selected only one restrictions; Internet except.  In the allowed box is www.harnett.org/library

    I did not lock - cannot get to any web page, even www.harnett.org/library

    I locked - same result

    I removed restriction in Internet except and can get to the webpage and any other webpage.

     

    I rebooted and powered off between tests.

     

    -jackie

     

    Wednesday, August 1, 2007 9:36 PM
  •  

    Hi Jackie,

     

    When you set selected “Prevent Internet access (except Web Sites below)” option, the system will set the proxy server in IE to a non-exist one (NoInternetAccess) and add web sites allowed to the “Exceptions”. The “Use the same proxy server for all protocols” option is checked. In this way, all web site access except for those allowed sites are blocked.

     

    As the issue persists under a new user account, I would like to confirm if you are using proxy server. This restriction will not work under an environment where already has a proxy server.

     

    If no proxy server is involved, please also check if the changes have made to registry:

     

    1. Click Start and then Run.

    2. Type in regedit and press Enter.

    3. Navigate to the following branch:

     

    [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

     

    4. Please check if ProxyOverride is available in the right panel. If so, please check if its value matches the address we added in SteadyState.

     

    Best Regards,

    Thursday, August 2, 2007 9:01 AM
  • We do not use proxy and if a setting has been turned on it is news to me.  This computer used the earlier version of MS shared computer toolkit.  I am not sure what that may or may not have activated.

     

    There is no registery setting for ProxyOverride.

    There are: ProxyServer = NoInternetAccess

    ProxyEnable=1

    autoconfigprox=wininet.dell

    migrateproxy=1

     

    I tried adding ProxyOverrride (String value) = www.harnett.org/library and it did not work.  I tried www.harnett.org and it liked that; maybe it does not like the /

     

    This limits me to anything in the harnett.org domain.

     

    I then went back to steady state and changed the url to  (this is the URL for another library who subscribes to tumblebooks, we have not received our URL yet)  http://www.tumblebooks.com/library/auto_login.asp?U=cumber&P=net

     

     and checked the registry and it changed teh value in the proxyoverride.

    Again I had to change to www.tumblebooks.com for it to work.  It did not go directly in already logged in (Cumberland County Library Logo), it too me to a login page.   Will ASP be a problem?  In other user accounts the URL works fine, I even have it a link on the desktop. 

     

    We want children to only access things from the internet that are on the tumblebooks site.  Tumble books will provide us an URL with our logo.

     

    Regardless after adding the ProxyOverrride (String value) = www.harnett.org/library it unlocked whatever was blocking me from doing this.  Now I can change things in steadystate and it updates the registry.

     

    thanks

    Jackie

     

     

     

     

     

     

     

     

     

     

    Monday, August 6, 2007 5:13 PM
  • Hi,

     

    As SteadyState uses a non-exist proxy server to block Internet access. Only the web sites added to the “Exceptions” list can skip the proxy server. Let’s manually configure the proxy server to check the result.

     

    1. To avoid confusion, please clear the “Prevent Internet access (except Web sites below)” option in SteadyState first.

    2. Click Start and click Run.

    3. Type “inetcpl.cpl” in the open box, and then press Enter.

    4. Select the Connections tab, click LAN Settings.

    5. Uncheck “Automatically detect settings”, select “Use a proxy server for your LAN. Input NoInternetAccess to the Address box, 80 to the port box.

    6. Click Advanced, select “Use the same proxy server for all protocols”

    7. Type www.tumblebooks.com in the Exceptions space. Click OK. (You can also add more websites to check this issue.)

    8. Open Registry Editor, check if ProxyOverride is available under the following branch. If so, please check if its value matches the address we added in the Exceptions list.

     

    [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

     

    9. Check if websites can be accessed or not.

     

    If the issue remains, we can conclude that the problem is not caused by SteadyState. I recommend consulting your network administrator to check if there is proxy server or some specific configurations which can affect Internet access. In addition, I would like to know the version of your Internet Explorer.

     

    Regards,

     

     

     

    Tuesday, August 7, 2007 8:38 AM
  • SteadyState appears to be working. 

     

    I find that the ProxyOverride in MS or SteadyState does not like anything but www.domain.xxx.  Regardless if I use MS or SteadyState if I type www.tumblebooks.com/library/auto_login.asp?U=cumber&P=net the regedit settings are only www.tumblebooks.com.  I have tried www.harnett.org/library and regedit settings is www.harnett.com.

     

    Maybe it is simply you can only allow at the domain level. This is okay and it works: with regedit setting www.tumblebooks.com I can get to anything with the domain.

     

    Regardless this works.

     

    thanks

    Jackie

     

    Wednesday, August 8, 2007 1:35 PM
  • Shawn,

    I'm having this same issue and I know we do not use a proxy server for web access. Steady State is making the correct changes to the registry, and I have tried the manual process of adding the allowed sites within the advanced network settings...Nothing works if the "Prevent Internet Access" box is checked, even if the allowed sites are correct. I am uising IE 7 build 5730.13 and whenever the "Prevent" box is checked, all sites are blocked...If that box is not checked, all sites work, which is the main problem for PC's we want to lock down.

     

    I could do the blocking using my web filter, Websense, but I would have to login as a domain user which means I can't use the other Steady State features to lock down the PC...Or is there a way to make SS work with a domain account??

     

    This issue seems to have been going on for awhile...Is there any real fix?

     

    Marc

    Thursday, September 11, 2008 4:55 PM
  • I am encountering a slightly different issue when attempting to restrict access via "Prevent Internet Access ..." on some computers (SteadyState v2.5)

    The web sites I entered in initially work fine, but any web site I try adding after the fact get saved in the client configuration screens, but the locked down user is denied access to them

    The only way I have been able to add to the exempt list is to uninstall SteadyState, delete all of the files and registry entries, and remove the locked down account and all of its files, then re-install SteadyState and recreate the locked down account
    Friday, September 19, 2008 9:43 PM