none
USMT loadstate error 27, invalid path. Tried multiple paths... RRS feed

  • Question

  • Hello all,

    Our first lab in a workstation class is migrating user data using USMT. We mapped a network drive, generated an xml using scanstate and loaded a new OS to do a loadstate on it. I'm using a batch file on the new Win7 install that maps the network drive again and runs loadstate, but I keep getting error code 27, invalid store path. I tried copying the file to the c: drive first and loading it from there, but got the same error. The instructor suggest that I can't generate the log file in the same directory as the genmig.xml that I'm using for loadstate, but moving the logfile generation directory doesn't change the outcome. Can anyone point out my mistake?

    The batch file I'm using follows:

    ========

    net use x: \\server-d222\migrate /user:[user] [pass]
    x:\amd64\loadstate x:\ /i:migdocs.xml /i:migapp.xml /lac /lae /l:c:\load.log
    pause

    ========

    • Edited by WhiteVandal Monday, January 30, 2012 10:08 PM
    Monday, January 30, 2012 10:07 PM

All replies

  • We had a similar problem. We used scanstate to save the settings to a I:\ drive. The program made a USMT folder in which the mig file was copied. We then renamed the USMT folder to <username>. After the migration to Win7, we were unable to import the settings with loadstate using the command I:\<username>. The reason for this was that the USMT tool expects a USMT subfolder within the store location. So, after createing a USMT subfolder in the I:\<username> folder and moving the mig file in it, loadstate worked perfectly. Hopefully, this solves your problem too. Good luck.
    • Proposed as answer by Oliver Adams Sunday, March 24, 2013 1:53 AM
    Wednesday, February 22, 2012 2:59 PM
  • Over 1 year after you posted that reply and you are still helping people. This had me really confused. Read your post problem solved, thank you very much!
    Sunday, March 24, 2013 1:53 AM
  • Life saver! Give that man a medal! Stumbled across this after banging me head against a brick wall with all the official MS TechNet stuff. Works a charm, Cheers!
    Friday, February 21, 2014 7:37 PM
  • This did not work for me.  However, the information I found at the following link did work:

    https://blogs.technet.microsoft.com/askds/2010/03/01/usmt-4-0-cryptic-messages-with-easy-fixes/

    Basically, the scanstate automatically creates a USMT folder when creating the MIG file, and when you create the command line for the loadstate, you should exclude that USMT folder in your command line statement.  

    For instance, if your scanstate command line statement was the following:

    scanstate G:\MyData /o /c /i:miguser.xml /i:migdocs.xml /localonly

    The resulting MIG file would be created in the following location:

    G:\MyData\USMT

    But, when you create your loadstate command, you should exclude the USMT folder:

    loadstate  /i:migapp.xml /i:miguser.xml G:\MyData /all

    So, the correct path is G:\MyData rather than G:\MyData\USMT.

    Wednesday, March 9, 2016 12:51 AM
  • Thanks Go4Bits. Worked great for me.
    Tuesday, February 6, 2018 2:19 PM
  • In my case the reason was, that I used the /nocompress flag for scanstate, but missed it in the loadState command line.
    Thursday, March 1, 2018 4:50 PM