locked
sharing is just not working... RRS feed

  • Question

  • Hello,

    Pardon my novice expertise in Windows, as I mainly use FreeBSD, but starting to use more and more Windows at work everyday. I am setting up a Server for a client, and am trying to get folder sharing to work. I've read many guides on it, and it appears to be so easy!, but am not sure what I am doing for it not to work.

    In every case, I don't have access to the folder that I am sharing from a remote location that is on the same network. I've shared a folder through the Dashboard. I've setup a folder, and straight shared it, giving full rights to select users. In either case, I am unable to access it.

    I then go to another system on the network that this system is on and am unable to get access to the folder by putting this in 'Explorer' \\SERVERNAME\SHARE

    Please help.

    Thanks

    Monday, January 19, 2015 11:51 PM

Answers

  • Network in Network and Sharing Center is set to Home or Work and not to Public?

    They are both set to 'Home,' however the Client machine is joined to "HomeGroup." I saw reports of this causing an issue, and it should be unjoined. What are the implications of unjoining a joined "HomeGroup"?


    No implications, especially if you do not use the sharing mechanics of that homegroup.

    Also check if there are not any stored credentials on the client (Control Panel/Credential Manager) pointing to the server with wrong user information.

    Can you see something in the security log of the server at the time of a failed login?

    You are directly trying to connect to a share, i.e. Start/Run -  \\Server\pictures and not solely to the server by \\Server (which seems to fail sometimes without for me obvious reason, maybe firewall or something like that)?

    Best greetings from Germany
    Olaf

    • Marked as answer by jgh40 Thursday, January 22, 2015 6:34 PM
    Wednesday, January 21, 2015 8:37 AM
  • Hmm - it should work!

    Are both machines on the same subnet? Can you ping one machine from the other and vice versa?

    Is your Server in a HomeGroup - if so, remove it as HomeGroup permissions override WHS permissions.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    • Marked as answer by jgh40 Thursday, January 22, 2015 6:33 PM
    Tuesday, January 20, 2015 12:02 AM
    • Marked as answer by jgh40 Thursday, January 22, 2015 6:34 PM
    Thursday, January 22, 2015 1:05 PM

All replies

  • Hmm - it should work!

    Are both machines on the same subnet? Can you ping one machine from the other and vice versa?

    Is your Server in a HomeGroup - if so, remove it as HomeGroup permissions override WHS permissions.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    • Marked as answer by jgh40 Thursday, January 22, 2015 6:33 PM
    Tuesday, January 20, 2015 12:02 AM
  • Hi Phil,

    Yes I can ping the machines from each other. They are in the 192.168 address space. How can I tell if they are in a HomeGroup? I did see that issue posted.

    Also, is there a particular place I should be sharing from? I created a "ServerFolder"

    One more note the machine that I am trying to access the server from is Windows 7 Home Premium SP1

    The Home Server 2011 is SP1, as well.

    Thanks!


    • Edited by jgh40 Tuesday, January 20, 2015 12:16 AM
    Tuesday, January 20, 2015 12:14 AM
  • HomeGroup is in the Dashboard, Server Settings, HomeGroup. You created "ServerFolder" - how? Using the Dashboard? What about the standard folders which are created during the installation (e.g. Music, Pictures etc.)? Can you share those?

    Did you setup sharing by using the Dashboard, Users, View Account Properties, Shared Folders?

    There should be no problem with W7 and WHS2011.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Tuesday, January 20, 2015 12:36 AM
  • I am unable to share these standard folders, as well. I didn't create them, but created an additional folder under "ServerFolder" for testing.

    I've tried setting it up through the Dashboard, but will try this again, later.

    One interesting bit is that when I do try to login to the share using a different username/password from another system to the home server, it errors in the logs on the server regarding the original user I was prompted to use, and not the one I was trying to connect as. This is very frustrating.

    Tuesday, January 20, 2015 12:57 AM
  • Hi,

    let me ask you a few questions:

    • Which Windows versions do you use?
    • Do user accounts on client and server have the same name (not display name only) and the same password?
    • If you try to login to connect with different user account, do you use Servername\user in the user name field?
    • Time, date and time zone matching on both the client and the server?
    • Network in Network and Sharing Center is set to Home or Work and not to Public?

    Best greetings from Germany
    Olaf

    Tuesday, January 20, 2015 2:13 PM
  • Hi,

    let me ask you a few questions:

    • Which Windows versions do you use?

    Windows Home Server 2011 SP1 (Server)

    Windows 7 Home Premium SP1 (Client)

    • Do user accounts on client and server have the same name (not display name only) and the same password?

    They do now, but I am not sure how this mattered as I was connecting as a valid user on the Server.

    • If you try to login to connect with different user account, do you use Servername\user in the user name field?

    Yes. I am using SERVERNAME\username

    • Time, date and time zone matching on both the client and the server?

    Yes, they match.

    • Network in Network and Sharing Center is set to Home or Work and not to Public?

    They are both set to 'Home,' however the Client machine is joined to "HomeGroup." I saw reports of this causing an issue, and it should be unjoined. What are the implications of unjoining a joined "HomeGroup"?

    Thanks!

    Answers are inline. Thanks for your help!
    Wednesday, January 21, 2015 6:13 AM
  • Network in Network and Sharing Center is set to Home or Work and not to Public?

    They are both set to 'Home,' however the Client machine is joined to "HomeGroup." I saw reports of this causing an issue, and it should be unjoined. What are the implications of unjoining a joined "HomeGroup"?


    No implications, especially if you do not use the sharing mechanics of that homegroup.

    Also check if there are not any stored credentials on the client (Control Panel/Credential Manager) pointing to the server with wrong user information.

    Can you see something in the security log of the server at the time of a failed login?

    You are directly trying to connect to a share, i.e. Start/Run -  \\Server\pictures and not solely to the server by \\Server (which seems to fail sometimes without for me obvious reason, maybe firewall or something like that)?

    Best greetings from Germany
    Olaf

    • Marked as answer by jgh40 Thursday, January 22, 2015 6:34 PM
    Wednesday, January 21, 2015 8:37 AM
  • I tried logging in after unjoining HomeGroup, and clearing credentials, and I am now at least getting an error that has my credentials in it. I am trying to connect through the explorer window, and just by double-clicking on the SERVERNAME, itself. I have replaced the actual servername with SERVERNAME for security purposes.

    This user is part of the Administrators, Remote Desktop Users, and Users groups.

    Thanks!

    Here is the error I received that coincided with a failed login from the client to the server. I was able to see the shares, though.

    An account failed to log on.

    Subject:

    Security ID: SERVERNAME\jgh

    Account Name: jgh

    Account Domain: SERVERNAME

    Logon ID: 0x454ddb9

    Logon Type: 3

    Account For Which Logon Failed:

    Security ID: NULL SID

    Account Name: Guest

    Account Domain: SERVERNAME

    Failure Information:

    Failure Reason: The user has not been granted the requested logon type at this machine.

    Status: 0xc000015b

    Sub Status: 0x0

    Process Information:

    Caller Process ID: 0xe5c

    Caller Process Name: C:\Windows\explorer.exe

    Network Information:

    Workstation Name: SERVERNAME

    Source Network Address: -

    Source Port: -

    Detailed Authentication Information:

    Logon Process: Advapi 

    Authentication Package: Negotiate

    Transited Services: -

    Package Name (NTLM only): -

    Key Length: 0

    Wednesday, January 21, 2015 8:36 PM
    • Marked as answer by jgh40 Thursday, January 22, 2015 6:34 PM
    Thursday, January 22, 2015 1:05 PM
  • So after working through all of the suggestions in the other threads (thank you!), and turning off password protection, I was able to access the shares. To me this doesn't make sense, and I was wondering why this is? I have an account jgh setup on the client and server with the same password, with access to the share. Yet, when I try to access it as that user with password protection on, I get this error. So my question is, how secure is this, now?

    Thanks, again. I very much appreciate the help, however I would like to get more of an explanation as to the security implications with this change.

    Thursday, January 22, 2015 5:42 PM
  • My view of it (might not be fully correct, since I never used homegroups at all):

    Password protected sharing is a feature solely available for the homegroup scenario. This seems to take precedence in authentication if connecting to any share, if enabled, and cannot be combined with Windows Server 2008 R2/WHS 2011 default user account based sharing. (You could however integrate WHS 2011 into the home group.)

    If you are using a server, it is assumed that you know what you do and can set security either by limiting shared folder access based on accounts or configuring NTFS permissions on the server the same way, giving you much more granularity with the selection who can access what. So this is safer - if you know, what you do.

    Best greetings from Germany
    Olaf


    Monday, January 26, 2015 2:11 PM