locked
TVersity & PS3 streaming VERY choppy RRS feed

  • Question

  • I have installed TVersity to stream various video formats, but the playback is so choppy that it is unwatchable. I am very confident that this is not a network issue - I can stream the exact same video content over the same wired router set up from my vista box (which is right next to my whs box). My WHS box is new, I just built it, AMD dual core, cpu shows under 5%, the box has 2gb of ram. 

    The main reason I set up this box is for media streaming, so this is very frustrating. Any suggestions? TVersity works great on my vista machine, but I can only really browse the files on the whs machine, playback is just way too choppy - 10 to 20 second pauses.

    I've been googling for choppy tversity, and I've seen a number of complaints (both with and w/out WHS), but no real leads to try. Are people having success streaming HD video from WHS via TVersity??

    Any suggestions very much appreciated.

    Tom
    Saturday, November 22, 2008 4:51 AM

All replies

  • Are you using a wired or wireless connection?  I started to use tversity for my ps3 streaming and also had stuttering.  I switched to media player 11 and got rid of the wireless g connection in favor of a gigabit switch.  After doing those two things, I can play high def or any type of video without any issues.  Browsing the shares is also much faster.
    athlon 3400, 2gb ram, 9 drives totaling about 3.5 tbs.
    Saturday, November 22, 2008 5:51 AM
  • I've sent this response several times for network issues so many times that now I've just copied the text to paste...

    Preface - My comments are directed to your WHS server and not your clients. I have had no issues with client side onboard NIC's
     
    I've had extensive problems with onboard NIC's (especially RealTek powered by nVidia chipsets). I as a matter of process, I now install a dedicated NIC from Intel. My preference for Intel Giga NICs is based on cost/performance/ease of configuration. I've built 5 WHS boxes for clients and I try to standardize on parts for obvious reasons so my routine is pretty well defined now. But for the last year I've played with a multitude of MB's with on board NIC's and more times than not the onboard NIC causes all kinds of problems related to speed and connectivity. In each of those instances I disabled the onboard NIC and plugged in the Intel card and whoala - problem solved. Problems have included choppy and locked up streaming, both music and video.

    For sanities sake, if you are using the onboard NIC, try this card to see if it resolves the issue:
    PCI-X (1x) http://www.newegg.com/Product/Product.aspx?Item=N82E16833106006  note, this has to go into a PCI-X 1x slot, it will not work in a 4 or 16x slot.
    PCI http://www.newegg.com/Product/Product.aspx?Item=N82E16833106121 this is your standard PCI card equivalent to the card above, obviously theoretical speeds will be lower because of the wide band for the PCI-X card.

    From my experience download speeds doubled and upload speeds quadruple, CPU utilization goes down to 3-5% for the NIC, which is down from 15-17%. Although I'm not a network engineer, my insight as to the reason for the onboard NIC issue is that some of them (the ones I've gotten) are not on the Server 2003 list of approved cards while the Intel cards are.

    For $30, it's a cheap way to trouble shoot for a common WHS problem.

    I hope this offers some insight from my experience,
    Saturday, November 22, 2008 7:27 AM
  • MicroSSG -
    Thanks for this suggestion. I do have an onboard nic - Realtek RTL8168C(P)/PCI-E Gigabit Ethernet NIC

    This is the Gigabyte mobo I'm using: http://www.newegg.com/Product/Product.aspx?Item=N82E16813128335. Looks like it should have some PCI Express x1 slots available, so I'll probably try that card. Actually, my Vista box which works so well has an upgraded dedicated gigabit nic card...

    I will update this thread if it solves my problem.

    Thanks!
    Tom
    Saturday, November 22, 2008 2:16 PM
  •  RomanTotale,

    While you're in the process of getting the NIC, you might want to read my original thread about this whole problem. I just re-read it and remembered so things I had forgoten...

    Anyway, at the very least you may glean some more bits, or just relish that you probably won't have to go through the same experience...

    http://social.microsoft.com/Forums/en-US/whshardware/thread/464a1838-8a01-4f95-946c-430f28a923dc

    good luck,

    MicroSSG
    Go State Win - and JoePa said he didn't believe in running up the score? Wow, what a beating Penn State put on us today! Oh well, It was still a great season for us and we'll go bowling some where nice.
    Sunday, November 23, 2008 4:26 AM
  • I got the Intel NIC today and installed it. Unfortunately, the choppy video is exactly the same.

    I disabled the old NIC and it is connecting through the new nic w/out problems, but the video issue is still the same.

    This is the first server I've built, so suggestions for trouble shooting hardware issues is appreciated. WHS does seem to be running fairly well. I notice that sometimes I have to try several times before windows connector will connect, and when I installed Web Folders 4 WHS, everything became very slow, but it is back to normal after uninstall. 

    Streaming video, however, is unwatchable, which I would really like to resolve since media serving is mostly what I want to use WHS for.

    I pulled up the performance moniter while the choppy video was streaming - cpu usage was in the 1 - 3% range and the networking graph was below 1% as well. 

    What else can I try??
    Thursday, November 27, 2008 2:53 AM
  • I am totally stumped, but I've tried a few more things, without success.
    -disabled windows search
    -updated the hdmi audio driver, which was missing - now it shows no error in device manager

    I think I can very safely rule out network issues. I can successfully stream videos (flawlessly) from the share folder on whs using my vista machine. I added the whs share folder to the tversity library on my vista box and streamed the files that way - absolutely no problems.

    So, the problem looks to be with tversity server running on the whs. could this be hardware driver related? like i've said, the performance monitor doesn't seem to be particularly loaded (under 5% for cpu, 1% for network)

    I have the following hardware:
    MOBO: Gigabyte GA-MA78G-DS3H rev 1.
    CPU: AMD Athlon64 Dual-Core 4450e (2.3Ghz)
    RAM: A-Data 2GB (2x1gb) ddr2 800 (pc2 6400)
    1 500 gb drive for system, 1tb samsung 5400rpm drive

    The only unusual thing I can think of on my install is that I had a bad drive in my initial install, but it wasn't the system drive.

    What am I left with to try - reinstalling WHS? I don't know what to look for for driver/bios issues - nothing shows up in the device manager and aside from streamin with TVersity, everything else seems to be okay.

    This is definitely driving me crazy.
    Friday, November 28, 2008 3:12 PM
  • I noticed there is a new version of tversity out, if that is what you have? If not, you might try upgrading or downgrading. And, you can read this link from the tversity forum. It does give one fix, but it also states the problem can be with your motherboard drivers and tversity. If this applies, I think you will need to go another route, there are alternatives to tversity.

    http://forums.tversity.com/viewtopic.php?f=1&t=11756 ,

    Ben

    Ben Ogilvie
    Friday, November 28, 2008 7:29 PM
  • I tried the new version - just happened to be out after I did a full, fresh install of whs. There did seem to be a bit of funkiness with my old whs install, and it seems much faster now, but Tversity still doesn't work. So, that is uninstalled, bummer. I'm trying Twonky now - I haven't used it for more than a quick test, but its already going much more smoothly than Tversity for my set up (it plays). I'll have to do a few longer viewings, but my short answer fix for now may be Twonky. Actually, if Twonky proves to be stable, I'll feel very foolish at the lengths I went to to try and make TVersity work - this was actually easy, but I haven't tested enough video to know if there is a quality difference or if I'll be missing some important video formats.

    Thanks,
    Tom
    Saturday, November 29, 2008 5:10 AM
  • RomanTotale,
    Were you able to fix the performance issue with TVersity on WHS? I think quite unncessarily, I took a plunge into WHS. It was a recent visit to MSCompany Store that attracted me to WHS. I formatted by DELL 8400 (which had XP Home running T-Versity, I used to use this in all the rooms at home (PS3, Xbox, Boxee on AppleTV and DLink). Tversity rocked on XP.

    I got attracted to WHS, because of the user-friendliness, ease of sharing on the internet and automated back-up.

    However, choppy video on Tversity is a deal breaker for me. I am almost regretting the move to WHS.

    Ideas are welcome.

    Saturday, June 20, 2009 12:50 AM
  • I also battled in the beginning to get TVersity up and running on my machine at home to display video smoothly.

    I have a no-name wireless router that I was connecting the server to directly then wireless streaming to the PS3/XBOX/PC. Picture would become choppy after a while (or when streaming to all 3 devices at same time).  I then added a DLink switch (8 Port one that I had lying around) between the server and wireless router and immediately video issues were resolved.

    This is how it looks:  [SERVER] <--> [DLINK 8port] <--> [WIRELESS ROUTER] >>>><<<< PS3/XBOX/Kids PC

    <--> is RJ45     and   >>>><<<< is Wireless  above

    I took the DLink out of the picture again and again the video became choppy. I replaced the wireless router and ran RJ45 from server to DLink switch to PS3 and it also went intermittantly choppy (after quite a while of watching).  So I put everything back as detailed above and have been running it successfully for about 6 months now.

    I don't know if the connectivity between the Dlink and No-Name Router is acting like a buffer, but it works!

    BTW: You might want to consider trying out PSMediaServer - http://ps3mediaserver.blogspot.com/  as an alternative to TVersity, as it provides alternative transcoding engines if some of your media does not want to play on the PS3 with Tversity, and it works nicely with the XBox also :-)
    Saturday, June 20, 2009 4:15 PM
  • Some folks have had success with upgrading to better switches ( not consumer grade ) to alleviate this problem. Also, make sure you are running your disks in DMA mode. You will not be by default. Also, have you tried process explorer to see if anything is running too heavily ?
    I have noticed on the tversity forum many people report the same result, and have asked that the software be compiled for WHS, with no luck. Unluckily, some people have been able to use tversity with WHS with success.


    Ben
    Ben Ogilvie
    Saturday, June 20, 2009 9:53 PM
  • thanks mscanlen. I am in  a very similar situation. Here is what my connectivity looks like [SERVER]<->[DLINK 5 port SWITCH]<->Wired Connection to <->2Wire Router<->Wired Connection<->DLink Switch<->PS3.

    All devices are connected wired, no wireless at all.

    CPU runs at 1-2%, if I try to access the WHS over remote desktop while the video is all choppy, the access is pretty smooth. No delayed response.

     

    I will try the DMA mode as benogil suggested.

    Its a shame a wonderful server like Tversity is not compatible with WHS.

    Sunday, June 21, 2009 11:25 PM
  • Hi Guys,

    Hi resolved my / your issue.

    Under device manager goto properties of your network card. Under Advanced Check your "Speed & Duplex", "Recieve Buffer" and "Transmit Buffer".

    For Info my settings are as follows:

    Speed & Duplex: 1GB Full Duplex (you guys may be needing 100MB Full duplex if you are running "standard routers")
    Transmit Buffer: 128 (was 512)
    Recieve Buffer: 512 (was 256)

    Good Luck guys!
    Monday, August 17, 2009 9:08 PM