none
Forum looses code block Formatting when doing an edit RRS feed

  • Question

  • If I add a Code block using the insert code block button, and post the message, it works ok. However if I go back and edit that message, the code block gets all screwed up and adds lots of carriage returns where they don't belong.
    Monday, October 4, 2010 2:43 AM

Answers

  • You can edit the code by clicking 'edit', highlighting the gray box text of the code and then clicking the edit code, bringing up the code edit dialog. We know the feature needs some work, thanks for reporting this.
    Community Forums Program Manager
    Monday, October 4, 2010 4:53 PM
    Answerer

All replies

  • When you went back to edit the message did you just edit it inline, edit the html for it, or highlight the code and bring up the edit code dialog? Can you give me a url for the code you had a problem with?
    Community Forums Program Manager
    Monday, October 4, 2010 3:58 AM
    Answerer
  • I edited the text part of the post, none of the code block.

    Another problem I noticed is that if I enter a code block, I can't seem to be able to alter that code block with the code block tool, I have to edit the html. I really don't want to mess with the html, it takes so much time to make sure you don't miss a tag when editing, especially with how it adds all the coloring for whatever code was entered.

    The feature really needs some polishing up...

    Monday, October 4, 2010 4:23 AM
  • You can edit the code by clicking 'edit', highlighting the gray box text of the code and then clicking the edit code, bringing up the code edit dialog. We know the feature needs some work, thanks for reporting this.
    Community Forums Program Manager
    Monday, October 4, 2010 4:53 PM
    Answerer