locked
Why don't .mkv files show up for network devices that can play them? RRS feed

  • Question

  • When I put .mkv files in the shared Video folder I expected them to be viewable by devices that can normally play the format.  However it doesn't look like those files are being served up.  Is there a way to fix this so the home server can share .mkv's?  I've read elsewhere that installing a codec pack may fix the issue - has anyone had luck with this?
    Wednesday, October 12, 2011 8:05 PM

All replies

  • Windows Home Server only knows about, and can only stream, certain formats. MKV is not among them.

    You can still play those files from your server if your device is capable of playing from a file share; you will need to configure your playback device to access the files from the share, rather than by using the built-in streaming.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, October 12, 2011 8:24 PM
  • WHS2011 does not natively stream Matroska contained files. See here for guidance on what it does support:

    Media Files

    Do a search on this forum as I believe from memory it has been asked before and might be as simple as changing the file extension.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Wednesday, October 12, 2011 8:27 PM
  • Hi Ken - Thanks for the reply.

    My goal here is to simply get Windows Home Server to host the files so that a capable device can play them back.  Currently, if I put .mkv files in the Videos folder they aren't visible to network devices.  I'm not expecting WHS to play them via its Silverlight streaming component or otherwise.

    Wednesday, October 12, 2011 8:33 PM
  • Thanks Phil, my first attempt was to search this forum for "mkv", but that phrase is too short to be a valid search ;)

    EDIT: Search issue must have been on another forum.  I'll take another look.

    I have had success with the renaming trick but that's not a great solution.  If you have an automated setup to download files that means I need to figure out an extra component that will do a rename when downloads complete.  It's not the end of the world but is it necessary?


    Wednesday, October 12, 2011 8:34 PM
  • If your media player supports SMB access to files then you should be OK. From the online documentation:

    "Devices that use SMB (network file/share access) instead of DLNA (media streaming) require the Guest account to be activated. This allows any device or user on the network to view the contents of shared folders without authentication."


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Wednesday, October 12, 2011 8:41 PM
  • Access the Videos folder as a file share rather than a DLNA streaming server, and your media player will probably be able to see the files. You may need to turn on the Guest account and allow it READ access to the share.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, October 12, 2011 8:41 PM
  • Well at least we are consistent in our responses!
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Wednesday, October 12, 2011 8:42 PM
  • Thanks to both of you - I'll turn on the Guest account and give that a shot!
    Wednesday, October 12, 2011 8:52 PM
  • I've installed on WHS 2011 Serviio media server - freeware

    http://www.serviio.org/download

    Windows Home Server add-in

    http://serviiowhs.codeplex.com/releases/80059/download/323805

    TV Sony Bravia

    Friday, January 20, 2012 12:41 PM
  • Hi, 

    You can work around by changing the extension *.mkv to *wmv. The file would appear on your TV and you can play/stream it normally.

    The problem is that you must do it one by one for all of you *.mkv file :(

    Some guy tried to config WMP extension in regedit but i havent tried yet. You can find it here:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-pictures/adding-mkv-files-to-the-windows-media-player/c867bdea-9674-4f0b-b56f-7650920f14a1?page=3


    Tuesday, November 25, 2014 5:11 AM