none
Server to IIS request taking long time in first hit RRS feed

  • Question

  • Hi I am using Windows Server 2016, I have sufficient and ample Memory on my server. The problem what I am facing is I am getting a consistent 15 second delay on the first request after 4 minutes of inactivity.
    Why is this causing so ? In IIS I have tried setting Start Mode as Always Running, Recycling Time Interval (in minutes) to '0' but no difference.
    My website is sleeping after couple minutes of inactivity. How to minimize and solve this ?

    Experts please advise 


    RH

    Thursday, October 24, 2019 2:26 PM

All replies

  • Look in the event logs. I suspect your site is getting an exception causing the site to stop.  Normal cycle down time is 20 minutes
    Thursday, October 24, 2019 10:11 PM
  • Hi Dan2890,

    Thank you for posting here.

    Accoring to your question, your issue is more related to IIS. Therefore, it will be more appropriate to ask your question in IIS Forums

    The CLR Forum discuss and ask questions about .NET Framework Base Classes (BCL) such as Collections, I/O, Regigistry, Globalization, Reflection. Also discuss all the other Microsoft libraries that are built on or extend the .NET Framework.

    Thank you for your understanding.

    Best Regards,

    Xingyu Zhao


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, October 25, 2019 9:35 AM