none
Application requires .NET 4.7.2 while it's already installed RRS feed

  • Question

  • Hi,

    I developed a console application using .NET 4.7.2, and referencing an open source 3rd party library using .NET Standard 2.0 (AmiClient). The app works fine in my development PC, but when I deployed to server the following message appeared. I installed the requested framework (and restarted the server) but the warning still appears.

    Need help on this. Thank you.

    

    Monday, July 9, 2018 4:54 AM

All replies

  • It's not a warning message. It's an exception message, and the program is terminating. The error message is telling you that .NET Framework v4.7.2 that the program was developed against (your development machine that has the (v4.7.2) is not on the machine where the program is trying to run on.

    You need to install .NET Framework v4.7.2 on the machine the program is intended to run on in order to run the program.

     
    Monday, July 9, 2018 10:11 AM