locked
Sync Framework v1.0 Install Fails on Vista x64 with Administator account. RRS feed

  • General discussion

  • I am unable to install v1, the log file shows this error:

    Installing using command 'C:\Windows\SysWOW64\msiexec.exe' and parameters ' -I "C:\Users\ADMINI~1\AppData\Local\Temp\VSD6162.tmp\Microsoft Sync Framework\Synchronization.msi" -q APPGUID={53AA4694-C1DE-4229-9C0E-0486C5AFEAEC}'
    Will attempt to elevate process.
    Process exited with code 1603
    Status of package 'Microsoft Sync Framework Runtime v1.0' after install is 'InstallFailed'
    Status of package 'Microsoft Sync Services for ADO.NET v2.0' after install is 'InstallNeeded'
    Status of package 'Microsoft Sync Framework Services v1.0' after install is 'InstallNeeded'

    I cannot understand what I need to do to elevate the process to get this to work.

    However I don't think the error is correct, I expect it can't install it because v2 is already installed.

    Wednesday, December 31, 2008 11:07 PM

All replies

  • Are you saying you already have installed Sync Framework v2 CTP1 on the machine and then trying to install Sync Framework v1 on it? If so, this is not supported right now. v1 and v2 cannot exist Side by Side and neither is upgrade supported as of v2 CTP1. You will have to uninstall v1 and then install v2.

     

    If this is not the problem or my understanding is incorrect, please let me know.

    Friday, January 2, 2009 9:17 PM
  •  

    No, I'm saying the error message is incorrect, because the installation fails when v2 is already installed.

     

    The error has nothing to do with the need to elevate a privledge for the installation. The installer already has the privledge it needs to run correctly.

    Sunday, January 11, 2009 1:19 AM
  • Actually 1603 is the generic "fatal error during installation" error code. The setup does log that it is trying to elevate, but that step succeeds as far as i can tell. if you get an error message in the UI when trying to run setup saying "a newer version is already installed", then things are working as expected. if you are doing a silent install and the log doesn't provide this error, i will try to repro this and file a bug to try and fix this.

     

    thanks

     

    sid

     

     

    Monday, January 12, 2009 5:56 PM
  • I was getting this problem (A fatal error occurred during the installation of Microsoft Sync Framework Runtime v1.0) during a SharePoint 2010 install and could not find much clear information on this.  I did have a look in the Programs and Features under Windows Server 2008 and found four existing installations for Sync services (these had a BETA tag against them).  I un-installed all these then retried the SharePoint 2010 install and this time with success.

    These are the last few lines of my install.log...

    ...
    The following properties have been set for package 'Microsoft Sync Framework Runtime v1.0':
    Property: [DotNetInstalled] = 1 {int}
    Running checks for command 'Microsoft Sync Framework\Synchronization.msi'
    Skipping ByPassIf because Property 'IsMsiInstalled' was not defined
    Result of running operator 'ValueEqualTo' on property 'DotNetInstalled' and value '0': false
    Result of checks for command 'Microsoft Sync Framework\Synchronization.msi' is 'Install'
    'Microsoft Sync Framework Runtime v1.0' RunCheck result: Install Needed
    Verifying file integrity of C:\Users\ADMINI~1\AppData\Local\Temp\1\VSD6299.tmp\Microsoft Sync Framework\Synchronization.msi
    WinVerifyTrust returned 0
    File trusted
    Installing using command 'C:\Windows\SysWOW64\msiexec.exe' and parameters ' -I "C:\Users\ADMINI~1\AppData\Local\Temp\1\VSD6299.tmp\Microsoft Sync Framework\Synchronization.msi" -q APPGUID={53AA4694-C1DE-4229-9C0E-0486C5AFEAEC}'
    Will attempt to elevate process.
    Process exited with code 1603
    Status of package 'Microsoft Sync Framework Runtime v1.0' after install is 'InstallFailed'
    Status of package 'Microsoft Sync Services for ADO.NET v2.0' after install is 'InstallNeeded'
    Status of package 'Microsoft Sync Framework Services v1.0' after install is 'InstallNeeded'
    • Edited by Andrew Maisey Wednesday, January 13, 2010 2:05 PM More information
    Wednesday, January 13, 2010 2:01 PM