locked
CWA activation problems RRS feed

  • Question

  •  

    Hi all,

     

    I had CWA running on one of my servers (the OCS server, actually) until it suddenly stopped working a while back. Since noone's actually using it I didn't care, but now my boss, for some unknown reason, has decided that we need it running.

     

    So...after playing around with it and try to get it working again, I uninstalled it and wanted to install it from scratch. Installed everything, and then went for the activation - only to get "Setup has not detected Microsoft Office Communications Server 2007 in the Domain". Everything else seems to work fine...

     

    Anyone got any tips? I've tried installing it on other servers as well, but I'm getting the same error from the activation wizard...

    Thursday, February 14, 2008 7:35 AM

Answers

  •  

    Found the solution - just run the forestprep again, and it works Smile
    Thursday, February 14, 2008 8:03 AM

All replies

  •  

    Found the solution - just run the forestprep again, and it works Smile
    Thursday, February 14, 2008 8:03 AM
  • I had the same problem - and this resolved it. Many thanks! Wish there was a KB on this (and why it's necessary). A search on microsoft.com and TechNet found nothing. A search on Google found this posting!

     

    Thursday, February 28, 2008 10:16 AM
  •  

    That is why Google is the #1 tool used internally @ Msft. =]
    Tuesday, June 10, 2008 8:34 PM
  • I am experiencing the same activation error as described above. Have re-run ForestPrep, SchemaPrep, DomainPrep but the problem is just not going away. Can't find any material anywhere else on the web about this issue. Mine is a single forest single domain AD environment and the OCS 2007 box is running W2K3 R2 x64, as is the CWA box. Any ideas would be most welcome. Thank you!

    Friday, July 11, 2008 3:39 PM
  • So I found the issue in my case, don't know if it will help but here goes (Windows Server 2008 EE)...

     

    During the DC Promo / DNS install process if you did not have the 'register this connection in DNS' checkbox selected then the proper MSTCS DNS records are not created and the OCS server has issues locating the proper AD resources. See if your missing any common AD DNS records...

     

    Possible Fix? : http://www.velocityreviews.com/forums/t51552-default-active-directory-dns-resource-records.html

    Saturday, July 12, 2008 4:05 AM
  • Richard, many thanks for the pointers. I explored the DNS angle extensively, and lots more, but drew a blank. I eventually overcame the activation problem as follows:

    - disjoined the CWA server from the domain and into a workgroup

    - joined the server back to the domain

    - ran the activation wizard again and it worked.

    Strange but true!

    Thursday, July 24, 2008 2:49 PM