none
El SqlDataSource no toma los parámetros de borrado RRS feed

  • Question

  • Buenos días

    Espero que me puedan colaborar con una duda  que me ha estado atormentando

    Tengo un SqlDataSource  al cual  le coloco unos parámetros de Inserción, actualización y borrado de los primeros me toma los datos que le envió pero del ultimo(Borrado) no lo hace

    Este es el código del data source

    <asp:SqlDataSource ID="DataSourceSimobi" runat="server"  ConnectionString="<%$ ConnectionStrings:SWC_conn %>"  
            DeleteCommand="SP" DeleteCommandType="StoredProcedure"
            InsertCommand="SP" InsertCommandType="StoredProcedure" 
            SelectCommand="SP" SelectCommandType="StoredProcedure"
            UpdateCommand="SP" UpdateCommandType="StoredProcedure">        
            <DeleteParameters>        
                <asp:Parameter Name="intProceso" Type="Int32" DefaultValue = "3"/>            
                <asp:Parameter Name="udi_usuario" Type="String"/>
                <asp:Parameter Name="emp_codigo" Type="Int32" />
                <asp:Parameter Name="udi_serial" Type="String" />
                <asp:Parameter Name="udi_tipo_usuario" Type="String"/>            
            </DeleteParameters>
            <UpdateParameters>
                <asp:Parameter Name="udi_usuario" Type="String"  DefaultValue = ""  />
                <asp:Parameter Name="emp_codigo" Type="Int32"  DefaultValue = "" />
                <asp:Parameter Name="udi_serial" Type="String"  DefaultValue = "" />
                <asp:Parameter Name="udi_tipo_usuario" Type="Int32"   DefaultValue = "" />
                <asp:Parameter Name="udi_fecha_ingreso" Type="DateTime"   DefaultValue = "" />
                <asp:Parameter Name="udi_fecha_modificacion" Type="DateTime"  DefaultValue = ""  />
                <asp:Parameter Name="udi_usuario_modificacion" Type="String"   DefaultValue = "" />
                <asp:Parameter Name="udi_estado" Type="Boolean"   DefaultValue = "" />            
                <asp:Parameter Name="intProceso" Type="Int32" DefaultValue = "1"/>                         
            </UpdateParameters>
            <InsertParameters>
                <asp:Parameter Name="udi_usuario" Type="String"  DefaultValue = "" />
                <asp:Parameter Name="emp_codigo" Type="Int32"  DefaultValue = ""/>
                <asp:Parameter Name="udi_serial" Type="String"  DefaultValue = ""/>
                <asp:Parameter Name="udi_tipo_usuario" Type="Int32"  />            
                <asp:Parameter Name="udi_fecha_ingreso" Type="DateTime"  />
                <asp:Parameter Name="udi_fecha_modificacion" Type="DateTime"  />
                <asp:Parameter Name="udi_usuario_modificacion" Type="String"   />
                <asp:Parameter Name="udi_estado" Type="Boolean"   DefaultValue = ""/>            
                <asp:Parameter Name="intProceso" Type="Int32" DefaultValue = "1"/>                        
            </InsertParameters>
            <SelectParameters>
                <asp:Parameter Name="intProceso" Type="Int32" DefaultValue = "2"/>                                
            </SelectParameters>
        </asp:SqlDataSource>


    Este esta asociado a una grilla  la cual tiene su KeyFieldName de un campo llamado "llave" y este campo  "llave" es el único que envía  y no entiendo la razón 

    Les agradezco de antemano la ayuda  y espero sus prontas respuestas 

     
    • Moved by Mike Feng Friday, April 19, 2013 7:16 AM
    Wednesday, April 17, 2013 1:51 PM

All replies