locked
Workflow for automatic email not working for another user RRS feed

  • Question

  • Hi, I had created a workflow to send an automatic email. It works in my PC but not in that of my colleagues. Is there any setting change that has to be done?
    Monday, June 22, 2009 6:21 PM

Answers

  • The Miscellaneous Privileges section appears on each tab of the security role form, which you can review by navigating to Settings > Administration > Security Roles and opening the desired role.
    • Marked as answer by Jim Glass Jr Tuesday, June 23, 2009 8:46 PM
    Tuesday, June 23, 2009 5:47 PM

All replies

  • Following were the changes I made to the settings of my colleague's PC:
    - Enabled 'Execute Workflow Job' under 'Customization' in Settings
    - Under Email Access Configuration, I chose MS Dynamics CRM for Outlook(Incoming) and E-mail Router(Outgoing)

    Is it that, only the owner can execute the jobs?
    Monday, June 22, 2009 7:03 PM
  • On the workflow form, you should be able to set the Scope of the workflow and change it from User to Organization.  This is assuming that when you say the workflow is not working that means the workflow is not running at all.  If the workflow is running but not sending the email, then something else may be going wrong.
    Monday, June 22, 2009 7:07 PM
  • The scope was always 'Organization'. The workflow instance is created, but the status is always waiting. In my PC, the status becomes 'Suceeded' and I get a mail. But my colleague gets the error 'You do not have enough privileges to access the MSDCRM object or perform the requested operation'
    Monday, June 22, 2009 7:19 PM
  • What other actions does your workflow perform; does the workflow attempt to update a record?  How are your security permissions different from your colleague's?  In the workflow, does the email regard a record that maybe your colleague doesn't have append permissions on?

    Monday, June 22, 2009 7:27 PM
  • Hi Richard, My colleague and I are part of the same business unit and have the same role.
    Monday, June 22, 2009 7:41 PM
  • Assuming the line in the workflow that fails is the line that sends the email and assuming the email regards the record, I think there may be one or two things going wrong.  Perhaps the email regards the record and the record is owned by you and your role only provides permissions to append emails to records owned by you.  So when your colleague runs the workflow against that record the workflow fails because your colleague cannot append emails to records he doesn't own.  Or, perhaps you are setting the owner of the email and your permissions do not allow you to create emails for other users.

    Is the record you are running the workflow against owned by you?  Does the workflow succeed for your colleague if he runs the workflow against a record he owns?  Are you explicitly setting the owner of the email in the workflow?

    Monday, June 22, 2009 7:50 PM
  • The logic is very simple. An email has to be sent if a user creates an activity and selects a radio button named'remind me'. When I create a new activity and click on 'remind me', I get the email at the time specified in the activity. When my colleague creates a new activity for which he will be the owner and clicks on 'remind me', the workflow is always in 'waiting' status and he gets this error,''You do not have enough privileges..'. So, yes, he is the owner of the record against which the email is sent.
    Monday, June 22, 2009 7:58 PM
  • Also, even the system administrator is not able to run the workflow.It works only for me. Does that give any clue?
    Monday, June 22, 2009 8:22 PM
  • Are you using a template for the email?

    Monday, June 22, 2009 8:25 PM
  • No.

    Also, this workflow was imported from another server.Not sure if that will cause any difference.
    Monday, June 22, 2009 8:31 PM
  • If the workflow works for you, it ought to work for others as well.  To test, though, you could create a manual workflow on the task entity which just sends an email with no other actions.  In the setup, set the To and From as the task owner and don't set the regarding field on the email.  If all users are able to run that workflow, I would rewrite the orginal workflow.

    If users cannot run the second workflow, I would turn on tracing on the server and post the results.  Generally that error is accompanied by an entry in the trace file which lists the particular privilege the user is missing, which will help narrow down what is going wrong.
    Monday, June 22, 2009 8:35 PM
  • Hi Glora,

    If workflow was imported from another server, I would suggest to check the following
     - check workflow steps for any missing reference i.e. To/From field if there was a hardcoded user name in any of the fields, it might give problems.
     - check your colleague has a valid email id in his/her profile.

    I know, you have clearly mentioned about missing privileges but still, these are the first two steps to be checked. Also, if these does not help, please do check workflow steps for any errors.
    Regards,
    Chinmay
    http://metrix.blogspot.com
    Tuesday, June 23, 2009 3:03 AM
  • The error trace:

    prvSendAsUser,6FD3EB4F-66E3-4587-B4AB-C064F03AD783 

    <q1:Value>description: SecLib::CrmCheckPrivilege failed. Returned hr = -2147220960 on UserId: 68593d99-c94b-de11-a821-000c297901a5 and PrivilegeId: 6fd3eb4f-66e3-4587-b4ab-c064f03ad783 

    >update WorkflowLogBase set Message='description: SecLib::CrmCheckPrivilege failed. Returned hr = -2147220960 on UserId: 68593d99-c94b-de11-a821-000c297901a5 and PrivilegeId: 6fd3eb4f-66e3-4587-b4ab-c064f03ad783

    This says that I do not have the prvSendAsUser priviledge and hence none of my workflows can be executed by anybody else. And the worst parts is, the prvSendAsUser is not configurable from the Settings->Administration screen. If anybody knows of a way to resolve this, please let me know. Thanks

    Tuesday, June 23, 2009 5:00 PM
  • In your security role form, on the Business Management tab, under miscellaneous Privileges, you should see Send Email as Another User.

    However, if you don't want to change the permissions, don't set the Sender of the email in the workflow.
    Tuesday, June 23, 2009 5:08 PM
  • Hi Richard, Not able to find where this is, could you point to where this privilege can be set. Thanks

    Tuesday, June 23, 2009 5:45 PM
  • The Miscellaneous Privileges section appears on each tab of the security role form, which you can review by navigating to Settings > Administration > Security Roles and opening the desired role.
    • Marked as answer by Jim Glass Jr Tuesday, June 23, 2009 8:46 PM
    Tuesday, June 23, 2009 5:47 PM
  • Installing this hot fix: http://support.microsoft.com/kb/949256/ resolved the issue. Thanks, Richard, for all your assitance, it really helped to narrow down the problem.
    Tuesday, June 23, 2009 6:21 PM