none
Need help with hardware/motherboard please! RRS feed

  • Question

  • Hello

    A few months ago I put together a server using the recommended parts from a Maximum PC article. The motherboard I'm using is the ASUS M4A78 PRO. First off i couldn't use the motherboard disc b/c it said "not compatible with OS" so had to manually install the drivers via device manager. Had it up and running for about 2 weeks, then I came downstairs one morning to "Boot Block Compatible Version .066" Bad Bios Checksum. Starting BIOS Recovery. Then it was looking for a disc or something. I pulled the CMOS battery, reinstalled, and restarted. It worked for a little bit, then got the Blue Screen of Death. One time was for "Bad Pool Header". Another time was for "irql_not_less_or_equal". I tried booting with the M/B disc as well as downloaded the Initial BIOS and most current revision BIOS and the computer just hangs. So now it won't even POST or go to the BIOS or anything. I explained all this to ASUS and the reply I got was "This motherboard is NOT compatible with WINDOWS HOME SERVER", Recommed using XP/VISTA/7. Before I left for my deployment I sent the motherboard back in for RMA and am still gone. I've been looking for a possible replacement board from Gigabyte and MSI. No one really seems to have any answers for a motherboard that will take Windows Home Server.
    I currently have
    AMD Athlon II Dual Core 240 2.8GHz AM3 processor
    CORSAIR XMS2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory Model TWIN2X2048-6400C5DHX

    I'd love for someone to say "OH click 'here' and download 'this' or try using 'this component'....

    Please help!
    Brent

    • Edited by brentagade Wednesday, February 17, 2010 12:41 PM
    • Moved by kariya21Moderator Wednesday, February 17, 2010 6:24 PM hardware question (From:Windows Home Server Software)
    Wednesday, February 17, 2010 12:13 PM

Answers

All replies

  • You should have posted this in the hardware and installation forum instead.
    However, what motherboard are you using now? Warranty?

    I'm using a gigabyte AM2+ board (GA-MA785GM-US2H) and it's been running 24/7 since xmas. This board should work with your CPU and RAM, but still try to claim warranty first.

    • Proposed as answer by Al West Wednesday, February 17, 2010 5:38 PM
    Wednesday, February 17, 2010 12:31 PM
  • I'd just like to add that the GA-MA785GM-US2H supports AM3 - which is the processor owned by the OP.

    You can buy it from these places (USA):
    http://www.google.com/products/catalog?hl=en&q=GA-MA785GM-US2H&cid=6432069789725895697&sa=button#p

    or here (UK):
    http://www.google.co.uk/products/catalog?hl=en&q=GA-MA785GM-US2H&cid=6432069789725895697&sa=button#p


    --
    • Marked as answer by brentagade Wednesday, February 17, 2010 2:58 PM
    Wednesday, February 17, 2010 1:06 PM
  • Thanks much! Sorry I googled this and didnt realize it was under software. I'm will most likely give that board a shot.

    There was still warranty for my ASUS board. I may sell it when I get home.

    Thanks again.

    I may post this in the hardware section for additional help.
    Wednesday, February 17, 2010 2:56 PM
  • Forgot to ask Al...did u have to download anything special? Did the Motherboard disc work with the OS?
    Wednesday, February 17, 2010 4:54 PM
  • You want to ask Bjurran that - I just piped up to say that the motherboard supported AM3 just in case you were thrown by the AM2+ reference.
    --
    Wednesday, February 17, 2010 5:38 PM
  • Bjurran
    did u have to download anything special? Did the Motherboard disc work with the OS? Anything special required or did it take from the beginning?

    Thanks

    Wednesday, February 17, 2010 6:02 PM
  • Hi Brent!
    As with many other gigabyte motherboards, there's something strange with the bios. Unless you have a floppy drive connected, you have to disable everything regarding floppy (even the boot order) to install the OS. I had trouble with the installation stalling at first, but then found out that people had the same issue installing other windows os, and did the same thing to get everything to work.
    There is a sata driver available, but I haven't tried it. (Set my board to legacy ata instead)
    The system works with the default drivers, however I ran the cd anyway. The only issue I have with the original drivers is if I log on locally, I get an error message regarding the ATI graphics. However, I haven't noticed anything not working.
    I haven't tested it yet, but it seems like the mobo cd also installed the HD sound driver. Not that I need it on a headless system, but it seems to be there in case you'd like to play around with it.
    You can't find many server 2003 drivers, however the xp drivers seems to work.

    Note. There's a new mobo rev. out now. I have rev 1.0, there's a rev 1.1 out now as well. Not sure what the difference is, but you should check the number on your board before installing it in case you need to download any drivers.

    Good luck!

    /Stefan, Sweden

    EDIT: in case you haven't already found the drivers: http://www.gigabyte.com.tw/Products/Motherboard/Products_Overview.aspx?ProductID=3141
    Wednesday, February 17, 2010 6:49 PM
  • brentagade and Bjurran,

    Were there any problems fitting the Gigabyte micro-ATX mobo in the Antec ATX case?

    I bought most of the same parts recommended in the MaximumPC article. For better or for worse I waited on buying the Asus mobo, then decided to get a different board based on reviews, problems, availability etc. Luckily I found this post and bought the recommended Gigabyte board. However, I didn't notice that the Gigabyte was a micro-ATX until Tiger had shipped my order. 

    I've heard micro-ATX boards will fit ATX cases with little problem. Just wondering if that was your experience.

    Thanks for the help. Hope your servers are running smoothly.

    Cheers,

    Mike

     


    Monday, April 26, 2010 6:19 PM
  • Hi Mike

    I have a different case. I'm using a Fractal Design, Define R2 case. I didn't have any problems installing the mobo in that case.
    Many ATX cases will work with mini-ITX and micro-ATX, and I'm pretty sure it's the same with Antec, but you'll have to verify that with the Antec spec.
    Not sure what case was listed in that article, but the popular Antec 200 will accept the micro ATX board.

    Regards,

    Bjurran, Sweden

    • Proposed as answer by AH1Cher Monday, May 3, 2010 4:14 PM
    Monday, April 26, 2010 6:39 PM
  • Bjurran,

    Thanks for the help! Everything worked out. This was my first build and I was surprised at how simple assembly was. The GB mobo was a good choice. I disabled all floppies like you said. That helped. The network adapter gave me some issues, but an updated driver cured that.

    Still updating WHS and working on some small issues, but otherwise very happy with the final result.

    Thanks again.

    Cheers,

    Mike

    • Proposed as answer by AH1Cher Monday, May 3, 2010 4:17 PM
    Monday, May 3, 2010 3:39 PM
  • Mike,

    Glad to help. It is correct that you need a new NIC driver. I forgot to mention that. I have similar Gigabyte boards in clients as well and I'm having the same issue when I need to use the recovery disc. (the NIC is detected, but whs try to use wrong driver and cannot get an IP)

    Apart from the NIC, you might note that the SMBus driver is not installed properly. If so, you'll find a package with XP chipset drivers here: http://www.gigabyte.com.tw/Support/Motherboard/Driver_Model.aspx?ProductID=3141&ost=xp#anchor_os
    download, extract and run the setup found in the SBDrv folder.

    You don't need to install the graphics drivers. On my first install I did install it and every time I logged in I got errors regarding the ATI drivers.
    The HD audio drivers seem to install but I never got around to check if the sound is working or not. (I don't need it, never installed it after I reinstalled)

    Remember, as you didn't have the NIC installed during setup, you'll need to allow time to re-boots and install updates for some time. Depending on your internet connection speed.

    Monday, May 3, 2010 4:25 PM
  • Bjurran,

    I did catch the SMBus driver issue. In fact, I think it was responsible for my BSOD right after install. I answered "Yes" when the BIOS asked me to set the SATA drives to AHCI vice IDE. Had to root around the BIOS and change that back (Integrated Peripherals menu, incidentally). That let me boot to WHS, and after I updated the the chipset drivers I was able to set the drives back to SATA.

    Interestingly, the Antec case has a SATA hot-swap port, but the drive still shows up as IDE, not SATA. The primary drive shows SATA, but not the hot-swappable one. Hmmm...

    Like you suggested, I ran the GB driver CD after install to update everthing, which helped.

    I'll try to roll back the graphics drivers. I'm using a 22" HDTV/monitor until I go headless and it looks *horrible* even with an HDMI cable and optimum display settings. I get the ATI driver error, too. Not a big deal, but I bought a BluRay drive and would like to try it out.

    I hear you about the NIC - is this slowing the whole system down? The download speed is slow and the system is overall sluggish even though I downloaded updated NIC drivers. Hopefully the updates will finish and things will speed up a bit.

    Thanks again,

    Mike

     

     

    Monday, May 3, 2010 11:09 PM
  • As I'm running my drives as lecagy IDE, I'm not 100 % sure about this. However, I recall reading something regarding that you need to use SATA port 4/5 to your ESATA drives, and also verify the settings in the bios. Port 4 & 5 should be operating differently from the ports 0-3. As I don't use hot swap, I haven't verified this myself.

    The download speed shouldn't really be a problem, however I recommend that you allow whs to install all updates before you proceed doing anything else. As this is your first whs install, I should probably point out that you should not run windows update the way you do on clients. Open up the console -> settings, you'll find the updates there.

    Regarding the sluggish behavious. All new whs installs are a bit slow in the beginning as all files are being indexed and spread out over the drives. That's one of the reasons you should wait with filling up the shares with data. Also, as pointed out many times before, don't ever copy anything to the d: drive you find on the server. You need to copy files to the network shares, even when working locally on the server.

    • Edited by Bjurran Tuesday, May 4, 2010 6:26 AM Early in the morning, crappy spelling...
    Tuesday, May 4, 2010 6:24 AM
  • Great info. Thanks again for the help. Voted you as "helpful" to bolster your rating. -Mike
    Tuesday, May 4, 2010 8:04 PM
  • Thanks for all the votes. Glad to be able to share my experience.=)

    One other thing. After running the server for a while, I would suggest that you check that the chipset heat sink is not too warm. I had to adjust my fan speeds a little or it would get warm after a while, but this could also be due to the airflow in the case I used. I made sure that the drives should not be too warm, but forgot about the chipset.

    Wednesday, May 5, 2010 5:50 AM
  • A couple more notes as the week progresses:

    1. I put my primary drive in SATA 0 port which made a huge difference in speed. Looking at the BIOS options, 0,1,2, and 3 are for permanent drives, 4 and 5 seem to be the front hot-swap and the rear eSATA. I think I screwed up getting everything to work as SATA and AHCI as I didn't fully read the mobo instructions before installing WHS. No biggee. I know you're running IDE and it sounds like it's working great for you.

    2. Tried to roll back the graphics driver but couldn't find the old driver. Ended up uninstalling the graphics controller - sounds boneheaded now as I could have lost all video, but in the end the graphics were better than ever.

    3. Rebooted and overall performance is up significantly. No more sluggishness. Working to get the initial backups complete on the clients.

    I'll check heat sinks and drives for overtemp. Good idea.

    Thursday, May 6, 2010 4:45 AM