none
Server 2008: Microsoft Software Licensing Service has stopped working RRS feed

  • Question

  • I have Windows Server 2008 installed on a Dell Vostro 1700 notebook, actually on the second hard drive as the first has Windows Vista SP1 on it.

     

    When I installed Windows Server 2008 I opted to not provide the license key until later as I can copy and paste it once in the OS from my MSDN subscription page.

     

    When the OS was installed and I'd installed the NVIDIA drivers and a few roles and features I noticed I get an error Window stating that the Microsoft Software Licensing Service has stopped working. Attempting to start the service within the Services control panel applet succeeds for a few seconds and then I'm presented with the same error. Without this service running I cannot enter my license key and activate my copy of Windows Server 2008 (RTM).

     

    Below is the diagnostics report from the Microsoft Genuine Advantage Diagnostic Tool which I saw was referred to in other posts.

     

    Any help would be greatly appreciated...

     

    Thanks,

     

    Doug Holland

     

     

    Diagnostic Report (1.7.0069.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0
    Online Validation Code: 0x80070426
    Cached Validation Code: N/A, hr = 0x80070426
    Windows Product Key: *****-*****-VWXK6-X8JC9-BFGM2
    Windows Product Key Hash: Q7VNC5MPxsgeWiB92qo4qftsxCk=
    Windows Product ID: 92573-082-2500115-76690
    Windows Product ID Type: 1
    Windows License Type: KMS Client
    Windows OS version: 6.0.6001.2.00030110.1.0.007
    CSVLK Server: N/A, hr = 0x80070005
    CSVLK PID: N/A, hr = 0x80070005
    ID: {A20A1D00-6245-41FC-8CB8-CE0D1D362D76}(1)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Server (R) 2008 Standard
    Architecture: 0x00000009
    Build lab: 6001.longhorn_rtm.080118-1840
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Notifications Data-->
    Cached Result: N/A
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-2920-80070002_025D1FF3-282-80041010_025D1FF3-170-80041010_025D1FF3-171-1_025D1FF3-434-80040154_025D1FF3-178-80040154_025D1FF3-179-2_025D1FF3-185-80070002_025D1FF3-199-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files (x86)\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{A20A1D00-6245-41FC-8CB8-CE0D1D362D76}</UGUID><Version>1.7.0069.0</Version><OS>6.0.6001.2.00030110.1.0.007</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-BFGM2</PKey><PID>92573-082-2500115-76690</PID><PIDType>1</PIDType><SID>S-1-5-21-417597918-1288980900-3735462928</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Vostro 1700                     </Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A06</Version><SMBIOSVersion major="2" minor="4"/><Date>20080203000000.000000+000</Date></BIOS><HWID>55303507018400FA</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL  </OEMID><OEMTableID>M08    </OEMTableID></OEM><BRT/></MachineData><Software><Office><Result>109</Result><Products/></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

     

    Thursday, March 13, 2008 8:11 PM

Answers

  • Hello Doug,

     

      The only thing I can suggest is to try the below steps to restart the Service, but if that doesn't work the only things (that I know of) that would stop the Service from running is a) some program is suppressing the service or b) there is something wrong with the slsvc.exe file (that runs the Service).

     

      but since the Diagnostic Report doesn't show that the slsvc.exe file, itself, has been modified at all, I feel it's unlikely that there is something wrong with slsvc.exe. Either way, the issue would be outside of my knowledge and I would suggest reposting your question to the Server 2008 forums at http://forums.microsoft.com/TechNet/default.aspx?ForumGroupID=161&SiteID=17 

     

    (Note: these steps are targeted to Vista, so I can't be sure that the steps are exactly the same for Server 2008)

     

    If you have acces to the Start button:

    1) Click the Start button

    2) Type: cmd in the Start Search field

    3) At the top the Start window, you will see cmd.exe

    4) Right Click cmd.exe and select Run as Administrator

    5) Type: net start slsvc

     

    If you do not have access to the Start button:

    1) Click the option Access computer with reduced functionality

    2) A Browser will open, type: %windir%\system32 into the address field

    3) Find the file cmd.exe

    4) Right Click on the cmd.exe and select Run as Administrator

    5) Type: net start slsvc

     

    Thank you,

    Darin Smith

    WGA Forum Manager

    Thursday, March 13, 2008 8:45 PM