none
Problem with WLW not supporting enlarged screen dpi

    Question

  • I've installed the latest RC beta of Windows 7 on my WUXGA laptop, setting screen dpi to 154% to enlarge the fonts to fit the 1920x1200 screen.
    WLW ran OK on XP2, albeit with the slightly wrong font control of IE7.  However it was beatifully sharp.   Installing IE8, WLW seemed to override DPI control, rendering everything at 96dpi, which made the preview very small.

    On the first W7 beta, from January, it too showed the WLW window with the fonts too small, again ignoring increased dpi setting.
    Now on the RC beta of W7, it seems to have said 'enough!', we are going to definitely increase DPI!  
    And it's done so.  However.... all the fonts are fuzzier, it's treating them as if they were simply graphics to enlarge.  Weirdly, even the menus and dialog boxes are bring enlarged badly, fuzzily.  

    This feels like 'out of the frying pan, into the fire'.

    I've long loved the 148dpi of my laptop screen.  But I'm starting to feel it's too much trouble.  Do the WLW developers know this problem exists?

    Sunday, May 10, 2009 11:18 PM

All replies

  • I don't know why the fuzziness suddenly started with Win7 RC, but you can probably get rid of it by going to C:\Program Files\Windows Live\Writer, right-clicking on the WindowsLiveWriter application file, select Properties, go to the Compatibility tab, and uncheck "Disable display scaling on high DPI settings".

    We're trying to figure out what's wrong with the font size rendering in IE8, haven't fully gotten to the bottom of it yet. However, in the meantime it might help to try some different values in the registry key Noah Coad talks about here:
    http://blogs.msdn.com/noahc/archive/2008/06/23/embedded-ie-text-size-too-small-or-large.aspx

    I think 03,00,00,00 might be better for you. You'll have to restart Writer after changing the registry value.

    Thursday, May 14, 2009 12:00 AM
    Owner
  • Thanks, Joe!  WLW isn't the only one with this issue.  iTunes too, and other programs which in the last version simply ignored display dpi.  Adobe Air progs included.

    For the time being I've simply gone back to 96dpi for the whole system, which does remove the problem (and makes Windows 7 - for me - the best OS I've ever used, I even prefer it to Mac).  But I'm rather reduced to squinting at the tiny fonts and icons - luckily I'm short sighted!

    I'll try to get some actual work done for my boss, before I spend time tweaking in the way you describe. :-)
    Thursday, May 14, 2009 1:20 PM