locked
Can´t change default organization in CRM 2011 Deployment Manager RRS feed

  • Question

  • I just installed CRM 2011 and succesfully imported my organization from CRM 4.0. But now I´ve still got the dummy-organization "Test" as default and can`t change it with deployment manager. When i right-click on my imported organization, "Set as default organization" doesn´t even appear.

    Hope someone can help me. Regards,

    Erwin

    Wednesday, April 27, 2011 10:22 AM

Answers

  • Hi all,

    This issue was raised in the Beta forums but since it is now retired, I'll repost my answer. Please let me know if you have questions.

    Thanks,

    Matios

     

    This is not a bug. We removed the feature because it was no longer of use. I think there's confusion between the default org that gets loaded when accessing http://server and the default org that used to exist in Deployment Manager. The two are different.

    1.    User's Default Org: when a user is added to an org for the first time in a deployment, the user's default org, and thus the org that is loaded by default when accessing http://server is set to this org. Any subsequent orgs the user is added to will not change this default org, unless it is deleted. The default org in this sense is a per user setting that cannot be modified.

    2.    The Default Org in Deployment Manager is not related to the above in any way. It was used in V4 for some features such as the first org chosen for upgrade. This feature is no longer required in CRM 2011 and only brought confusion.

    Wednesday, April 27, 2011 5:20 PM

All replies

  • Hello Erwin,

    Please make sure you're a Deployment Administrator. If not, please ask the User (with Domain Admin privileges) that installed the CRM to help you change the default organization.


    Cornel Croitoriu - Senior Software Developer & Entrepreneur

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Biz-Forward.comCroitoriu.NET

    Wednesday, April 27, 2011 12:02 PM
  • Hi Cornel,

    Well, I am the Domain Admin who installed CRM, and of course I am Deployment Admin. But I still can´t change the default organization, the option doesn´t even show up in the context menu as it`s supposed to be.

    Regards,

    Erwin

    Wednesday, April 27, 2011 12:08 PM
  • Erwin,

    I have the same problem which the "Set as default organization" does't appear in deployment manager. Did you find the answer?

    Ben

    Wednesday, April 27, 2011 2:46 PM
  • Hi all,

    This issue was raised in the Beta forums but since it is now retired, I'll repost my answer. Please let me know if you have questions.

    Thanks,

    Matios

     

    This is not a bug. We removed the feature because it was no longer of use. I think there's confusion between the default org that gets loaded when accessing http://server and the default org that used to exist in Deployment Manager. The two are different.

    1.    User's Default Org: when a user is added to an org for the first time in a deployment, the user's default org, and thus the org that is loaded by default when accessing http://server is set to this org. Any subsequent orgs the user is added to will not change this default org, unless it is deleted. The default org in this sense is a per user setting that cannot be modified.

    2.    The Default Org in Deployment Manager is not related to the above in any way. It was used in V4 for some features such as the first org chosen for upgrade. This feature is no longer required in CRM 2011 and only brought confusion.

    Wednesday, April 27, 2011 5:20 PM
  • Hi Matios,

    thanks a lot for clearing up that issue. I only tried CRM with the admin-account that I used for installing it, so it was obviously bound to the initial "Test"-organization. All the other users have the correct default org, just as you described.

    Regards,

    Erwin

     

     

    Thursday, April 28, 2011 6:41 AM
  • Thanks for your reply.

    There is only one problem with that. When a users default organization is disabled and a new organization is deployed, the user cannot access the new deployment by http://server anymore. We have a testserver where we do different test-deployments. Old deployments are disabled and the user should land on the new test-deployment. Is ther no chance to set a new default organization for the users or a specific user?

     

    Friday, September 16, 2011 6:56 AM
  • Hi,

     

    Unfortunately, there's currently no supported way to change the default organization of a user. You'll have to go through support channels and open a case.

     

    Thanks,

    Matios

    Sunday, September 18, 2011 3:34 AM
  • I agree to Ivolio, we also work often with redeployments on testsystem. I opened a connect feature:

    please vote

    https://connect.microsoft.com/dynamicssuggestions/feedback/details/713650/possibility-to-change-the-default-org#tabs

    Friday, March 9, 2012 8:31 AM
  • Monday, March 12, 2012 10:55 PM
  • that was the biggest nonsense ever.
    Thursday, February 6, 2014 12:35 AM