locked
WHS 2011 Sharing issues RRS feed

  • Question

  • I'm not sure if this is the right place for this, but I have Windows Home Server 2011, which is basically a bare bones Windows Server 2008 R1. I have 3 Windows 7 machines and an XP machine on the network. Where my issue is, is with sharing folders. It's a basic share of my music and videos, so that the other computers and the 2 consoles (Xbox 360 & PS3) we have, can access the content. Some days it works fine and other days I can't access the folders. I get the "You don't have permission" errors when trying to access them. I've check the shares over and over and I can't figure out what I did wrong. I have the server in the Home Group with the machines that run 7, and when the shares die, so does the HomeGroup shares. 

    On the server I have 3 accounts, Admin, me, and guest. When the shares die, I'm prompted to log in from one of the Windows 7 machines. If I type guest in the username and hit enter, it works. I've been all over Google looking for a solution and one solution I read said that if you turn off the file sharing on the server and turn it back on, it comes back to life. That does work, but that isn't a permanent solution, especially if I have to do this everyday. All I know is when you set the permissions correctly, it should work flawlessly. I even have the permissions set for everyone to have full control of these 2 folders. I even had my business partner, who is a server administrator, look at it and he can't figure it out either. 

    Is this common to WHS 2011? Does anyone have a resolution to this? Thanks!

    Wednesday, October 26, 2011 1:58 PM

All replies

  • I had a similar problem with WHS2011.  Sometimes I could navigate to the server's shares then sometimes I couldn't. 

    I had to log off and then log on again to be able to connect which was really annoying.

    I also could not get any media from the server to show up in Windows Media Player and this was tearing my hair out too!

    I discovered from another post, that once you make the server 'Leave the Homegroup' the problem is fixed (well it did for me anyway).

    To do this:

    1. log on to server using Remote Desktop Connection
    2. click Start -> Network
    3. click button at the top 'Network and Sharing Centre'
    4. where it says 'HomeGroup' click the 'Joined' link
    5. click the 'Leave the HomeGroup' link

    I think that having the server as a member of the Homegroup confuses the security settings.

    see: http://social.microsoft.com/Forums/uk/whsvailbeta/thread/170846cc-4a0d-4958-a9ee-eba409d12fd4

    Monday, February 13, 2012 11:13 PM
  • HomeGroup settings overide those set up in the Server Dashboard. Best to remove it from the HomeGroup and just use the Dashboard for access permissions.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Monday, February 13, 2012 11:31 PM