locked
Validation error 0x80080299 RRS feed

  • Question

  • I downloaded the latest WGA update today and I received the message 'You have encountered an unknown error...  0x80080299' when trying to validate Windows XP.  My copy has been validated before and never had problems.  I've tried a few of the solutions I've read in the forums already including:  using tools/manage add-ons to ensure the WGA is enabled, deleting the legitcheckcontrol.ddl & trying to revalidate, running the diagnostic tool which gives no errors, redownloading the WGA, rebooting, etc..    Please help.

     

    A download of the diagnostic tool is:

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: N/A
    Windows Product Key: *****-*****-GD6GR-K6DP3-4C8MT
    Windows Product Key Hash: s2kt66ZJWfV4nS1wFD5F9bxTSDw=
    Windows Product ID: 76477-OEM-2111907-00102
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    ID: edfb009e-dd99-45da-8563-abbc995d9696
    Is Admin: Yes
    AutoDial: Yes
    Registry: 0x0
    WGA Version: Registered, 1.5.723.1
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic: 70AFE6BE-116-800401f3_63BB5E84-365-800401f3_E2AD56EA-252-800401f3_16E0B333-138-800401f3_70AFE6BE-116-800401f3_63BB5E84-365-800401f3_E2AD56EA-252-800401f3_16E0B333-57-800401f3
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: N/A
    File Exists: Yes
    Version: 1.7.18.5
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: Registered, 1.6.21.0
    Signed By: Microsoft
    Office Diagnostics:

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details:  

    Saturday, April 14, 2007 10:50 AM

Answers

All replies

  • Jwalk,

    Based on an error code (0x800401f3) in your report and previous posters with the same error code, you may want to try to download and install an updated XML core services package.

    On this page http://www.microsoft.com/downloads/details.aspx?familyid=993c0bcf-3bcf-4009-be21-27e85e1857b1&displaylang=en choose to download the msxml6.msi file (it's the first one on the list of four, 1.5MB in size).

    After running this package, restart the computer and then retry validation at www.microsoft.com/genuine.

    If you validate successfully, then go on and try to get an Update or other WGA-protected downloads to verify that all WGA files and settings are working normally.

    If no joy, then please submit an email support request here:  https://support.microsoft.com/oas/default.aspx?c1=509&gprid=9860

    Good Luck!

    Saturday, April 14, 2007 2:51 PM
  • I downloaded and installed the mxsml6.msi, restarted, and tried to revalidate with the same results - error 0x80080299.  I also had notification to download the WGA update again, which I then did, tried to revalidate, same results.  I've sent an email ticket to the support address above.
    Saturday, April 14, 2007 5:45 PM
  •  

    Hi Jwalk,

     

    After creating your service request, would you post the confirmation number in this thread? I would like to follow the progress of this issue.

     

     

    Thank you,

    Darin Smith

    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

    Monday, April 16, 2007 8:01 PM
  •  Hi Jwalk,

     

    We have been testing this issue and I have been able to reproduce the error and then was able to fix it using the below steps. The cause is that the registry entry ‘HKEY_CLASSES_ROOT\MSXML.DOMDocument’ is missing. This is the registry key for MSXML 3.0 and should be there on all Windows XP computers. WGA uses the XML service, on a computer, to be able to validate that computer.

     

    Fix a:

    1) Click 'Start' button, then 'Run...'

    2) In the Run window, Type: regsvr32 msxml3.dll  <Click OK>
    (Note: This will register the msxml3.dll and the registry entry ‘HKEY_CLASSES_ROOT\MSXML.DOMDocument’ will be generated)

     

    If this does not work, the msxml3.dll may be missing or corrupt. Follow the below steps, in that case:

     

    Fix b:

    1) Go to the Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7) download page at  http://www.microsoft.com/downloads/details.aspx?FamilyID=28494391-052b-42ff-9674-f752bdca9582&DisplayLang=en

    2) From the files available, download “msxml3.msi”

    3) Double click the file and follow the steps to install.

    4) Click 'Start' button, then 'Run...'

    5) In the Run window, Type: regsvr32 msxml3.dll  <Click OK>

     

    Please tell us how this works for you.

     

    Thank you,

    Darin Smith

    MGA Forum Program Manager

    --------------------------------------------------------
    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

    Wednesday, April 25, 2007 6:11 PM
  • Hello,

    I've opened ticket number SRX1033538539 with support, but have not been able to resolve the problem.  The current action steps are similiar - to use the regsvr32 command for msxml.dll, msxml2.dll and msxml3.dll.  I received errors trying to register msxml2.dll and msxml3.dll, however msxml.dll registered fine.  However, this caused explorer to stop working while google toolbar is installed and I am not pleased.

     

    I tried the step below and downloaded & installed msxml3.msi without any error messages.  I then tried to register the msxml3.dll and received the same error message I had received before.  The error message is as follows:  "DllRegisterServer in msxml3.dll failed.  Return code was 0x80004005"  By the way, I have tried disabling all non-microsoft services and startup items with the same result.  It clearly appears the msxml3.dll is the problem.  Can the registry be manually edited?

     

    Any further steps you can add will be appreciated.

     

    Regards,

    JWalk

    Sunday, April 29, 2007 3:04 PM
  • Some additional information.  I ran Regedit to view the registry.  When I click on the .xml folder under HKEY_CLASSES_ROOT to view it, I immediately get an error "Cannot open .xml:  Error while opening key".  Random selection of other folders shows no problems.  It appears the registry has been corrupted.

     

    JWalk

    Sunday, April 29, 2007 3:21 PM
  • I have the same problem. I tried many different things but nothing works. Somebody, please HELP!

     

    Lucie

    Wednesday, May 2, 2007 12:35 AM