locked
New Drive Letter RRS feed

  • Question

  • I just switched over to Windows 7 Ultimate on my home desktop with 2 hard drives. a 'C' drive with operating system and a 'D' drive for data. (Photos, videos and music.) 
    Also installed 7 Ultimate on my laptop.
    MY problem is in Windows Home Server.
    If I try to restore the laptop, everything is fine. The restore only shows the one volume.
    But, if I try to restore my main desktop, it shows THREE drives.
    A 'System Reserved'  (100MB) which is now 'C'. Another is 'D' Data, (152585 MB) and a 3rd. one which says 'E' Volume 3, (152485MB).
    I've tried several different ways to restore my desktop, but can't get it to restore the regular 'C'.
    What am I doing wrong??
    Why does it have the System reserved and the laptop does not?
    I did not have this problem with both computers running Vista.
    Perhaps I need to change some drive letters?
    Anyway, I really need to get this corrected.
    Thanks for any help you may give.
    Wednesday, February 17, 2010 7:56 PM

Answers

  • Thank you!!
    I see how to do it now.
    WHS does not seem to remember these settings.
    Apparently you have to set these before each restore.
    Is that correct?

    Yes.

    But no problem.
    Easy when you know how. 
    You folks are great!!

    • Marked as answer by rspilot Friday, February 19, 2010 4:46 PM
    Friday, February 19, 2010 1:00 AM
    Moderator

All replies

  • I assume you did a fresh install of Windows 7 on your desktop, rather than an upgrade in place? The system reserved partition is created as part of a clean installation of windows 7.

    The drive letters that Windows Home Server assigns in the backups are not always the same as the drive letters on the machine. So you will restore the system partition (C:) to the system partition (no letter on your PC when it's running), the data partition (D:) to the data partition (D:), and the third partition (E:) to the system partition (C: when your computer is running) on your PC.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, February 17, 2010 8:03 PM
    Moderator
  • But when I did this, I had no operating system on my 'C' drive. It was on my 'D' drive. The only thing on my 'C' was the reserved partition.
    The source volume is correct, the destination volume that goes to my computer is not.??? And as far as I can see, can't be adjusted.
    Destination Volume has:
    C: System Reserved (100MB)
    D: Data (152585MB)
    E: Volume 3 (152485MB)

    I set the Source at:
    C: System Reserved (100MB)
    D: Data (152585)
    C: Volume 3 (152485MB)
      
     I already have an 'E' drive. Its my 1st. DVD drive. 'F' is 2nd. DVD drive and G, H, I, J, are my flash card reader.
    So where did WHS put the operating system? It put it on my 'D' drive.??? All the other data on the 'D' was gone.
    I had to re-install Windows again and also the data I had on my original 'D'.
    I just want to know I can back it up correctly.
    I had wanted to send a small jpeg to show but saw no way to attach.
    Sorry to be so long but trying to give you all info I can.
    Lee
    Thursday, February 18, 2010 3:27 AM
  • But when I did this, I had no operating system on my 'C' drive. It was on my 'D' drive. The only thing on my 'C' was the reserved partition.
    The source volume is correct, the destination volume that goes to my computer is not.??? And as far as I can see, can't be adjusted.
    Destination Volume has:
    C: System Reserved (100MB)
    D: Data (152585MB)
    E: Volume 3 (152485MB)

    I set the Source at:
    C: System Reserved (100MB)
    D: Data (152585)
    C: Volume 3 (152485MB)
      
     I already have an 'E' drive. Its my 1st. DVD drive. 'F' is 2nd. DVD drive and G, H, I, J, are my flash card reader.
    So where did WHS put the operating system? It put it on my 'D' drive.??? All the other data on the 'D' was gone.
    I had to re-install Windows again and also the data I had on my original 'D'.
    I just want to know I can back it up correctly.
    I had wanted to send a small jpeg to show but saw no way to attach.
    Sorry to be so long but trying to give you all info I can.
    Lee
    You need to use the MMC Disk Management tool (I believe it's under the Advanced button if I remember correctly) and manually assign the correct drive letters (or, in the case of the System Reserved partition, lack of drive letter) to the destination partitions.
    Thursday, February 18, 2010 3:54 AM
    Moderator
  • Thank you!!
    I see how to do it now.
    WHS does not seem to remember these settings.
    Apparently you have to set these before each restore.
    Is that correct?
    But no problem.
    Easy when you know how. 
    You folks are great!!
    Thursday, February 18, 2010 2:40 PM
  • Thank you!!
    I see how to do it now.
    WHS does not seem to remember these settings.
    Apparently you have to set these before each restore.
    Is that correct?

    Yes.

    But no problem.
    Easy when you know how. 
    You folks are great!!

    • Marked as answer by rspilot Friday, February 19, 2010 4:46 PM
    Friday, February 19, 2010 1:00 AM
    Moderator
  • Sorry to dredge up an old thread, but I have a similar problem and don't understand the solution given above.  Here is my situation:

    - Clean install of Win7 x64, but a problem necessitated a system restore

    - I am in the midst of the restore at the moment

    (- Thanks to another thread, I was able to solve the Realtek driver issue)

    - The original system had a boot drive (C), the system reserved partition (no letter), and a data drive (D)

    - Restore wants to make the data drive C, the system partition D, and the boot drive E

    - I went into Disk Management to change the letters, but got dire warnings about the effect this would have on drivers, etc. What should I do?

    - If I leave the letters as Restore wants to have them, can I still boot into Windows correctly? Can I change the drive letters later? I'm assuming the answers to both of these questions are no, which leaves me the problem of reassigning the letters now without mucking up the whole thing.

    Thanks!

    (Apologies in advance if this is a duplicate post)

    Sunday, August 8, 2010 3:36 PM
  • If you re-assign the drive letters as the computer has them, you won't have any driver issues. I don't know why WHS changes them, but if you put them as they are in the computer, it will work great.

    Just an extra issue you have to contend with but no biggie.

    I do a lot on my computer and have to restore every so often.

    Works great!!!

    Sunday, August 8, 2010 3:45 PM
  • Thanks  for the reply!  I know this must be obvious, but I don't want to mess up the restore, so want to be absolutely clear.  I'm in the midst of re-specifying the drive letters, changing my boot to C and data to D, but don't see a way to make the 100MB system reserved partition unlettered, as it was before.  Should I give it something like Z?  What did you find?

    ETA: And as my "Source Volume" pointing to the System Reserved "Destination Volume", do I select "None" or my C (boot) drive, since the latter is where it resided physically?

    • Edited by boffo67 Sunday, August 8, 2010 4:11 PM clarification
    Sunday, August 8, 2010 4:01 PM
  • Yes, 'Z' will work fine. I just use 'P'.lol Any letter that your not using.

    It will than re-image the drive as you originally had it.

    Works so well that you will feel much more protected.

    Only problem I've ever had was when I changed to a larger and different hard drive. It wouldn't boot.

    But as long as you are using the same drive, you can re-image it with no problem.

     

    Sunday, August 8, 2010 4:11 PM
  • Great!  And as you answered that, I added a further question, which I think I understand from your other answers.  Sounds like I should select "None" as the Source for the System Reserved volume, and Windows will figure out what to do with it.
    Sunday, August 8, 2010 4:14 PM
  • Well, that one I don't know. It might need a source??

    But if it won't work, just redo.

    Windows has a nasty habit of really being dumb sometimes.

    Sunday, August 8, 2010 4:18 PM
  • And it indeed it did work.  Thanks again for all the help.
    Sunday, August 8, 2010 4:51 PM