locked
Cannot restore Win7 PC from WHS server, drivers not loading. RRS feed

  • Question

  • I have a new PC (iCore 710 CPU) with Win7 Ultimate working OK with stripled raid on 4 disks. The Windows score is 6.9 limited by disk. Automated backups work OK to WHS. (as do 5 other PCs).

    I decided to change the Raid configuration and restore the whole PC from WHS. I copied the WHS drivers directory from server USB drive. I made an up to date restore CD. 

    Restore fails to load network driver and hence search for home server fails. The network LED is always off. So I changing bios setting for Realtec network driver to load driver from bios. Now the network LED flashes on bootup, but goes out when WHS CD restore is loading drivers. I get a failure to load network drivers from USB etc and hence the server connection search fails.

    Have you any suggesions ? I want my PC back without having to reinstall OS Win 7 and all applications.


    nutty craft
    Sunday, February 14, 2010 11:18 AM

All replies

  • Take a look at this FAQ .
    I'm not on the WHS team, I just post a lot. :)
    Sunday, February 14, 2010 3:50 PM
    Moderator
  • I am having much the same issue with a new Core i3 build with Windows 7. I cannot get the restore CD to install a NIC driver. I tried the stuff in the above mentioned FAQ, downloading the Realtek drivers from the link. I put the drivers on a USB drive. I put 'em in the root dir, in a folder called Drivers, nothing worked. I tried opening a backup of the client computer and copying the Windows Home Server Drivers for Restore folder to a USB drive. I copied the folder into the root, I copied the folder to another folder named Drivers, I copied the subfolders to the root, and I copied all the individual files to the root of the USB drive. I even dragged out an old floppy drive and tried that. No way can I get the network drivers installed so the client can find my server. The network card shows up on the Restore CD's initial hardware assessment, but the light on the back of the computer isn't lit, and I can't see my server.

    My server is working fine with 6 other computers although I haven't tried a restore on all of them to see if this is a problem. The new Core i3 might be the only Realtek NIC computer I have, others are Marvel or Nvidia I think. I learned this when HD died on the new Core i3 build on day 2 and I wanted to restore. I couldn't do it and I ended up reinstalling Windows 7.

    So what's the trick to installing these drivers that I'm missing here? It shouldn't be this hard, but I spent all day rebooting the Restore CD, trying stuff, to no avail!
    Monday, February 15, 2010 2:41 AM
  • Try this Restore CD, very simple, worked for me with the Realtek issue:
    Hit the download link for Version 1.2:
    http://xfiles.breakinghomeserver.com/2009/11/30/whs-client-restore-v1-2/ 
    • Proposed as answer by thosj Monday, February 15, 2010 6:29 PM
    • Unproposed as answer by kariya21Moderator Tuesday, February 16, 2010 12:41 AM
    Monday, February 15, 2010 2:38 PM
  • That worked! Thanks a mil.
    Monday, February 15, 2010 6:30 PM
  • Great to hear that!  I'm a big fan of simple solutions.
    Monday, February 15, 2010 6:45 PM