locked
Problem with installation SrsDataConnector RRS feed

  • Question

  • Hello,

    I have faced with a challenge problem during reconfiguration my CRM environment..
    I use such configuration for CRM:

    CRM server - ServerCRM1
    Database\Reporting Server (used only by CRM) - ServerDB1 (MS SQL2008 SP2)

    I've tried to move CRM's databases and reporting service to another server.
    Databses should be moved to a server - ServerDB2. (MS SQL2008 R2, I've created new not-default instance)
    Reporting service should be installed on the CRM server - ServerCRM1.

    I've moved CRM's databases to ServerDB2. I've used SQL aliases.
    Then I've tried to move Reporting Service to ServerCRM1. I've used this guide: http://msdn.microsoft.com/en-us/library/ms156421.aspx . I've successfuly configured Reporting Service, but I can't install the SrsDataConnector on this server. If I try to install the SrsDataConnector I receive this error:

    The specified database has a later version.

    Information from the installation log:

    verbose| Retrieving config database version Provider=SQLOLEDB;Data Source=CRMSQL;Initial Catalog=MSCRM_CONFIG;Integrated Security=SSPI ...
    Info| Config database version: 5.0.9688.583.
    Error| Check ConfigDatabaseVersionValidator : Failure: The specified database has a later version.

    SrsDataConnector installation files are updated (server has access to the internet).

    I thought that this problem is related to different versions of SQL instances which host CRM databases.
    ServerDB1 (MS SQL2008 SP2) - hosted CRM databases
    ServerDB2 (MS SQL2008 R2) - hosts CRM database

    So I've attached CRM databases to the server ServerDB1, which hosted them previously and has Reporting Service role, and removed SrsDataConnector from this server.
    Then I've tried to install SrsDataConnector again, but receive the same error.

    Please help me to resolve this issue.
    Thursday, February 9, 2012 11:26 AM

Answers

  • I've found a solution. We used CRM 4.0 which was updated to CRM 2011. I've tried to use  SrsDataConnector from CRM 4.0 - it was my mistake. I've downloaded\installed SrsDataConnector from CRM 2011. It works.
    Friday, February 10, 2012 12:11 PM