locked
Firewall must be off for me to connect to printer RRS feed

  • Question

  •  

    I have a windows xp box that has a USB printer. The printer is shared by name of \canon. I have windows live one care enabled and running on this box. Additionally I went to the firewall settings and enabled the printer sharing by selecting te checkbox.

     

    I have a windows vista ultimate laptop that is trying to add the printer as a network printer using:

    \\192.168.1.4\canon (192.168.1.4 is the xp box).

     

    However it cannot communicate with it. When I disable the windows live one care firewall on the XP box, then I can add the printer from my vista laptop.

     

    I am unable to figure out a way to have the live onecare firewall active and still share the printer.

     

    Both machines are using wireless, connecting to the same router and are on the same subnet.

    Wednesday, December 12, 2007 3:08 PM

Answers

  • I suggest contacting support. Support can be reached by using the help link in the One Care console.

    Thursday, December 13, 2007 3:29 AM
    Moderator

All replies

  • Wednesday, December 12, 2007 6:47 PM
    Moderator
  •  

    None of the articles helped. Additionally most of the instructions on them were severely outdated. My windows live onecare doesn't have a network "location" tab or anything like that on my XP nor vista box.

     

    Turns out i can't connect to the XP box at all without turning off the onecare firewall on it, no files printers or anything.

     

    Thursday, December 13, 2007 1:26 AM
  • I suggest contacting support. Support can be reached by using the help link in the One Care console.

    Thursday, December 13, 2007 3:29 AM
    Moderator
  •  bpatters wrote:

     

    None of the articles helped. Additionally most of the instructions on them were severely outdated. My windows live onecare doesn't have a network "location" tab or anything like that on my XP nor vista box.

     

    Turns out i can't connect to the XP box at all without turning off the onecare firewall on it, no files printers or anything.

     

    All of the articles are current and apply to version 2.0 and the Printer Sharing feature of OneCare 2.0. This feature does not exist in 1.6, so I suspect that you are still using version 1.6.

    Click Help/About in OneCare to verify this.

    Now, assuming that you are using 1.6, open OneCare, click on Change settings, click on the Firewall tab and then the advanced button. There should be an entry for enabling File and Printer Sharing for the Subnet only or with all computers, including the Internet. If neither item is checked, check the Subnet only option and see if the problem is resolved. If Subnet does not allow sharing to work, place a check next to the other option - all computer. This does not expose File and Printer sharing if you are behind a router, but if the PCs are laptops and do connect to a public connection, not under your control, you should disable this manually when off of your network.

     

    As Jim noted, if none of this works, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

    -steve
    Thursday, December 13, 2007 3:57 PM
    Moderator