locked
CRM 4 on Port 5555? RRS feed

  • Question

  • I installed the CRM 4 software some time ago and I remember it insisting it use port 5555. Now within the next couple of days I have to move it to a new server. When I install it how can I configure it to use Port 80.

     

    A long shot - I was going to use a DNS alias for internal users so http://machinename/CompanynameCRM becomes http://DNSAlias/CompanynameCRM But I would like to set it up so it could be accessed via the DNS alias or machine name directly.

     

    Tuesday, March 18, 2008 5:33 PM

Answers

  • David,

     

    If there isn't any website using port 80 in your new server, you can just create a new website in IIS with port 80, then select this website when you install CRM 4.

     

    Cheers,

    Jim

     

    Tuesday, March 18, 2008 11:35 PM
    Moderator
  • Hi David,

    There are two ways to achieve this task...

     

    1. Configure during the CRM setup

    When you run the deployment tool, it give you two option i.e. to create CRM web as default or create a new website in IIS. If you keep it default, setup will automatically configure IIS and web will be available on port 80. Keep in mind that in this way, CRM web won't be available using port 5555. Now it will just be available using port 80...

     

    2. Configure IIS after installation

    Suppose you have already configured to use port 5555 in your new deployment and now you want to change it to use default port 80. Follow the below steps:

     

    open IIS -->expand your IIS server on your computer --> expand website node --> right click "default web site" node and click its properties --> on HOme Directory tab define the path of CRMWEB folder in the "local path" text box --> on "Document" tab bring default.aspx on the top as defualt page --> on directory security tab, click edit in "Authentication and access control" --> disable anonymous access --> enable usage of integrated window authentication -->click ok -->click Apply --> click OK --> restart IIS

     

    Now you will be able to access your CRM using both http://CRMURL or http://CRMURL:5555

     

    Hope this resolves your problem. Inform if you still get stuck with any issue...

    Wednesday, March 19, 2008 5:38 AM

All replies

  • David,

     

    If there isn't any website using port 80 in your new server, you can just create a new website in IIS with port 80, then select this website when you install CRM 4.

     

    Cheers,

    Jim

     

    Tuesday, March 18, 2008 11:35 PM
    Moderator
  • Hi David,

    There are two ways to achieve this task...

     

    1. Configure during the CRM setup

    When you run the deployment tool, it give you two option i.e. to create CRM web as default or create a new website in IIS. If you keep it default, setup will automatically configure IIS and web will be available on port 80. Keep in mind that in this way, CRM web won't be available using port 5555. Now it will just be available using port 80...

     

    2. Configure IIS after installation

    Suppose you have already configured to use port 5555 in your new deployment and now you want to change it to use default port 80. Follow the below steps:

     

    open IIS -->expand your IIS server on your computer --> expand website node --> right click "default web site" node and click its properties --> on HOme Directory tab define the path of CRMWEB folder in the "local path" text box --> on "Document" tab bring default.aspx on the top as defualt page --> on directory security tab, click edit in "Authentication and access control" --> disable anonymous access --> enable usage of integrated window authentication -->click ok -->click Apply --> click OK --> restart IIS

     

    Now you will be able to access your CRM using both http://CRMURL or http://CRMURL:5555

     

    Hope this resolves your problem. Inform if you still get stuck with any issue...

    Wednesday, March 19, 2008 5:38 AM
  • Great! thats really helpful thanks!!!

     

    Wednesday, March 19, 2008 10:50 AM