locked
BTHomeHub Router - Remote Access not working now RRS feed

  • Question

  •  

    Hi,

     

    I have replaced my old netgear router with the one BT sent to me, I have made sure the UPNP is enabled and it is. Other programs that configure routers via upnp work fine, but Homeserver doesn't like it. However I can get around this manually.  But the problem then is that I can not setup the domain name again to xxxx.livenode.com, when I enter my passport and password i get the error

     

    Microsoft Live ID Server is unavailable. Please try again later. 80048869

     

    However if I check the status page on the net from the server, it says that all live services inc passport are fully working!

     

    I can't even create a new domain, as it doesn't let me login with my usual live ID i use for hotmail etc.

     

    Can anyone help?

     

     

    Monday, September 10, 2007 10:14 PM

Answers

  • Hi Keith,

     

    I have got it to work again. I have expanded my previous post with more detailed instructions, hope this helps.

     

    Here is the list of instructions I followed.

    1. Reboot the router.
    2. Disable UPnP on the router.
    3. Assign service to the server I tried a different tack here.
    4. On the left hand menu in advanced you should see "Application Sharing" click on this.
    5. In the middle of the screen you should see three heading Game or Application ,Device,Log
    6. Underneath these are some boxes with dropdown menus. In points 6 and 7
    7. Choose HTTP from list of services in drop down menu and assign to server again from drop down menu.This associates Port 80.
    8. Choose HTTPS from list of services in drop down menu and assign to server again choose this from drop down menu. This associates Port 443.
    9. Then we have to create a ne service, in the centre of the screen you should see the following text in blue "click here"
    10. Click on that.
    11. Enter a name for your new rule - WHS-RemoteAccess
    12. Then click radio button called manual entry of port maps.
    13. Then click next.
    14. This brings up headings shown below
    15. Protocol Port Range Translate To ... Trigger Protocol Trigger Port
    16. From drop down choose TCP enter 4125 in both boxes for port range.
    17. Leave the rest on the boxes blank and click add then apply.
    18. Return to the application sharing page and repeat point 7. choosing your newly named Service as in point 11.
    19. Making sure you assign it to the server.
    20. Then tested connection in WHS console and got four green ticks.
    21. Have tested remote access from within the network and can login with no problems.
    22. Can even log on to server this brings up WHS console.
    23. Will check tomorrow from work - yet again.

    BTW I am using the RC with livenode. I only set up the livenode address this week.

     

    Check this hyperlink for screenshots as well.

    http://www.portforward.com/english/routers/port_forwarding/BT/BTHomeHub/HTTPS.htm

     

    Regards,

     

    Andi

     

    Thursday, September 13, 2007 7:47 PM

All replies

  • Hi,

    Can you see if this Topic help the issue.

    If not, try to reset the domain again the WHS console remote asscess.

    My best.
    Monday, September 10, 2007 10:47 PM
  • Hi Abobader,

     

    I tried both those topics last night with still no solution, I still get the same error code.

     

    Keith

     

    Tuesday, September 11, 2007 7:57 AM
  • Hi Keith,

    Did you reboot the WHS when you switch to the new router? Some times it could be the issue.

    Also, some topics going on lately as same issue with homeserver.com matters, and most of them solve the case, but just switching the WHS on/off, and they tried later on, and it solve the issue.

    My best.
    Tuesday, September 11, 2007 8:44 AM
  • Hi Keith,

     

    I might be doing a bit of grandmothers and succking eggs here. But...

     

    I had a similar issue and there is an article on the forum somewhere I will look about the ports that needed to be open.

     

    From memory there were three with services associated with each.

     

    I will have look to see if I can find the relevant post.

     

    Regards,

     

    Andi

     

    Tuesday, September 11, 2007 9:53 AM
  • Could not find the post but I had ripped the script into word for future reference.

     

    See below, I will try and find the original post to credit the original person who solved the problem.

     

    "I had much the same problem in changing the setting once applied, it is possible but just as quick to delete the newly made addition and then start from scratch again.

     

    Sign into the router, mine is 192.168.1.254 then click advanced and then advanced again and put in your password.

     

    click application sharing

     

    click the click here button in the middle of the screen to create another application for sharing.

     

    Name the new application what you want, i would suggest Windows Home Server or something similar,

     

    Select manual entry of port maps and select next.

     

    Now, make sure that the protocol is TCP and do one entry for each port. (80,443,4125) so 3 in total.

     

    In the port range to and from you need to put the same number (i.e for port 80, will be TCP then from port 80 to port 80) also put the same number in translate to.

     

    Leave the trigger protocol on ANY and the trigger port empty.

     

    Click ADD to save the settings.

     

    Once you have the 3 ports completed click on application sharing on the left of the screen.

     

    You will then see a screen where you can select a game or application from a drop down menu and assign it to a specific pc.

     

    Select the newly created Windows Home Server game or application and then select from the next drop down menu the pc you want to assign it to (in effect BT's way of trying to make it easier to not have to input ip's as you can rename the pc's on your network on the BT homehub interface to make things simpler to use.

     

    Once you are happy with your selection click add and a new bold blue line will appear on the screen showing that you have created and assigned the correct protocol.

     

    Exit the IE browser and away you go.  

     

    Works on both http and https"

     

    Hope this helps.

     

    Regards,

     

    Andi

     

    Tuesday, September 11, 2007 9:58 AM
  •  

    Abobader,

     

    Yes I have rebooted the server, still the same message. Also added the ports to allow forwarding as suggesting in this thread and still get the same error code. I get to the part where I have to enter my passport to connect upto MS and collect my livenode.com address. When I click connect/sign in it tries and I get the error above.

     

    Keith

    Tuesday, September 11, 2007 5:55 PM
  • Hi Keith,

    Can you try to register with new live ID and try even new domian to see if it going at least?

    See it an issue right now, Tom (WHS Team) wil lgive us soon answer for these issue, as I quote his words here:

     Tom Ziegmann wrote:
    I've contacted the Remote Access team, and I'll try to get to the bottom of this.


    From this Topic.

    My best.
    Tuesday, September 11, 2007 8:52 PM
  • Hi again,

     

    I have tried to access using another live ID and still get same error, although I can login to both live id accounts using IE on the server. So I know the server is accessing the internet fine.  Just running out of ideas now, it worked fine on the netgear router, but the router kept dropping the connections to clients and also internet, thats why I replaced it with the new BT one.

     

     

    Tuesday, September 11, 2007 9:10 PM
  • Hi Keith,

     

    Last night I reset my remote access on my WHS and BT Home hub and got it to work without to many problems.

     

    These are the steps I took to make it happen

    1. Reset my password on the PC for my user account.
    2. Reset my password on WHS console to match the PC password and checked the enable remote access button.
    3. Then chose my domain name - logging in with my live ID.
    4. Created a service called WHS on the BT Router as described in my previous post and assigned it to the server.
    5. Then enabled the security on the router for remote access (can't remember the menu path as now sat at work), from memory there were two check boxes to fill in. One was about internet access and one about using enhanced security.
    6. I then went back to WHS console to set up the remote access.
    7. So from the menu bar on the left choose remote access.
    8. On this tab I ignored the configure router option, as even with UPnP checked and unckecked on the router I could not get it to work always an error message.
    9. Then the final option of testing clicked through this menu and all was sweet eventually, spent about an hour messing around with various settings on the router, before disovering the correct settings as above.
    10. I also added the IP address in a previous post into the trusted sites zone for the server.
    11. I then rebooted the WHS and also the router.
    12. I then tested from home using the https: //(yourname) dot livenode dot com address and was able to log on.
    13. I have tested this morning from work and was able to log on without any problems.

    Hope this helps.

     

    Regards,

     

    Andi

    Wednesday, September 12, 2007 8:12 AM
  • Hi Andi,

     

    I will try this again when I get home, I know which setting you mean regarding the enhanced security tick box. Not sure about the internet access one, but will investigate.

     

    Keith

     

    Wednesday, September 12, 2007 9:18 AM
  • Hi Andi,

     

    Update for you, I have done that also and still get the same error, double checked by trying my hotmail account and same again. Rebooted server again and tried, still same error.  Close to giving up now :-(

     

     

    Wednesday, September 12, 2007 7:38 PM
  • Keith,

    Can you do this simple test on the WHS server:

    Remote desktop (RD) to WHS, run - cmd, and ping the homeserver.com I just want to be sure, the server can resolve the DNS ok

    Then apply this: ipconfig /flushdns

    Next, can you see if new firmeware or patch older than what you use to update the router.

    Then, reset the BT router to factory setting, disable uPnP and do the 3 ports forwards again.
    (Recheck the ports, 443, 4125, and 80 "optional" All TCP to your WHS local IP)

    Make sure the WHS firewall setting are all ok, as this Topic.

    My best.
    Wednesday, September 12, 2007 9:28 PM
  •  

    Hi,

     

    I've done that and I can ping homeserver.com, also flushdns etc.  All that works, again created a new liveid, and still same.

     

    Could it be because I am still running the CTP not the RTM version?

    Wednesday, September 12, 2007 10:13 PM
  • Hi Keith,

    I test mine on RC, linenode.com as well homeserver.com (I used my own domain, but test it for other topic issue).

    Livenode.com domain been transfer to Homeserver.com for the beta tester, and since you have it before, then it should be ok.

    But the issue not regarding transfer now, it your router can not do remote asscess to get the domain.

    Can you put back the old router and see if it work?

    Regarding the CTP issue, I hope one of the whs team could give answer for it. But you should been testing RC by now, many fixed issue been done from CTP to RC.

    Sorry again for not beening in good help in this matters.

    My best.
    Wednesday, September 12, 2007 10:22 PM
  • Hi Adobader,

     

    Sorry yes it is the RC version, I will try the other router again at the weekend and see if that works.

     

    Thanks for your help

     

    Keith

    Wednesday, September 12, 2007 10:38 PM
  • Well Keith mine was working but now gone t*ts up.

     

    I had a look at my device table and the home page for the router, the one that shows up time, username etc. and I have no ISP IP address shown against the router.

     

    Looking at the devices tab my server now seems to have the external BT IP address and not one on my LAN?

     

    So redid everything as you have done and now remote access has stopped working, and fails the test from within WHS console.

     

    It seems interesting that we are both having similar problems, could be a BT issue?

     

    Or the router isn't up to the job?

     

    Anyway I will have another crack tonight after work and then give up.

     

    Regards,

     

    Andi

     

     

     

    Thursday, September 13, 2007 7:53 AM
  • Hi Keith,

     

    I have got it to work again.

     

    Here is the list of instructions I followed.

    1. Reboot the router.
    2. Disable UPnP on the router.
    3. Assign service to the server I tried a different tack here.
    4. Chose HTTP from list of services and assigned to server. Port 80.
    5. Chose HTTPS from list of services and assigned to server.Port 443.
    6. Created a new rule for Remote Access and assigned to server.Port 4125.
    7. Then tested connection in WHS console and got four green ticks.
    8. Have tested remote access from within the network and can login with no problems.
    9. Can even log on to server this brings up WHS console.
    10. Will check tomorrow from work - yet again.

    BTW I am using the RC with livenode. I only set up the livenode address this week.

     

    Regards,

     

    Andi

     

    Thursday, September 13, 2007 6:27 PM
  •  

    Andi,

     

    I've followed steps 1 and 2, but I'm unsure how to do step 3,4,5 and 6.  I can't seem to fine what you are refering to, can you help?

     

    Keith

    Thursday, September 13, 2007 6:46 PM
  • Andi,

     

    I plugged my old netgear router back in because the BT one just kept hanging on the web browser admin screen, anyway since doing this the homeserver now works with remote access and I have now had my livenode.com address changed to homeserver.com address.

     

    So all is now working again, I'll just have to wait until I can get a new one, because this one keeps locking up when it gets hot after a few days service.

     

    Thanks for your help,

     

    Keith

    Thursday, September 13, 2007 7:21 PM
  • Hi Keith,

     

    I have got it to work again. I have expanded my previous post with more detailed instructions, hope this helps.

     

    Here is the list of instructions I followed.

    1. Reboot the router.
    2. Disable UPnP on the router.
    3. Assign service to the server I tried a different tack here.
    4. On the left hand menu in advanced you should see "Application Sharing" click on this.
    5. In the middle of the screen you should see three heading Game or Application ,Device,Log
    6. Underneath these are some boxes with dropdown menus. In points 6 and 7
    7. Choose HTTP from list of services in drop down menu and assign to server again from drop down menu.This associates Port 80.
    8. Choose HTTPS from list of services in drop down menu and assign to server again choose this from drop down menu. This associates Port 443.
    9. Then we have to create a ne service, in the centre of the screen you should see the following text in blue "click here"
    10. Click on that.
    11. Enter a name for your new rule - WHS-RemoteAccess
    12. Then click radio button called manual entry of port maps.
    13. Then click next.
    14. This brings up headings shown below
    15. Protocol Port Range Translate To ... Trigger Protocol Trigger Port
    16. From drop down choose TCP enter 4125 in both boxes for port range.
    17. Leave the rest on the boxes blank and click add then apply.
    18. Return to the application sharing page and repeat point 7. choosing your newly named Service as in point 11.
    19. Making sure you assign it to the server.
    20. Then tested connection in WHS console and got four green ticks.
    21. Have tested remote access from within the network and can login with no problems.
    22. Can even log on to server this brings up WHS console.
    23. Will check tomorrow from work - yet again.

    BTW I am using the RC with livenode. I only set up the livenode address this week.

     

    Check this hyperlink for screenshots as well.

    http://www.portforward.com/english/routers/port_forwarding/BT/BTHomeHub/HTTPS.htm

     

    Regards,

     

    Andi

     

    Thursday, September 13, 2007 7:47 PM
  •  

    Andi

     

    Thanks for that also - thinking back I think we had a powercut/BT issue and the router must have stoofed somehow.  Just doing the reboot solved it for me...

     

    Thanks again

     

    Graeme

    Saturday, September 15, 2007 6:52 PM
  • Graeme,

     

    You are very welcome.

     

    Regards,

     

    Andi

     

    Saturday, September 15, 2007 10:21 PM