locked
Question about Web Component validation error RRS feed

  • Question

  • Dear All,


    I tried to deploy OCS 2007 on my company's POC enviroment.

    After the installation, I tried to do validation on the OCS server.

    I have done 3 of them, "Validation Front End Server Configuration", "Validate Web Components Server Functionality" & "Validate Web Conferencing Server Functionality".

    However, only the "Validate Web Components Server Functionality" failed.
    Below is the error msg.


    Code Snippet

    Check Http URL   URL: https://exocsbe.ems.tspl.com.sg/Abs/Int/Handler/Sample_Company_Phone_Number_Normalization_Rules.txt
    Received a failure HTTP response.: HTTP Response: 404 Not Found
    Content-Length:1635
    Content-Type:text/html
    Date:Mon, 07 Apr 2008 00:57:35 GMT
    Server:Microsoft-IIS/6.0
    X-Powered-By:ASP.NET


    The page cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    --------------------------------------------------------------------------------


    Please try the following:


    Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.

    If you reached this page by clicking a link, contact
    the Web site administrator to alert them that the link is incorrectly formatted.


    HTTP Error 404 - File or directory not found.
    Internet Information Services (IIS)


    --------------------------------------------------------------------------------


    Technical Information (for support personnel)

    Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.

    Open IIS Help, which is accessible in IIS Manager (inetmgr),
    and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.


    Received a failure HTTP response.: NotFound
    Suggested Resolution: Check whether the Web Server or Office Communications Server component is running and also listening on the specified url. If server is behind a load balancer, please make sure the loopback connection is allowed from load balancer FQDN.
    Suggested Resolution: Check the Web Proxy setting in this machine and ensure that it is correctly configured
       Failure
    [0xC3FC200D] One or more errors were detected 


    Check Web Conferencing Server Virtual Directory Setting       Success
     

    Check Http URL   URL: https://exocsbe.ems.tspl.com.sg/etc/place/null/slidefiles/blank.png
    Received a successful HTTP response: HTTP Response: 200 OK
    Accept-Ranges:bytes
    Content-Length:567
    Content-Type:image/png
    Date:Mon, 07 Apr 2008 00:57:35 GMT
    ETag:"05f2bc264c6c71:3d6"
    Last-Modified:Sat, 14 Jul 2007 22:17:26 GMT
    Server:Microsoft-IIS/6.0
    X-Powered-By:ASP.NET

    Received a successful HTTP response: OK


     As you can see only the address book part failed.
    I run throught the Virtual Lab and discovered that this address book validation suppose to validate something like "f-dbd.lsabs" file. Is there somthing i have missed?

    Does OCS 2007 setup need Exchange 2007 UM service?

    Thanks

    Monday, April 7, 2008 1:05 AM

All replies

  •  

    You probably have no OAB yet

    Force the creation of the OAB

    Run abserver.exe -syncnow from Core directory under OCS\Server\core to force AOB

     

    Wait 5 minutes and check for the files

    Monday, April 7, 2008 6:28 PM
  • Hi,

    thanks for the help. I realise that too..
    However i have run the command after i hit the error also. but the OAB doesnt appear at all.

    After checkin the log file on both OCS 2007 and the system itself for the past few days. I came to realise some funny issues of this setup.

    The system log of communication server shows the server able to sync the user and address sometimes.
    The communication server admin tools on e other hand appear all errors regarding any sync processes or anything to do with connecting to DC.

    However I am able to log in as administrator of the domain or any other accounts in the domain to the server.

    Then this morning, out of desperation, I tried out a util call "netdiag" from OCS 2007 server and discovered that the OCS 2007 somehow trying to connect to another domain controller on another subnet which belongs to a totally different domain.

    That's somehow ring the bell and i tried to disable all unused network interfaces on the server and force the only interface to resolve all hostnames only by DNS( disable WINS & NetBIOS).

    Finally, after execute the command abserver.exe -syncnow, the OAB files appeared and the validation is completed without any error.



    :Cheers





    Tuesday, April 8, 2008 6:32 AM
  • My validation was working perfectly with no errors when I ran it UNITIL I modified the Sample_Company_Normalizations rules to address users in AD that didn't have E.164 numbers listed. 

     

    Once I did this, all invalid numbers were corrected but I started seeing the exact error Triston reported above.  For some odd reason the Check URL Link is looking to connect to the normaliztion rule file itself and not the DABS file it used to point to.

     

    URL: https://OCS1.DOMAIN123.ORG/Abs/Int/Handler/Company_Phone_Number_Normalization_Rules.txt
    Received a failure HTTP response.: HTTP Response: 404 Not Found

    The other strange thing is that the ABS files get generated on a nightly basis on on demand and users CAN download the address book without any issues.  Only problem is the Validation now fails. 

     

    Any ideas from anyone?  My thoughts are this is a bug in the validation tests as I've seen some other validation errors that don't translate into Production issues.

     

    Thanks

    Dino

    Tuesday, June 24, 2008 2:00 AM
  • Check the permissions on the location where you keep the address book (share and file). 

    Tuesday, June 24, 2008 3:30 AM
  • Permissions are fine as the clients can download address book files.

    I've discovered a bug I believe..  Here is more detail. 

     

    Once you modify the Sample_Company_Phone_Number_Normalization_Rules.txt to Company_Phone_Number_Normalization_Rules.txt or any other name for that matter, it seems the validation tool tries to read it and throws the error shown in the previous post.  If you don't change this file or if you rename it back to the original name the validation error doesn't occur.  I've tested and repro'd this on a couple of machines now.


    Dino.

     

    Tuesday, June 24, 2008 3:37 AM