locked
Associate message type plugin CRM 2011 Online RRS feed

  • Question

  • Hello,

     

    I have built a plugin which triggers off an Associate message which works perfectly fine in a hosted (development VM) under sandbox / database deploy however when I register it to a CRM 2011 online instance it doesn't execute (nothing happens).

    Is there a trick to get it to fire for CRM online?

     

    Any help would be appreciated.

    Tuesday, July 5, 2011 2:01 PM

Answers

  • Has anyone successfully deployed a plugin triggering off Associate in the CRM 2011 Online environment?  Just want to know if it's only me that's running into this.
    • Marked as answer by Daryl Orwin Tuesday, July 5, 2011 7:02 PM
    Tuesday, July 5, 2011 3:31 PM
  • Wow....don't I have egg on my face.  FALSE ALARM. 

    Seems someone thought it would be a good idea to updated the associated view to only display items with a option set value we weren't populating from the plugin.  (They also updated the active view so I had to look through advanced find to see them)

    • Marked as answer by Daryl Orwin Thursday, September 3, 2015 5:09 AM
    Tuesday, July 5, 2011 7:00 PM

All replies

  • Try to debug your plugin. Refer below URLs for more help

    http://pogo69.wordpress.com/2011/04/19/debugging-plugins-in-crm-online/

    http://crmbusiness.wordpress.com/2011/02/08/crm-2011-you-can-now-add-tracing-to-your-plugins/


    Thanks, Ankit Shah
    Inkey Solutions, India.
    Microsoft Certified Business Management Solutions Professionals
    http://www.inkeysolutions.com/MicrosoftDynamicsCRM.html
    Tuesday, July 5, 2011 2:26 PM
  • Hi Ankit,

    No errors are displaying with the trace.  I don't think it's even executing the plugin.

    I've double checked the registration / step for the dll and it's exactly the same as the development environment.  The other new events (Create/Update) are firing just not the Associate one.

    Tuesday, July 5, 2011 2:48 PM
  • Has anyone successfully deployed a plugin triggering off Associate in the CRM 2011 Online environment?  Just want to know if it's only me that's running into this.
    • Marked as answer by Daryl Orwin Tuesday, July 5, 2011 7:02 PM
    Tuesday, July 5, 2011 3:31 PM
  • Wow....don't I have egg on my face.  FALSE ALARM. 

    Seems someone thought it would be a good idea to updated the associated view to only display items with a option set value we weren't populating from the plugin.  (They also updated the active view so I had to look through advanced find to see them)

    • Marked as answer by Daryl Orwin Thursday, September 3, 2015 5:09 AM
    Tuesday, July 5, 2011 7:00 PM