locked
CRM 3.0 Workflow - Date DataFields RRS feed

  • Question

  • I've been experimenting with workflow to automate email notifications for various entities/objects. Pretty basic stuff to be honest. No complicated conditions, not calling any webservices, just simple 'if workflow called, send email to x, with subject y, and body z' - really couldn't make it any simpler.

     

    I've encountered two problems while doing this, that have left me scratching my head.

     

    1. When I add a datafield that points to a date field from the related object, the email received always returns the default value (or blank if no default specified). In all cases, the source date fields I'm trying to reference always contain valid data in the CRM object, so why these never get picked up by workflow I don't understand.

    Has anyone come across this before?

     

    2. If I add multiple datafields in the body of a workflow email, each one entered seperately they all return the same value. When I enter each one I specify a unique source field, but when I subsequently open each datafield to check, I find they have all changed to the same source field.

    Again, absolutely stumped how this could happen. I am not copying and pasting datafields, then editing the properties of each (which I could be convinced might somehow be cloning the field settings) - but rather adding a new distinct datafield each time.

     

    We are soon upgrading to CRM 4.0, so potentially the changes to workflow in 4.0 will either resolve this issue for me, or negate the workflow I've setup altogether. But in the meantime, I really need these workflow notifications to work, so would love to hear any feedback from people on my issues.

     

    Thanks folks

     

    Julian

     

     

     

    Wednesday, February 13, 2008 1:02 AM

Answers

  • I've never seen the slug behaviour you're describing; I've had no problems including multiple distinct fields in the body of a workflow email.

     

    This sounds like a problem with the workflow manager tool. Do you have another CRM environment to test this on ?

    Monday, February 18, 2008 9:59 AM
    Moderator

All replies

  • Dear Julian,

     

    See this has been fix in rollup update 2

     

    http://www.microsoft.com/Downloads/details.aspx?FamilyID=81674da5-ffef-492a-a7b1-7e1f1951b05f&displaylang=en

     

    Let me know if still date issue you get while workflow or some other objects.

     

     

    Yes CRM 4.0 have great workflow manager and web based, as its using Windows workflow foundation. you very strong.

     

    You can use trial version of CRM 4.0 on microsoft site

     

     

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

     

    Wednesday, February 13, 2008 12:56 PM
    Moderator
  •  

    Thanks. Rollup 2 does indeed fix the date issue.

     

    Doesn't fix the second issue I mentioned - regarding field 'slugs' all containing the same source field.

     

    Seemingly, while you can add as many 'slugs' as you want within a workflow email body, and you can add multiple data fields to one slug, all slugs within the body are essentially clones of each other, so will all return the exact same field data.

     

    Seems like a pretty pointless feature to me.

    Thursday, February 14, 2008 10:13 PM
  • I've never seen the slug behaviour you're describing; I've had no problems including multiple distinct fields in the body of a workflow email.

     

    This sounds like a problem with the workflow manager tool. Do you have another CRM environment to test this on ?

    Monday, February 18, 2008 9:59 AM
    Moderator