locked
CRM 2011 SRS Reports missings RRS feed

  • Question

  • Hi all

    I have just installed SRS Reports for CRM 2011.  The install completed successfully and I can create and run custom reports fine but there are no other reports avaliable.  I belive default reports should be available now but there is nothing.  I have tried uninstalling the SRS Connector, deleting the Reports database, recreating the database and then reinstalling the SRS connector with no success.  I have all so run the publishreports.exe tool, which seems to run OK but still have no reports.

    I can't seem to find any thing about this specific issue.  Any ideas?

    Regards

    David


    D

    Wednesday, August 15, 2012 12:57 AM

Answers

  • They didn't show under the 5.0.xxxx folder.  However I found that the files for the reports are stored under C:\Program Files\Microsoft Dynamics CRM\LangPacks\1033\Reports\MSCRM\ and was able to add the ones I wanted manually.

    I later found a few other errors with the setup and decided to just export my customisation, delete the organization and then recreate it.  When it was recreated all of the reports were added correctly.

    Thank you for the assistance.

    David


    D

    • Marked as answer by GrimD Sunday, August 19, 2012 10:16 AM
    Sunday, August 19, 2012 10:16 AM

All replies

  • Taken from Install Microsoft Dynamics CRM Reporting Extensions:

    The reports will not be published if:

    • The user running CRM Reporting Extensions Setup does not have appropriate permissions on the organization database.
    • CRM Reporting Extensions are installed for an Microsoft SQL Server Reporting Services instance that is different from the one that is being used by the organization.
    • The base language of the organization is different from the language in which CRM Reporting Extensions are being installed.

    Do any of these apply?


    Jason Lattimer

    Wednesday, August 15, 2012 2:30 AM
    Moderator
  • Thank you for the reply but I don't believe any of those points are applicable.

    • The fist time I installed the SRS extensions it was with a user that had not access to organisation database but on the later installs and when running the publishreports.exe I have used an appropriated user with full access to the organisation database
    • The instance is the same one
    • The base language's are the same

    Regards

    David


    D

    Wednesday, August 15, 2012 8:04 AM
  • If you browse to your report server URL (http://servername/reports) under the Shared Reports - 5.0.xxxx folder do you see them?

    If so I would double check the permissions and make sure they are similar to this:

    • domain\PrivReportingGroup Browser for Microsoft CRM
    • domain\ReportingGroup Browser for Microsoft CRM
    • domain\SQLAccessGroup Publisher for Microsoft CRM

    If you don't see them, maybe double check the report server URL is correct for the organization under Deployment Manager.


    Jason Lattimer

    Thursday, August 16, 2012 12:08 AM
    Moderator
  • They didn't show under the 5.0.xxxx folder.  However I found that the files for the reports are stored under C:\Program Files\Microsoft Dynamics CRM\LangPacks\1033\Reports\MSCRM\ and was able to add the ones I wanted manually.

    I later found a few other errors with the setup and decided to just export my customisation, delete the organization and then recreate it.  When it was recreated all of the reports were added correctly.

    Thank you for the assistance.

    David


    D

    • Marked as answer by GrimD Sunday, August 19, 2012 10:16 AM
    Sunday, August 19, 2012 10:16 AM