locked
Custom Presence RRS feed

  • Question

  • Hi All,

    I am trying to add some custom presence to the OCS Communicator client.  I have followed the instructions, but it is not working at all.  The custom presence does not appear in the presence options.  Here is what I have:

    <?xml version="1.0" encoding="utf-8"?>
    <customStates>
      <customState
        ID="1"
        availability="Online">
        <activity
          LCID="1033">Working from home</activity>
      </customState>
    </customStates>

    And I have the following in the reg file that I have run:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Communicator]
    @=""
    "CustomStateURL"="file:///c:/Program Files/Microsoft Office Communicator/OCSPresence.xml"

    I have verified that the registry key exists. 

    Anyone know why this is not working?

    Friday, July 10, 2009 9:50 PM

Answers

  • Okay, I found the answer. Communicator 2007 R2 is configured to default to using https only for all connections, including that of pulling down the presence XML file. So even if it is stored locally, it won't pull down the file because it is not available via https. What you need to do is add the string "EnableSIPHighSecurityMode" to the registry in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator key and set it's value to 0. Doing so allows non https connections. It is important to note that this is not a very god set up from a security point of view. You really should store the presence XML file in a secure location that is available via https, but if you are just looking at testing custom presence prior to implementation, this will work fine. Also, if doing custom presence for domain users, you should use Group Policy to set the registry values. Cheers
    • Marked as answer by fha101 Monday, July 13, 2009 4:52 PM
    Monday, July 13, 2009 4:51 PM