none
Waring deployment active directory connectivity test...

    Question

  • I set up cluster environment with two computers in which one is as a head node as well compute node and the ohter is a compute node.

    I run lizard test tool for HPC server 2008 to test the cluster efficiency but it looks the test stops.. I mean there is no progress the test even after two days.

    Thus I run a diagnostics tool on cluster manager and I found that on the head node computer the compute node domain controller is not connected to Active Domain controller.

    The following is what I have; (I changed actual name of server to headnode or computenode)

    headnode

    Erros Contacting Active Directory
    This table shows the errors returned by the node when attempting to contact Active Directory.
     
    Domain Controller Error Message
    computenode.mechanicslab.com The server is not operational. Name: "computenode.mechanicslab.com" 
     


    Information
    Successfully contacted 1 domain controller(s) from this node


    Warning
    Failed to contact 1 domain controller(s) from this node


    back to top


    computenode(Success)


    --------------------------------------------------------------------------------

    Errors Contacting Active Directory
    This table shows the errors returned by the node when attempting to contact Active Directory.
     
    Domain Controller Error Message
     


    Information
    Successfully contacted all 2 domain controller(s) from this node

    Please give me any advise to solve this problem.

    Thanks in advance.

    Saturday, January 1, 2011 7:22 PM

All replies

  • Do you have an active directory domain controller for your cluster and are all nodes of your cluster still able to join your domain? 

    What network topology did you choose when configuring the cluster?  Are all nodes able to communicate (at least ping) the DC?

    --Brian

    Sunday, January 2, 2011 8:55 AM
  • I delete one domain controller was set up on the second computer wokring as compute node. Thus right now I run the diagnostic test on cluster manager I will have no more error on the connection to ADDS.

    Right now there are one domain controller on my cluster. But I am confusting several things. The head node has two NICS and one is connected to the router and the other is connected to the compute node by cross-cable directly. When I unplug the internet connection line I got warning message on DNS test but plug the internet connection I got error message.

    Someone recommended to use without internet connection and run cluster. How do you think about this?

    And the head node computer woks as well as compute node thus in the cluster one head node and two compute nodes with two physical computers.

    To get the best result with numerical calculations do I have to delete the compute node on head node computer?

    I am really confusing about this.

    Please give me any advise.

    Sunday, January 2, 2011 4:33 PM
  • You do not need to change the role on your HN (head node) and remove CN (compute node) role. Having two CN should give you better (more) results than just using one.

    Your cluster needs connectivity to the DS. I understand that the CN is only connected to the HN so your HN has to have connectivity to the DS and NAT enabled. This is setup during the configuration stage.

    Wednesday, January 12, 2011 11:26 PM