locked
Do you want to save this file? Blank.aspx? RRS feed

  • Question

  • We currently running CRM 4.0.  We have started to receive the following error message when accessing CRM from the Outlook Client:

    Do you want to save this file?

    Name: Blank.aspx

    Type:  Unknown File Type

    From: (Servername)

     

    Any ideas on why this message is appearing?  We have had no changes made to the clients or the server recently.

    Wednesday, August 13, 2008 4:40 PM

Answers

  • We've just had the same thing with a customer.  It appears that a windows update makes windows lose the association with aspx files.  Save the file that it is asking you to save on your desktop.  Right click on it and open it.  Choose to open it with Internet Exporer and choose "always use this"...  Then try CRM again.

    Wednesday, August 13, 2008 4:52 PM

All replies

  • We've just had the same thing with a customer.  It appears that a windows update makes windows lose the association with aspx files.  Save the file that it is asking you to save on your desktop.  Right click on it and open it.  Choose to open it with Internet Exporer and choose "always use this"...  Then try CRM again.

    Wednesday, August 13, 2008 4:52 PM
  • Thanks, that fixed my problem.  I figured that it had something to do with the one of the patches that was applied, I just wasn't sure how to fix it.

     

    Thanks again

     

    Wednesday, August 13, 2008 5:40 PM
  • Same issue here running CRM 3.0.  Ajusting the file association as described does not resolve the issue.  Laptop using Windows XP Pro, Office 2003, IE 6.

     

    Thursday, August 14, 2008 6:24 PM
  • When you were adjusting the file association, did you make sure you checked the box that says always use this to open this type of file?
    Thursday, August 14, 2008 6:30 PM
  • I saved it to my desktop...right click on it and tell it to open with IE and nothing happens.

    Thursday, August 14, 2008 6:32 PM
  • Yes, the box is checked.  And I can see from Windows Explorer | Tools | Folder Options | File Types that the aspx file association is listed.

     

    Also, the Blank.aspx on the desktop now shows the Internet Explorer icon on the white document.

     

    This issue occurred with the latest Microsoft Update that ran two days ago.  I agree the update changed the configuration.
    Thursday, August 14, 2008 6:40 PM
  • No, this does not correct the error, and has created a new one. When returing from Accounts or Contacts to your Inbox, it does not display any messages. You now have to go to another folder first, before returning to your Inbox.

     

    Thursday, August 14, 2008 6:52 PM
  •  

    Help. I saved it to my desktop...right click on it and tell it to open with IE and nothing happens.
    Thursday, August 14, 2008 7:26 PM
  • Apparently this is the offending patch that was installed recently:

     

    "Uninstalling KB953838 fixes the problem..."

     

    Posted here:

    http://community.dynamics.com/forums/p/4732/5985.aspx

     

    About to try the uninstall to see if it fixes my issue.

     

     

     

    Thursday, August 14, 2008 7:30 PM
  • Uninstalling KB953838 from add/remove programs did the trick for me.  Requires a reboot.  Since we have to remain on IE6 for legacy app compatibility, this seems like the only solution available to me.  YMMV. 

     

    Thursday, August 14, 2008 7:49 PM
  • That is the patch that caused the problem.  I uninstalled the patch also, but the problem with that is that it will try to reinstall that update the next time Automatic updates try to run on the computer.  Maybe Microsoft will do a Microsoft Dynamics update that will fix the problem that it causes to the Dynamics applications.

     

    Friday, August 15, 2008 3:08 PM
  • So, Microsoft knows that this patch is causing issues for Microsoft CRM and they are suggesting the following workaround:

     

    --------------

    Please edit the default blank.aspx file in CRM so it contains data. This file is located at My Computer | System Drive | Program Files | Microsoft Dynamics CRM | CRMWeb |_ root. Here you will find the Blank.aspx text file.

     

    Open the file and add some text to the file, for example you can add ‘test’ to the existing data.

     

    Test

    <% Response.Expires = 1440; %>

    <% Response.Cache.SetCacheability(HttpCacheability.Public); %>

     

    Once you have added data, save the file, clear your temporary Internet Files, and do an IISreset. Once this is done go back into CRM to verify that this has resolved this issue.

    --------------

     

    Hope this helps!


    Cheers,
    Rob

    Wednesday, August 20, 2008 6:04 AM
  • Rob, thanks for the post.  However, when I go into Program Files\Microsoft Dynamics CRM there is no subfolder called CRMWeb.  I did a search on the hard drive for blank.aspx and the file doesn't exist.  Any suggestions or reason why I wouldn't have this file or the CRMWeb folder?

     

    Thanks in advance

    Wednesday, August 20, 2008 4:05 PM
  • So, it looks like when CRM was originally installed, it was instead installed into an alternative folder - which can happen when someone pre-creates the website for CRM to be installed into.  So, this would mean that there may not be a specific folder called CRMWeb, but you should instead look for a folder with typical CRM webpages [like loader.aspx] ... which will more than likely be in a sub-folder in the Inetpub folder... possibly in the wwwroot folder.

     

    Give this a try and hopefully you'll be able to track this down.

     

    Cheers,

    Rob

    Wednesday, August 20, 2008 4:26 PM
  • But as I mentioned, I did a search on the entire hard drive for a file called blank.aspx and it doesn't exist.  So...even if I find this folder where the web pages are located, there still won't be a file called blank.aspx in that folder to edit.

    Wednesday, August 20, 2008 4:31 PM
  • OK - I think I know the problem... This page is actually on the CRM Server, not your workstation... Or at least that's my guess of why you can't find it.  If you're on the CRM Server and you're still not finding this, then you need to track down where your CRM Server application is installed - otherwise I'm not quite sure what to say.

     

    Wednesday, August 20, 2008 4:40 PM
  • Rob,

     

    Thanks for posting this! Fixed the issue for one of my customers with CRM 3.0 on a SBS box....

     

    SRW

     

     Robert Kszan [CRMsource] wrote:

    So, Microsoft knows that this patch is causing issues for Microsoft CRM and they are suggesting the following workaround:

     

    --------------

    Please edit the default blank.aspx file in CRM so it contains data. This file is located at My Computer | System Drive | Program Files | Microsoft Dynamics CRM | CRMWeb |_ root. Here you will find the Blank.aspx text file.

     

    Open the file and add some text to the file, for example you can add ‘test’ to the existing data.

     

    Test

    <% Response.Expires = 1440; %>

    <% Response.Cache.SetCacheability(HttpCacheability.Public); %>

     

    Once you have added data, save the file, clear your temporary Internet Files, and do an IISreset. Once this is done go back into CRM to verify that this has resolved this issue.

    --------------

     

    Hope this helps!


    Cheers,
    Rob

    Monday, August 25, 2008 10:31 PM
  • Great!  My pleasure!!

     

    Tuesday, August 26, 2008 9:06 PM
  • Yes this fixed the problem for us, too (CRM 4.0 on Windows Server 2003 R2 SP2).

    I found Blank.aspx on the CRM server in the following location:

    C:\Inetpub\wwwroot\_root

    Added text to the top of it and saved it. Ran iisreset and cleared the cache on the clients' IE6 browsers. Re-logged in to CRM and the issue was resolved.

    Thanks!!

    ~Tony
    Tuesday, August 26, 2008 10:18 PM
  • Excellent solution Robert - especially since you installed our CRM! Keep up the great work!

     

    David Atherton

    Wednesday, August 27, 2008 7:05 PM
  • thanks for that thread, I have the same issue

    Friday, August 29, 2008 8:47 AM
  • Yes, however now when the page loads you see "Test" momentarily instead of a blank page.

     

    Monday, January 5, 2009 9:09 PM
  • Hi Suzy - Yup... That's exactly what happens... which is the trade off for it not erroring out.

     

    The key way to truly resolve this issue is to have all server & client computers experiencing this issue to uninstalling the KB953838 update... but in some cases there are environments where this is not possible - usually due to company security compliance requirements.

     

    The way to get rid of this [just in case you need this info] is to go to the Add/Remove programs area, Select the Show Updates checkbox at the top of this window, and then find and uninstall "Security Update for Windows Internet Explorer 7 (KB953838)"].

     

    You can get move info on this security update and on whether this security update may pertain to your specific environment here: [http://support.microsoft.com/kb/953838]  

    Hope this helps!

     

    Cheers,

    Rob

     

     

    Monday, January 5, 2009 9:47 PM
  • Thanks, Rob. I also read that installing IE 7 would resolve the issue. My client only had 2 users complain about it and they were both IE 6, so I've asked them to upgrade. Hopefully that will be a cleaner solution. I'll let you know if it helped and if not we'll uninstall the security update.

    I appreciate your advice and assistance!

    - Suzy

     

    Tuesday, January 6, 2009 2:12 AM
  • My client didn't have the option to upgrade to IE7 [again, company security policy], so this wasn't possible for them either [and thanks for reminding me of this option as well!]  Also, my last post should have indicated the IE6 version of this Security Update - Oops!

    OK - Best of Luck Suzy! :-) 

    Tuesday, January 6, 2009 5:35 AM