locked
CRM 4.0 Install Error: Error accessing URL http://"servername": The remote server returned an error: (404 not found. HTTP error: 404 - File or Directory not found.) RRS feed

  • Question

  • Hi,

    I am installing MS CRM 4.0 on a 64bit Windows Server2003 SP2 server.

    I want to install CRM 4.0 on the default web site port 80.

    However when I select to do this I get the following error on the System Requirements page,

     Error accessing URL http://"servername":  The remote server returned an error: (404 not found.  HTTP error: 404 - File or Directory not found.)

    I am able to browse in IE using http://"servername": to the IISStart.htm though.

    If I choose create to create a new website using port 5555, I don't get the error on the System Requirements page.

    Does this mean?:

    a) I can ignore the error

    b) I need to make changes to the default website before the CRM install

    c) I need to make changes to the default websiter after the CRM install

    Thanks,

    Steve


    Tuesday, June 28, 2011 7:02 PM

Answers

  • Hi Steve,

    Please make sure if there any website installed on 80(Default Web Site) port. if exists, CRM will overwrite the website and make sure all the services, CRM Website and App Pool are running.

    b. You can choose default web site(80 port), when installing the CRM

    c. If you have installed CRM on 5555 port, you just need to a port 80 binding for CRM Website from IIS Manager->Sites->Microsoft Dynamics CRM->Bindings.

     

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    • Marked as answer by Steve Fleming Wednesday, June 29, 2011 9:21 PM
    Wednesday, June 29, 2011 5:00 AM

All replies

  • Hi Steve,

    Please make sure if there any website installed on 80(Default Web Site) port. if exists, CRM will overwrite the website and make sure all the services, CRM Website and App Pool are running.

    b. You can choose default web site(80 port), when installing the CRM

    c. If you have installed CRM on 5555 port, you just need to a port 80 binding for CRM Website from IIS Manager->Sites->Microsoft Dynamics CRM->Bindings.

     

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    • Marked as answer by Steve Fleming Wednesday, June 29, 2011 9:21 PM
    Wednesday, June 29, 2011 5:00 AM
  • Hi Khaja,

    Thanks for your reply it so are you saying I should go with option 'a' and ignore the error as the default web site, which currently isn't being used by an application, will be overwritten by MS CRM?

    Thanks,

    Steve

    Wednesday, June 29, 2011 9:44 AM
  • If it is a warning you can ignore.. if it is a error it may not allow you to install.

    Please update the error message.

     

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    Wednesday, June 29, 2011 9:58 AM
  • Hi,

    It is a warning.

    Wednesday, June 29, 2011 10:15 AM
  • Hi,

    I can see that in the home directory there are only 2 files, 'iisstart.htm' and 'pagerror.gif' but on the documents tab, 'Enable default content page' is ticked and there are 4 files listed, iisstart.htm. default.htm, default.asp & index.htm. Could this be why the error is being reported?
    Wednesday, June 29, 2011 10:24 AM
  • Hi,

    Have tried disabling  'Enable default content page'  and then tried removing the documents which weren't there but that hasn't made any difference.

    Wednesday, June 29, 2011 10:43 AM
  • I have tried deleting the Default web site and now no warning is showing during the preinstallation checks. I will confirm later if it is successful after the install.
    Wednesday, June 29, 2011 12:08 PM
  • Hi Steve,

    These are the default files, you dont need to delete this.

    These files may not cause you any issues.

     

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    Wednesday, June 29, 2011 12:55 PM