locked
OCS 2007 R1 SE Eval to OCS 2007 R2 SE (Licensed) RRS feed

  • Question

  • Greetings,

    Please bear with me as I have jumped into all of this with absoluately no background so I am learning as much as I can as I go along.

    Just a preface, this deployment is strictly for internal users; we do not require any edge servers, reverse proxy, or anything like that.

    With that said, we have a Win2K3 root domain in which I've succesfully deployed Microsoft OCS 2007 R1 Standard Edition. This version is a 180-day evaluation version which is about three months old.

    We have decided to purchase the product and upgrade from R1 to R2. My goal was to deploy a second OCS server (which required extensions of the schema database again) and have the two co-exist as I migrate users from one to the other and hopefully be able to shut the evaluation server down after hours to test the functionality.

    However, when I deployed R1, it was on a x86 virtual server running W2K3 x86. I have now deployed (or am in the process of) R2 on a x64 virtual server running W2K3 x64 and am wondering about the coexistence of the two--reason being, when I try to use the ADUC extensions on the R2 box to enable additional users, I have to use the evaluation server as ADUC on the R2 box does not have these options regardless of the fact the 64 bit admin tools have been installed. If I am on the R1 box, I can enable users using ADUC and then open an RDC to the R2 box and move the users from the R1 SE server to the R2 SE server and everything seems just fine at that point.

    What is the best way to approach this?

    Thank you in advance!

    Wednesday, May 20, 2009 2:50 PM

All replies

  • The correct approach would be to use the Management Tools on the R2 server.  Locate the users listed under the Earlier Server Versions to move them between the R1 and R2 pools.  Also, ADUC should have the Communications tab showing for users on the R2 server if the Managment Tools have been correctly installed.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Wednesday, May 20, 2009 3:43 PM
    Moderator
  • Thanks for confirming user migration.

    Regarding ADUC and the OCS Management Tools, I've installed the 64-bit version of the OCS Management Tools from my setup disc. Two snap-ins (OCS 2007 R2, Communicator Web Access) have been created and I can manage my R2 server without issue using those snap-ins. However, I can't seem to get the same "Enable users for OCS" context-menu to integrate with version 5.2.3790.3959 of ADUC (running on the R2 server) like I can with R1. My current situation would require me to enable users on R1 and then migrate them to R2.

    Have you (or anyone else) run into this issue?
    Wednesday, May 20, 2009 6:31 PM