locked
CRM 2011 Mail Router - Incoming Status: Failure RRS feed

  • Question

  • I am trying to get CRM mail router functioning so we can use queues.  I have worked through the 401 and 403 errors but now I am getting a new error:

    Incoming Status: Failure - The specified object was not found in the store. Verify that the specified user credentials have Receive permission on the target mailbox. The request failed with the error message:--<head><title>Document Moved</title></head>
    <body><h1>Object Moved</h1>This document may be found <a HREF="https://mail.server.com/OWA/">here</a></body>--.

    Any suggestions you may have would be great.

     


    G
    Tuesday, March 1, 2011 10:41 PM

Answers

  • After much mucking around, we found our problem.

    In our instance the Default Global Address List had us listed, but our mailbox was tied to another custom address list, that was not listing our address correctly due to a typo. The access to the GA was being blocked by custom security settings.

    This comes back to the same post above. Although nothing to do with the check box about  “Hide from Exchange address lists” - we were in effect being hidden from the address list that mattered.

    Thursday, August 4, 2011 2:26 PM

All replies

  • Is your owa/exchange url correct?


    Jamie Miley
    Tuesday, March 1, 2011 11:03 PM
    Moderator
  • According to the documentation:

    1. In the Location section of the E-mail Router Configuration Profile dialog box, verify that the correct URL of the Exchange Server is entered. For example:

    Important

    1. Do not enter any additional characters at the end of the URL string, such as /OWA or /Exchange or even a / character. If you are using Secure Sockets Layer (SSL), be sure to use https in the URL instead of http.

    As we are using SSL I have tried https://localserver and https://localserver/EWS/Exchange.asmx with the same results.  I'm not sure if it is relevant but https://localserver brings up our OWA site and https://localserver/EWS/Exchange.asmx brings up some XML file for display.

    What should my owa/exchange url look like?

     


    G
    Tuesday, March 1, 2011 11:24 PM
  • The URL should be https://localserver  for Exchange 2003 or 2007.

     

    • Proposed as answer by Jim Glass Jr Tuesday, July 26, 2011 3:52 PM
    Wednesday, March 2, 2011 5:52 AM
    Moderator
  • We're running Exchange 2010. My apologies, we should have made that clear in the original post.
    Wednesday, March 2, 2011 2:15 PM
  • Then you should definitely use the https://localserver/EWS/Exchange.asmx format because Exchange 2010 only provides Exchange web services.
    • Proposed as answer by Jim Glass Jr Tuesday, July 26, 2011 3:52 PM
    Wednesday, March 2, 2011 2:34 PM
    Moderator
  • As disclosed in the second reply, this does not change the error. For your reference outbound email works, but inbound email does not, using the same server. Any suggestions?
    Wednesday, March 2, 2011 3:06 PM
  • I appreciate that you still have the error, I was just confirming that the correct URL.

    Do you get the error for all users and queues or specific ones?

    Wednesday, March 2, 2011 3:11 PM
    Moderator
  • The error happens for all users.  I just tested again and now I am only recieving Failure: No results were found.


    G

    Also I found this in the event viewer:

    Log Name:      Application
    Source:        MSCRMEmail
    Date:          3/2/2011 9:22:45 AM
    Event ID:      26090
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      server.domain.COM
    Description:
    #26090 - An error occurred while opening mailbox mail.user@domain.com. Microsoft.Crm.Tools.Email.Providers.EmailException: No results were found.
       at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.IsCurrentUser()
       at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.GetService()
       at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.InitExchangeConnector()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSCRMEmail" />
        <EventID Qualifiers="0">26090</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-03-02T17:22:45.000Z" />
        <EventRecordID>11686</EventRecordID>
        <Channel>Application</Channel>
        <Computer>server.domain.COM</Computer>
        <Security />
      </System>
      <EventData>
        <Data>#26090 - An error occurred while opening mailbox mail.user@domain.com. Microsoft.Crm.Tools.Email.Providers.EmailException: No results were found.
       at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.IsCurrentUser()
       at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.GetService()
       at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.InitExchangeConnector()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()</Data>
      </EventData>
    </Event>

    • Edited by ctcG Wednesday, March 2, 2011 5:54 PM More info
    Wednesday, March 2, 2011 4:54 PM
  • I wonder if this article is relevant to your situation. Although it is refers to CRM 4.0 the actual issue is pertinent to Exchange.

    http://support.microsoft.com/kb/2190890

     

     

     

    • Proposed as answer by Jim Glass Jr Tuesday, July 26, 2011 3:52 PM
    Friday, March 4, 2011 4:44 AM
    Moderator
  • Thank you for the above link.  The address was hidden from the GAL.  I am now able to successfully test with the service account and it's queue.  However I am still not able to test with a user account using my service account.     I have granted the service account Full Access permission in Exhcange to my user account but the test still fails with: 

    Failure - The account does not have permission to impersonate the requested user. 

    Any ideas as to what rights may be missing?


    G
    Friday, March 4, 2011 7:59 PM
  • We are following this, and kind of wondering now if this is a bug?

    We had CRM 4.0 setup, with Exchange 2010 + Email Router. - This All worked fine (for years)

    We migrated to a new CRM and setup a new Email Router on that server. Using the same details for Exchange 2010 - with the updated new URL details for the CRM, we get an error: Incoming Status: Failure - No results were found.

    If we change the password to something invalid, the response is correctly: 

    Incoming Status: Failure - The remote Microsoft Exchange e-mail server returned the error "(401) Unauthorized". Verify that you have permission to connect to the mailbox. The request failed with HTTP status 401: Unauthorized. 

    So it is looking at least at the CRM user details to do something. 

    It is also worth noting, that the Exchange and CRM both have SSL certificates issued by a trusted authority. + That from the server, the URL for the exchange, does respond back with some "Blurb" when accessed with a users details. 

    + We have looked at the GAL issue (not a problem for us) Also a reminder that we had a working environment in 4.0 to the same mailboxes and same exchange server. The GAL issue would have failed there too if that was the problem.

    So something is a miss here...  We would welcome any suggestions as this one has already shaved a day off my life with little but frustration to show!

    Tuesday, July 26, 2011 3:23 PM
  • After much mucking around, we found our problem.

    In our instance the Default Global Address List had us listed, but our mailbox was tied to another custom address list, that was not listing our address correctly due to a typo. The access to the GA was being blocked by custom security settings.

    This comes back to the same post above. Although nothing to do with the check box about  “Hide from Exchange address lists” - we were in effect being hidden from the address list that mattered.

    Thursday, August 4, 2011 2:26 PM