locked
Better WPA2 Enterprise support? RRS feed

  • General discussion

  • I've had the same problem going from Windows Mobile 6.0 to 6.1 to 6.5 on different devices.

    At my university, Stockholms Universitet we have a wireless network shared with KTH, the Royal Institute of Technology. This network serves 15.000+ students (not all are going to connect to it obviously, but all have access if they need).

    The problem is that a Windows Mobile device cannot access the protected/automatically connecting versions of this network "KTHOPEN-WPA" or "eduroam". Windows Mobile users are forced to connect to a open version and log in using a web browser. If you really quickly want to check your schedule or something, this is of course far from ideal. Other devices like Symbian, iPhone etc can connect with a minimum of effort.

    I'm not an expert on WPA or network authentication but what I've worked out is that the network uses WPA2 Enterprise with PEAP and and authentication using a certifice. I'll post the instructions needed for connecting to it using a standard Windows XP PC (Windows 7 works simply entering username and password!)

    These instructions can be found here:
    http://www.lan.kth.se/kthopen/wpa/

    Instructions for standard microsoft driver

    1. Click on the wireless network icon in the bottom right corner of your screen. A dialog opens.
    2. Click the "Properties" button. A Properties dialog opens.
    3. Switch to the "Wireless Networks" tab.
    4. Click "Add...". A new dialog opens.
    5. Enter the following settings:
      • Network name (SSID): eduroam
      • Network Authentication: WPA2 (or WPA if there's no WPA2 in the list)
      • Data encryption: AES (if possible)
    6. Switch to the Authentication tab.
    7. Select "Protected EAP (PEAP)" in the "EAP type" box.
    8. Uncheck "Authenticate as computer ...".
    9. Click Properties. Another dialog opens.
    10. Find "GTE CyberTrust Global Root" in the list of certificate authorities and check the box next to it.
    11. Click the "Configure..." button. Uncheck "Automatically use my Windows logon ..." and click OK.
    12. Click OK in the rest of the dialog boxes to close them.
    13. Wait a little and a balloon will pop up in the bottom right corner saying "Click here to select a certificate or other ...". Click on the balloon. A dialog will open.
    14. Enter your username (e.g. nisse@kth.se) and the network secret you retreived from here . Leave the domain field empty. Click OK.
    15. You have now configured eduroam.

    If anyone against all odds has any suggestions on how to get this to work I'd be amazed. But if this could be put on a to-do list for Windows Mobile 7 I'd be happy enough.
    Wednesday, September 30, 2009 11:46 AM

All replies

  • I have the same problem. Any solutions?
    Monday, November 30, 2009 2:27 PM
  • This is still an unresolved problem /bug / missing feature and as far as I'm concerned we're lucky if it's sorted in Mobile 7.0, I wouldn't hold my breath though.
    Monday, November 30, 2009 9:57 PM