none
Office365 Admin center connection using IE 11/ EDGE

    Question

  • I manage multiple Office365 domains from my PC. Once I login as Admin of a domain (domain 1) and log out, I cannot connect to any other domains even if I use inPrivate Browser . I try login to domain 2, the system accepts my domain 2 credential and I get the domain 1 console. I check the login name every time I get into admin console, as changes could be made to the wrong domain due to this erratic behavior of IE/EDGE. Why does the system accept credential of domain 2 and take me into Domain 1 admin console? Can Microsoft not fix this? The recommendation I had from a Microsoft engineer in the past was that we need to clear cache everytime we exit admin console. This is not a realistic solution . I find Chrome works without an issue.

    MP

    Tuesday, November 8, 2016 2:26 PM

Answers

All replies

  • For O365 administration I'd ask over here.

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_o365admin?

     

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by mmpai Tuesday, November 8, 2016 2:33 PM
    Tuesday, November 8, 2016 2:29 PM
    Moderator
  • Thanks

    MP

    Tuesday, November 8, 2016 2:33 PM
  • You're welcome.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Tuesday, November 8, 2016 2:41 PM
    Moderator