locked
Cant Authenticate on Surface 8.1 CRM 2013 onPrem RRS feed

  • Question

  • Hi There - 

    I am working on an upgrade from CRM 2011 onPrem to CRM 2013 onPrem and I am working on getting the mobile piece working. I've installed SP1 as well as configured IFD successfully. On an Ipad3 I am able to authenticate to the site and use the mobile site. On a Surface however I am unable to authenticate. 

    I am asked to enter my companies web address which i do. I am then redirected and asked to connect to it. I hit Ok 3x (it wont let me through the first 2 times) I am then redirected to our ADFS login page where I type in my credentials and I get this error "we can't connect to the service you need right now. Check your network connection or try this again later"

    After "Binging" the error the documentation says IFD must not be enabled, but it is as I am able to login from outside the network with no VPN, and I'm able to access the application via Ipad. 

    I've made the registry changes outlined here and tried to enable the tracing outlined here but there is nothing in the logs after i reproduce the error. 

    Am I missing something here? I checked to make sure the app was not blocked via Firewall and confirmed as such. Any help would be greatly appreciated. 

    Thanks! 

    Wednesday, August 20, 2014 7:52 PM

Answers

  • There are at least 2 other steps you need to make.

    I think it is very poor that this documentation is scattered over various articles, not in one place.

    Note that the "Configure the OAuth provider" section does not need to be performed, that step is redundant.

    I couldn't get CRM for Android to work without doing the above 2 steps.

    • Proposed as answer by Caratacus Thursday, August 21, 2014 11:15 AM
    • Marked as answer by Alip85 Thursday, August 21, 2014 3:49 PM
    Thursday, August 21, 2014 11:15 AM

All replies

  • Hi Alip85

    Couple of questions for you.

    1. When you used the Ipad were you connected to the company network?

    2. Have you tried to authenticate using a laptop outside the network? EG: - connecting from home using a hope laptop using the internet connection at home( not using VPN)

    Thursday, August 21, 2014 4:55 AM
  • There are at least 2 other steps you need to make.

    I think it is very poor that this documentation is scattered over various articles, not in one place.

    Note that the "Configure the OAuth provider" section does not need to be performed, that step is redundant.

    I couldn't get CRM for Android to work without doing the above 2 steps.

    • Proposed as answer by Caratacus Thursday, August 21, 2014 11:15 AM
    • Marked as answer by Alip85 Thursday, August 21, 2014 3:49 PM
    Thursday, August 21, 2014 11:15 AM
  • Thank so much for your answer! I cant believe I missed that. Going to walk through those steps today and hopefully get all of my devices connected.

    Thanks again!

    Thursday, August 21, 2014 3:52 PM
  • Hello Alips85 and Caratacus,

    many thanks for using Microsoft Forums and Communities. I have read your post and wanted to add a short comment. Thanks for your feedback on the documentation Caratacus. We very much appreciate your feedback – it is critical for us and enable us to further improve and build best in class products and services.

    If you have a suggestion on improving the documentation, I would encourage you to log it at Microsoft Connect platform  https://connect.microsoft.com/ and provide insight to the Microsoft development community about it. Thank you very much in advance.

    If you have any questions, do let us know.

    Regards,

    Nina Peneva

    Microsoft Dynamics CRM

    Follow EMEA Microsoft Dynamics CRM Support on Twitter  https://twitter.com/MSDynCRMSupport

     

     


    Nina Peneva Support Engineer Microsoft Dynamics CRM Follow EMEA Microsoft Dynamics CRM Support on Twitter https://twitter.com/MSDynCRMSupport

    Monday, August 25, 2014 12:11 PM